[solved] Laptop boots into bios after install


I have a problem with my manjaro install after installing it onto my laptop it boots into bios instead of booting into the os. The only way i can boot into my os is if i leave the usb in and select "other efi devices". I tried updating it and it did not solve the problem. Reinstalling it also did not solve the problem. Even setting up manual partitions with a boot/efi partition selecting boot and esp does not work. I followed these instructions and it also did not work. Please help as i do not know what else to try :frowning:

Disk /dev/sda: 111.8 GiB, 120034123776 bytes, 234441648 sectors
Units: sectors of 1 * 512 = 512 bytes
Sector size (logical/physical): 512 bytes / 512 bytes
I/O size (minimum/optimal): 512 bytes / 512 bytes
Disklabel type: gpt
Disk identifier: 1809AA95-5D43-4BD1-AAD0-1D3C57DAD842

Device Start End Sectors Size Type
/dev/sda1 4097 618497 614401 300M EFI System
/dev/sda2 618498 198544564 197926067 94.4G Linux filesystem
/dev/sda3 198544565 234436544 35891980 17.1G Linux swap

can you return
with USB install sitck

efibootmgr -v

Are you hiding the complete output of "fdisk -l". A machine with 17 GB of swap and only a 120GB drive seems a litte unusual. Is this a dual boot?
Is secure boot turned on? If so, turn it of.

It is a 120g ssd. No dual boot, manjaro is the only os. Yes secure boot is off. I managed to find a solution for the problem via suggested topics :slight_smile: changed grubx64.efi to bootx64.efi, ran grub-install and that fixed the problem :slight_smile:

Thanks for this valuable information :slight_smile:

We don't delete threads with solutions on the forum. I'll remove that from your title. Nice work. :smile:

Should I rather give the solution in my first post as I had found it somewhere else on the forum? The reason, why I asked for the thread to be deleted, was before somebody could actually assist me I had found the solution.

Incomplete. There is no 'manjaro' bootentry in efibootmgr. It works because your system boots from device, that is bootx64.efi. There has to be another step to generate manjaro bootentry.

Will fail again or more accurately, whenever there is a manjaro revision of grub or kernels your bootx64.efi will still be the old grubx64.efi (unless you repeat this 'solution').

So why don't you show where you get this 'solution'. It;' okay, don't be shy.
Condescending? Yes. Sure!

1 Like

After running the command efibootmgr it shows manjaro in the list, where before it did not and rebooting the machine it boots into manjaro. I followed some of the instructions in this thread until it worked for me.

In that link, there is a further command
sudu efiboitmgr -c -d ***** /dev/sda 3 xxxx XXX
Do it.

I used this

sudo efibootmgr -c -d /dev/sda -p 1 -L “manjaro” -l "\EFI\Manjaro\grubx64.efi"

and when i run efibootmgr it shows manjaro twice the second one has funny characters next to it. I assume i should have put manjaro without the " "

how do i fix that?

That's because of this discourse forum.
It changes

" these apostrophes"

"these apostrophes"

Note carefully the appostrophes. in both cases.

You copied from the forum 'text' when you should copy from the text within the fences.
Or the link you refer to may not have the fences.
Use this first post instead. It also explains more comprehensively what your problem is and how to handle it. Note the commands are in the [Additional UEFI commands] section. You can copy from there but do not place them in the discourse forum to copy from. As mentioned, this forum converts the apostrophes to non-compliant linux formats.


Thank you for the tips @gohlip your thread is very informative :slight_smile:


This topic was automatically closed 30 days after the last reply. New replies are no longer allowed.

Forum kindly sponsored by