[SOLVED] Long delay and long slowness in the terminal, to open the pop-up menu or the app. Maybe because of the CPU warmness?

Hello,

I am using Manjaro KDE 18.0 on a damned Mac mini Mid 2011. Here, in Brazil, it is the summer now.

It takes among 30 seconds and 2 minutes to open the pop-up menu, the app and to run any command in the terminal.

  • inxi -Fxz:
System:    Host: gusbemacbe-macmini Kernel: 4.19.6-1-MANJARO x86_64 bits: 64 compiler: gcc v: 8.2.1 Desktop: KDE Plasma 5.14.4 
           Distro: Manjaro Linux 
Machine:   Type: Laptop System: Apple product: Macmini5,1 v: 1.0 serial: <filter> 
           Mobo: Apple model: Mac-8ED6AF5B48C039E1 v: Macmini5,1 serial: <filter> UEFI: Apple v: 130.0.0.0.0 date: 08/22/2018 
CPU:       Topology: Dual Core model: Intel Core i5-2415M bits: 64 type: MT MCP arch: Sandy Bridge rev: 7 L2 cache: 3072 KiB 
           flags: lm nx pae sse sse2 sse3 sse4_1 sse4_2 ssse3 vmx bogomips: 18366 
           Speed: 1057 MHz min/max: 800/2900 MHz Core speeds (MHz): 1: 921 2: 1106 3: 877 4: 928 
Graphics:  Device-1: Intel 2nd Generation Core Processor Family Integrated Graphics vendor: Apple driver: i915 v: kernel 
           bus ID: 00:02.0 
           Display: x11 server: X.Org 1.20.3 driver: modesetting unloaded: intel resolution: 1920x1080~60Hz 
           OpenGL: renderer: Mesa DRI Intel Sandybridge Mobile v: 3.3 Mesa 18.2.6 direct render: Yes 
Audio:     Device-1: Intel 6 Series/C200 Series Family High Definition Audio driver: snd_hda_intel v: kernel bus ID: 00:1b.0 
           Sound Server: ALSA v: k4.19.6-1-MANJARO 
Network:   Device-1: Broadcom and subsidiaries NetXtreme BCM57765 Gigabit Ethernet PCIe driver: tg3 v: 3.137 port: efa0 
           bus ID: 02:00.0 
           IF: enp2s0f0 state: up speed: 100 Mbps duplex: full mac: <filter> 
           Device-2: Broadcom and subsidiaries BCM4331 802.11a/b/g/n vendor: Apple AirPort Extreme driver: bcma-pci-bridge 
           v: N/A port: efa0 bus ID: 03:00.0 
           IF-ID-1: wlp3s0b1 state: down mac: <filter> 
Drives:    Local Storage: total: 465.76 GiB used: 73.06 GiB (15.7%) 
           ID-1: /dev/sda vendor: Hitachi model: HTS547550A9E384 size: 465.76 GiB 
Partition: ID-1: / size: 447.72 GiB used: 73.05 GiB (16.3%) fs: ext4 dev: /dev/sda4 
           ID-2: swap-1 size: 8.40 GiB used: 0 KiB (0.0%) fs: swap dev: /dev/sda2 
Sensors:   System Temperatures: cpu: 78.0 C mobo: N/A 
           Fan Speeds (RPM): N/A 
Info:      Processes: 202 Uptime: 1h 29m Memory: 7.70 GiB used: 2.64 GiB (34.3%) Init: systemd Compilers: gcc: 8.2.1 
           clang: 7.0.0 Shell: zsh v: 5.6.2 inxi: 3.0.27 
  • free -m
              total        used        free      shared  buff/cache   available
Mem:           7888        2613        1211         342        4063        4631
Swap:          8599           0        8599
  • sudo vmstat -s
      8077620 K total memory
      2652864 K used memory
      3464432 K active memory
      2994628 K inactive memory
      1243968 K free memory
       334272 K buffer memory
      3846516 K swap cache
      8806396 K total swap
            0 K used swap
      8806396 K free swap
        73057 non-nice user cpu ticks
        22925 nice user cpu ticks
        24634 system cpu ticks
      1774519 idle cpu ticks
       331451 IO-wait cpu ticks
         5899 IRQ cpu ticks
         2071 softirq cpu ticks
            0 stolen cpu ticks
      3189792 pages paged in
     12007561 pages paged out
            0 pages swapped in
            0 pages swapped out
      3108316 interrupts
      9723685 CPU context switches
   1544639443 boot time
        11587 forks
  • htop:

image

  • sensors:
sensors                                                                66  18:09:35  
applesmc-isa-0300
Adapter: ISA adapter
Exhaust  :   1807 RPM  (min = 1800 RPM, max = 5500 RPM)
TA0P:         +63.5°C  
TA0p:         +63.5°C  
TA1P:         +64.5°C  
TA1p:         +64.5°C  
TC0C:         +75.0°C  
TC0D:         +75.8°C  
TC0E:         +81.0°C  
TC0F:         +82.5°C  
TC0G:         +94.0°C  
TC0J:          +1.2°C  
TC0P:         +72.2°C  
TC0c:         +75.0°C  
TC0d:         +75.8°C  
TC0p:         +72.2°C  
TC1C:         +75.0°C  
TC1c:         +75.0°C  
TCGC:         +74.0°C  
TCGc:         +74.0°C  
TCPG:         +98.0°C  
TCSC:         +71.0°C  
TCSc:         +71.0°C  
TCTD:          -0.2°C  
TCXC:         +75.0°C  
TCXc:         +75.0°C  
TI0P:         +70.0°C  
TI0p:         +70.0°C  
TI1P:         +67.8°C  
TI1p:         +67.8°C  
TM0P:         +70.5°C  
TM0S:         +71.8°C  
TM0p:         +70.5°C  
TMBS:         +50.0°C  
TP0P:         +72.0°C  
TP0p:         +72.0°C  
TPCD:         +74.0°C  
TW0P:         +60.8°C  
TW0p:         +60.8°C  
Tp0C:         +58.0°C  

coretemp-isa-0000
Adapter: ISA adapter
Package id 0:  +81.0°C  (high = +86.0°C, crit = +100.0°C)
Core 0:        +81.0°C  (high = +86.0°C, crit = +100.0°C)
Core 1:        +78.0°C  (high = +86.0°C, crit = +100.0°C)

The exhaust should start speeding up, but probably does it when the CPU reaches 86.0°C
IF there is a way to change that (probably using the fancontrol-kcm), you can test if your theory is correct (and personally i think your theory is correct).

I installed fancontrol, and I ran it, but it gave an error:

fancontrol 
Loading configuration from /etc/fancontrol ...
Error: Can't read configuration file

Temps, even high, not critical. Why would you suspect that and not inspect the logs for errors?..

Just asking.. I hate Linux Macs! Good luck!

Hear, hear !
Macs have this feature by design, is suppose to remain quiet for as long is possible, that is why the fans start spinning faster only when reaches a higher CPU temperature, but in the same time has this thermal throttle that will reduce the multiplier to approximately 75% of its normal maximum value, and is happening before the fans start spinning faster.
In this case, when the core is at 81.0°C the frequency is lowered and will stay there till the temperature decreases, but it doesn't as the fan is still spinning at 1807 RPM ... A design flaw that apple refused to address :slight_smile:

Yeah, you will have to see if mbpfan is working with newer kernels, as it seems to be ok for your model.

1 Like

I would try to reduce the amount you are swapping to disk. Try reducing your swapiness factor to 10 to minimize the amount you are swapping.

Unless this has an SSD drive, swapping to disk will slow performance considerably.

Here is:

Starting the tests..
It is normal for them to take a bit to finish.
Error: max_fan_speed value is not 6200 
Tests run: 5

And

  • lsmod | grep -e applesmc -e coretemp
coretemp               16384  0
applesmc               24576  0
input_polldev          16384  1 applesmc

What is the article about it in the Arch Wiki?

There must be a way to set that manually to the correct value ... Maybe there is a tutorial somewhere.
For the swapiness se here
https://wiki.archlinux.org/index.php/Swap#Swappiness

Bizarre, here is:

cat /sys/fs/cgroup/memory/memory.swappiness                      145  05:55:19  
60

Is it good? As @tbg has suggested, do I must set to 100 or is 60 already good?

I attempted, but it failed:

Disk /dev/sda: 465.8 GiB, 500107862016 bytes, 976773168 sectors
Disk model: Hitachi HTS54755
Units: sectors of 1 * 512 = 512 bytes
Sector size (logical/physical): 512 bytes / 4096 bytes
I/O size (minimum/optimal): 4096 bytes / 4096 bytes
Disklabel type: gpt
Disk identifier: 1F8A0E99-0E9F-4E04-B265-9A95DA884D4E

Device         Start       End   Sectors   Size Type
/dev/sda1         34   1845247   1845214   901M Microsoft basic data
/dev/sda2    1845248  19458047  17612800   8.4G Linux swap
/dev/sda3  975503592 976773127   1269536 619.9M Apple boot
/dev/sda4   19458048 975503591 956045544 455.9G Linux filesystem

sudo swapon --priority 100 /dev/sda4                  SIG(127) ↵  151  06:19:42  
swapon: /dev/sda4: read swap header failed

Temporary:

sudo sysctl vm.swappiness=10

To set the swappiness value permanently, edit a sysctl configuration file

/etc/sysctl.d/99-sysctl.conf

Add the entry:

vm.swappiness=10

Reboot for the change to take effect permanently.

The information I just posted was on the Arch wiki link. Did you not read the Arch wiki page. Why should I have to parrot the Archwiki info when you should have read it yourself.

Good luck to you.

Ah, I am really sorry for this and for upsetting you, I will try to solve by myself alone without posting the next new requests. I will refrain from the forums.

You don't need to refrain from posting , just try to become more self sufficient. Don't constantly request others find stuff that you can easily find with a quick internet search. You've been on the forum a while now, just try to spend more time researching yourself, before you expect others to do for you.

1 Like

I researched by myself during days. I discovered the cause of slowness and warmness. It was Linux 4.19. By middle of the Arch Wiki, I switched from Linux 4.19 to 4.14, now the OS returned to the smoothness.

One of apps opens 3 seconds, the pop-up menu takes milliseconds and entering any command in the terminal takes milliseconds. Now very quick.

2 Likes

Very nicely done. See don't you feel a greater feeling of accomplishment for solving it on your own. Well done.

2 Likes

Do you have the power to close this thread as it is solved? I can not mark my own answer as solved because it is illegal according the rules of Manjaro Forum.

It's not illegal, it's just not looked favorably upon. I will mark it solved for you.

I did the same thing; but my only symptom was that any terminal took 10-20 seconds to open the first time, but (at least some) other programs were OK.

I guess the cause be the warmness or the swappiness. The most warm, the most slow. Maybe the thermical paste and the fan adding be the solution.

We do not know your computer specifications, but Apple computers are poorly designed due to the lack of fan and of thermal paste. I have to switch to a customised PC.

@tbg

In spite of Linux 4.14 being the solution and my workstation remained quick during several hours, but in the course of heating and also if you suspend or hibernate, the workstation becomes slower.

During hours I have researched, the final conclusion is that Apple computers' problem with overheating is fan control. As mine is a Mac mini, a lot of Mac mini users had problem with the overheating of Mac mini due to poorly design of fan control:

I have to follow some instructions at https://macpaw.com/how-to/how-to-fix-an-overheating-mac.

This topic was automatically closed 30 days after the last reply. New replies are no longer allowed.

Forum kindly sponsored by