[Solved] Lost internet after VirtualBox installation

I have a dual boot Laptop with Windows & Manjaro. But now I want to install Windows in VB on Manjaro host to be able to write in MSWord in my regional language, which others could edit on their systems which mostly house Windows OS. I had almost stopped using Windows but I will have to switch between the two OSes often times now. I want to get rid of the Windows OS on the other partition and have it on Manjaro itself.

Two days ago I installed VirtualBox-6 with these following commands that I copied from the Arch wiki and a couple of the Manjaro forum pages.

sudo pacman -Syu virtualbox linux54-virtualbox-host-modules

sudo vboxreload

sudo pacman -Syu

sudo systemctl enable vboxweb.service

sudo systemctl start vboxweb.service

lsmod | grep -i vbox

pamac build virtualbox-ext-oracle

sudo pacman -Syu virtualbox-guest-utils

sudo modprobe vboxdrv

sudo gpasswd -a $USER vboxusers

#Replace $User with your username#

sudo modprobe vboxguest vboxvideo vboxsf

sudo systemctl enable --now vboxservice.service

sudo gpasswd -a ak vboxsf

Everything went so smooth that I was delighted. But when I restarted; the internet was gone and got a Vbox kernel error. I took cue from a Manjaro forum page and uninstalled VB guest utils. But no use.

Right from then on I cannot connect to internet. The icon in the tray is gone. I used to connect to my Hotspot.

I searched the web for solutions for two days and tried everything possible, I suppose, with no effect. I even followed the instructions on the below site thoroughly, probably the best one;

https://linuxhint.com/arch_linux_network_manager/

When I start the system, I get an error message which says;

Failed to start modemmanager

Before I realized that I could tether my phone, I uninstalled Network-Manager and downloaded packages from the Archlinux website with the Antix OS live USB, and installed the tar packages offline by giving the command,

sudo pacman -U packagename

I even uninstalled VB, and the virtualbox-guest-utils, but no use.

I can connect to the internet on the same Laptop with other OS Windows. I can even connect to the internet on the same Laptop with Live USB sticks with Antix and Pricise Puppy on them. I can even connect to the internet on this very Manjaro system by tethering to my mobile phone, which I am doing right now.

I have attached the image file which shows what I did with CLI, to resolve the issue. I don't understand much about the commands I used. It was a blind game which I have won in the past some times.

NW issue resolution trials

I started the nmtui;

But alas, since I am a noob, I didn't understand anything of it. I tried to activate the connections in the Terminal-gui but it didn't respond. It sat idle.

As a last resort I came to the forum. Please help.

Thanks & Regards

This is the first time I hear installing VirtualBox should break the host internet connection.

I am 100% certain that the malfunctioning network is not caused by installing VirtualBox.

If you have used the recommended install command you will have issued a system update too.

sudo pacman -Syu virtualbox

It appears from your list of commands is the installation of guest utilities and activation of guest services on the host which also explains the vbox error message.

Please disable - on the host - the guest service and - on the host - uninstall guest-utils.

Hi linux-aarhus,

Thanks for coming.

May be you are right. This happened 2-3 times before too and not while installing VB. A long back once, about 7-8 months back once and a few days back while I was on Windows. The last time what I did was, I immediately switched to Manjaro to see if it works there or is it a Hardware issue. There too the same thing happened. Manjaro didn't connect to internet. Then I searched the web and gave the following commands;

sudo dhclient -r
sudo dhclient

and rebooted. The internet was back on both OSes. But this time it didn't happen that way. Internet is working on the other OS and the USB live OSes too but not on Manjaro. Here on Manjaro too, I can connect to my phone via USB tethering, but not the wifi or the ethernet.

I did it again now, and rebooted but the issue remains.

I forgot to mention earlier that once I uninstalled the guest utilities from the host Manjaro, the VB Kernel issue was resolved.

what is the output of this command

systemctl list-unit-files --state=enabled
$ systemctl list-unit-files --state=enabled
UNIT FILE                                   STATE   VENDOR PRESET
org.cups.cupsd.path                         enabled disabled     
autovt@.service                             enabled disabled     
avahi-daemon.service                        enabled disabled     
bluetooth.service                           enabled disabled     
cronie.service                              enabled disabled     
dbus-fi.w1.wpa_supplicant1.service          enabled disabled     
dbus-org.bluez.service                      enabled disabled     
dbus-org.freedesktop.Avahi.service          enabled disabled     
dbus-org.freedesktop.ModemManager1.service  enabled disabled     
dbus-org.freedesktop.NetworkManager.service enabled disabled     
dbus-org.freedesktop.nm-dispatcher.service  enabled disabled     
dbus-org.freedesktop.timesync1.service      enabled disabled     
display-manager.service                     enabled disabled     
getty@.service                              enabled enabled      
lightdm.service                             enabled disabled     
ModemManager.service                        enabled disabled     
NetworkManager-dispatcher.service           enabled disabled     
NetworkManager-wait-online.service          enabled disabled     
NetworkManager.service                      enabled disabled     
org.cups.cupsd.service                      enabled disabled     
systemd-timesyncd.service                   enabled enabled      
tlp.service                                 enabled disabled     
lines 1-23

No screenshots please.

Just the text - format it using the </> in the toolbar


I think you may be missing the dhcpcd service

sudo systemctl enable --now dhcpcd
$ sudo systemctl enable --now dhcpcd
[sudo] password for XX: 
Failed to enable unit: Unit file /etc/systemd/system/dhcpcd.service is masked.

Why have you masked that?

sudo systemctl unmask dhcpcd

If you are using a static IP address then you usually disable the service but mask it - not for this service.

And if you are using a static IP - then you need to specify gateway and netmask otherwise your network won't work.

1 Like

Oops! I did it taking cue from some web suggestions...


[XX@XX-RV509 ~]$ sudo systemctl unmask dhcpcd
Removed /etc/systemd/system/dhcpcd.service.
[XX@XX-RV509 ~]$ sudo systemctl enable --now dhcpcd
[XX@XX-RV509 ~]$ systemctl list-unit-files --state=enabled
UNIT FILE                                   STATE   VENDOR PRESET
org.cups.cupsd.path                         enabled disabled     
autovt@.service                             enabled disabled     
avahi-daemon.service                        enabled disabled     
bluetooth.service                           enabled disabled     
cronie.service                              enabled disabled     
dbus-fi.w1.wpa_supplicant1.service          enabled disabled     
dbus-org.bluez.service                      enabled disabled     
dbus-org.freedesktop.Avahi.service          enabled disabled     
dbus-org.freedesktop.ModemManager1.service  enabled disabled     
dbus-org.freedesktop.NetworkManager.service enabled disabled     
dbus-org.freedesktop.nm-dispatcher.service  enabled disabled     
dbus-org.freedesktop.timesync1.service      enabled disabled     
dhcpcd.service                              enabled disabled     
display-manager.service                     enabled disabled     
getty@.service                              enabled enabled      
lightdm.service                             enabled disabled     
ModemManager.service                        enabled disabled     
NetworkManager-dispatcher.service           enabled disabled     
NetworkManager-wait-online.service          enabled disabled     
NetworkManager.service                      enabled disabled     
org.cups.cupsd.service                      enabled disabled     
systemd-timesyncd.service                   enabled enabled      
lines 1-23

No, I am not using a static IP.

Well - I think we have found the culprit then.

If you don't have a dhcp client running your network will never come up.

1 Like

What is it? I am desperate, on this side, to know and learn.

Why do I not have a dhcp client? I didn't remove/disable it on purpose.

That maybe but when you mask a service you are effectively disabling it.

So one thing to learn from this is - never blindly execute commands when you have no understanding of what it does.

But I only masked it while trying to resolve it taking suggestions from the web. When the internet connection failed, it was not masked. Now what? Since I have unmasked it, should the net get connected? What have I to do next?

Very true. I did it out of desperation, not willing to leave anything without trying.

check you device is up (look for state UP)

ip link

check your addresses (look for inet x.y.z.ip/x)

ip a
$ ip link
1: lo: <LOOPBACK,UP,LOWER_UP> mtu 65536 qdisc noqueue state UNKNOWN mode DEFAULT group default qlen 1000
    link/loopback 00:00:00:00:00:00 brd 00:00:00:00:00:00
2: enp0s29u1u5: <BROADCAST,MULTICAST,UP,LOWER_UP> mtu 1500 qdisc fq_codel state UNKNOWN mode DEFAULT group default qlen 1000
    link/ether 72:f0:c8:20:4a:a6 brd ff:ff:ff:ff:ff:ff

$ ip a
1: lo: <LOOPBACK,UP,LOWER_UP> mtu 65536 qdisc noqueue state UNKNOWN group default qlen 1000
    link/loopback 00:00:00:00:00:00 brd 00:00:00:00:00:00
    inet 127.0.0.1/8 scope host lo
       valid_lft forever preferred_lft forever
2: enp0s29u1u5: <BROADCAST,MULTICAST,UP,LOWER_UP> mtu 1500 qdisc fq_codel state UNKNOWN group default qlen 1000
    link/ether 72:f0:c8:20:4a:a6 brd ff:ff:ff:ff:ff:ff
    inet 192.168.42.114/24 brd 192.168.42.255 scope global dynamic noprefixroute enp0s29u1u5
       valid_lft 3490sec preferred_lft 3490sec

This looks like a tethered android - am I right?

If I am right - then you have no network interfaces on the system.


I don't think it is possible to guide you to a solution - you have made so many changes - it is impossible to know what has gone awry.

1 Like

Yes, I have tethered my android, but I can't confirm, if it is that.

Oh god, please, no.

Forum kindly sponsored by