[SOLVED] Manjaro and zfs?

Hey all,
I'm new to Manjaro. I have a machine that is currently running Mint that I'd like to switch over to manjaro. The only issue that I have is that the machine currently has three drives. One for the OS (not a vdev), and two that I use for storage configured as a raidz1. I don't have the data backed up, and it's not mission critical data, but I was really hoping to just avoid wiping it all, and just import the pool into Manjaro and continue to use it as a storage pool.

I went through the wiki before and just had a hard time getting zfs installed and working. I started googling and I ended up with conflicting instructions and whatnot. My google searches typically led me to responses on how to get manjaro installed ON the vdev. That's not what I want. I want manjaro on it's separate drive, and then to import my storage vdev after the fact. I guess I'm just looking for a couple clear answers/guidance.

  1. Can I just install zfs once manjaro is installed and import my current vdev?
  2. If someone here has done this, could you post a quick little guide, as I found the wiki instructions to not work as intended.

Thanks,
-RYknow

2 Likes

I have zfs running on manjaro. Very easy. You just neeed to install the zfs packages from the manjaro repo. Dont forget to install the zfs-utils as well.

You also want to enable a few zfs related systemd services to autoimport your pool. I can not recall right now which those are. I can tell you when I am back home.

Ok, so I'm going to assume I missed something simple then. I'm new to pacman... and while I get that the commands are there (per the wiki), it's just different to me. haha. I'll give it another shot.

You need to have the zfs extramodules installed, linuxXX-zfs and linuxXX-spl.
From then, it should work quite easily.

Yes.

  1. Install Manjaro
  2. pacman -S linux**-zfs
  3. zpool import poolname
1 Like

Here we go. This is what I have installed.

I have two kernels installed: linux414 and linux419
linux414 is my main kernel at the moment but linux419 is working just fine with zfs as well.

And along with that:

linux414-zfs 0.7.12-2
linux419-zfs 0.7.12-2
zfs-utils 0.7.12-1
linux414-spl 0.7.12-2
linux419-spl 0.7.12-2
spl-utils 0.7.12-1

And I have the following services enabled:

7# systemctl list-unit-files | grep enabled | grep zfs
zfs-import-cache.service                                         enabled        
zfs-mount.service                                                enabled        
zfs-zed.service                                                  enabled        
zfs-import.target                                                enabled        
zfs.target                                                       enabled
2 Likes

You need to find your kernel version after installing. In this example, lets assume it is 4.19.x.

Install zfs:

sudo pacman -S linux419-zfs

Replace 419 with something appropriate for the kernel you are running. This as should bring along everything else you need as dependencies.

Import your existing zfs pool:

sudo zpool import <poolname>

Enable the appropriate zfs services:

 systemctl enable zfs.target
 systemctl enable zfs-import-cache
 systemctl enable zfs-mount
 systemctl enable zfs-import.target

If you don't have any filesystems mounted by zfs you only need the first one above. The others enable the automatic mounting of zfs filesystems.

If you do need/want zfs mounting you should also create an initial zpool cache file

 sudo zpool set cachefile=/etc/zfs/zpool.cache <poolname>

zfs on Manjaro is really very straightforward.

2 Likes

This worked perfectly. Thank you!

1 Like

I added the cache file as you suggested! Thanks!

1 Like

I was able to migrate my pool from my Gentoo system with no issues at all, thank you.

One item I was wondering about is does anything need to be done when there is a kernel update (which was an issue in Gentoo)?

No, the zfs modules should get updated with the kernel. Also, if you use the manjaro tools to install additional kernels they will automatically bring in the zfs modules once you have them installed.

If it is only a data volume that should be all there is to it.

If you are booting off zfs and using grub, you will probably need to add ZPOOL_VDEV_NAME_PATH=YES into your environment somehow.

This topic was automatically closed 90 days after the last reply. New replies are no longer allowed.

Forum kindly sponsored by