[Solved] Manjaro KDE Testing 18.0.4 - Latte Dock error

On any clean installation I get the following error on boot. Ok makes it go away, but is there something in the initial config that needs to change so it doesn't happen in the first place, much less fix the existing config?
Screenshot_20190413_230214

Hi,
First try would be clearing your session if you are using 'saved session's
(the thing that opens the same windows you had open before logging out)
There is also a dedicated lattedock thread here on the forums that the developer is active in, so you might find some info there:
Latte Dock is pretty awesome
Oh, actually looks like this is related:
Environmental variables / latte-dock wont save layout

thanks, I will check that out. Main reason for posting was this error is on every default install of that testing build.

:thinking: But latte dock doesnt come installed by default...

Anyhoo - just checking, which version of latte? from the repos or aur? git ?

and are you all up to date?

sudo pacman-mirrors -f && sudo pacman -Syyuu

It does on the KDE testing build: Manjarowish kde plasma full with all kde-applications and kernel 5.0 and kv arc dark theme

Error is on initial boot of the 18.0.4 build of that, and continues after fully updating. (Good to ask though!)

That isnt [official] manjaro.
That is some users personal spin.
[notice the category - Unofficial Spins]

Which is fine to use, if you want, if you trust that person, blah blah.

Just letting you know :wink:

Seeing as it was an official Manjaro announce, not sure what you mean...?

No it wasnt. Where exactly on twitter or elsewhere do you see a link to 'manjarowish' or that thread you posted?

That twitter post points to here:
https://manjaro.org/download/kde-preview/
which is official, but dated, as 18.04 is already released and stable.

That twitter post is a couple of months old.

Here is the latest kde edition:
https://osdn.net/projects/manjaro/storage/kde/18.0.4/manjaro-kde-18.0.4-stable-x86_64.iso

Hmmm correct. Odd, that original post did NOT link to that...

Original twitter post linked to this: manjaro-kde-18.0.4-testing-x86_64.iso

18.0.4 has passed testing at this point. It is now stable.

Which, again, would be official, if it still existed,
and has nothing to do with 'manjarowish'

.. I really am at a loss as to how you ended up downloading THAT thinking it was official.

In any case .. things should work .. else your profile/session is messed up, lattedock has a bug, or the 'wish' has a bug.

Given that last one, its hard to have a common starting point... but from what I can see from the avid lattedockers we have around .. you might be the only one experiencing this issue at the moment.

Who knows, I dont use it :blush:. Maybe someone else who does will know more.

Umm, when the official chan tweets this: https://manjaro.org/download/kde-preview/

and links to a variation off of their site, now showing an RC, but still testing: https://osdn.net/dl/manjaro/manjaro-kde-18.0.4-rc-testing-x86_64.iso

How would you not assume its legit?

Again, all of those are/would be fine (besides the fact that you chose a rather OLD announcement)
The question is how you ended up HERE:

Manjarowish kde plasma full with all kde-applications and kernel 5.0 and kv arc dark theme

Because there are NO official links leading there.

Really, sorry if I am being confusing here! Thought I was noting an issue with a testing build, but apparently its more dated than I thought, though haven't actually solved the error myself yet, minor as it is.

For clarification, chain of events:
Saw this twitter post: https://twitter.com/ManjaroLinux/status/1099747899691450368
Downloaded this iso: manjaro-kde-18.0.4-testing-x86_64.iso
Installed in virtual and tested for a month. Installed as host on a laptop, still receive that error with that specific install media.
Get the above mentioned latte dock error on boot. Even after fully updating as of Apr 14, 2019. Basis of the post was still getting the error even after updating and versions rolled, hoping to help others out, or identify something I missed.

I assume that on the basis of above this came from official install media, but perhaps a not widely used one?

This is the problem. You probably downloaded this one:
https://sourceforge.net/projects/manjarowish/files/manjarowish-kde-plasma-dark/18.0.4/manjaro-kde-18.0.4-testing-x86_64.iso/download

While the filename is manjaro-kde-18.0.4-testing-x86_64.iso, it is not the official ISO. It is a user's personal spin. He just used the same filename.

As far as I know, latte-dock isn't on the official ISOs so it would be weird to get a latte error from an official ISO.

In order to check this, compare the size of the ISOs. ManjaroWish includes a lot of extra apps so the ISO should be bigger than an official ISO.

Hmmm ok, interesting. What I clicked on a month ago doesn't seem to be taking to the same spot, nor the linked article in the original post (mentioning wish), which seems to be the iso I downloaded, doesn't seem to be the official one. This does really help, and explains why an odd error is happening on boot in a testing (vs unstable) build.

1 Like

You are absolutely correct. Unsure how I got the wish version from the original twitter link, but the iso I originally downloaded is 4.1gb. Comparing that to the official location ( https://osdn.net/projects/manjaro/storage/kde/18.0.4/ ), coming in at 1.9gb... no wonder I am finding odd quirks.

Would you recommend reinstalling with one of the official stable, testing, or dev builds? The build is nice, but explains a few things.

It is up to you. I am sure the issues are fixable if you want to stick with what you have installed. I do think you would get a better feel for what Manjaro is by starting with an official build and experimenting with spins after that.

Forum kindly sponsored by