[SOLVED] Massive issues upgrading to 17.0.1

This update did not go smoothly. Besides breakages around the switch to elogind, which were resolved using additya's guide on upgrading, once the update finally went through, I am left with several issues:

  1. No privilege escalation is possible for desktop applications. I.e., "Open as root" in the file manager no longer does anything, pamac fails with "Authentication failed" on trying to install anything.
  2. Pulseaudio no longer starts, it complains about a missing service module to consolekit, which is no longer installed.
  3. No audio controls are available

As for issue 1, I followed instructions on the forum to make sure that /etc/pam.d config files reflect the change to elogind. No luck.

As to 2. and 3., I have currently no idea. Removing pulseaudio is not an option, as it would remove about half of my system. aplay -L shows the sound devices are there.

System is using lightdm desktop manager and Cinnamon desktop.

I am sure I need to provide more information and I am happy to do so. If you are willing to help, just let me know what information is needed.

Maybe start with the output of rc-status -a and the exact error you get from pulseaudio --start

1 Like

Hello cimmarrononline,


rc-status -a output:

Runlevel: nonetwork
 local                                                                                                                                                [  started  ]
Runlevel: default
 dbus                                                                                                                                                 [  started  ]
 NetworkManager                                                                                                                                       [  started  ]
 netmount                                                                                                                                             [  started  ]
 syslog-ng                                                                                                                                            [  started  ]
 acpid                                                                                                                                                [  started  ]
 xdm                                                                                                                                                  [  started  ]
 alsasound                                                                                                                                            [  started  ]
 bluetooth                                                                                                                                            [  started  ]
 cronie                                                                                                                                               [  started  ]
 cupsd                                                                                                                                                [  started  ]
 local                                                                                                                                                [  started  ]
Runlevel: boot
 hwclock                                                                                                                                              [  started  ]
 swap                                                                                                                                                 [  started  ]
 modules                                                                                                                                              [  started  ]
 fsck                                                                                                                                                 [  started  ]
 root                                                                                                                                                 [  started  ]
 mtab                                                                                                                                                 [  started  ]
 localmount                                                                                                                                           [  started  ]
 procfs                                                                                                                                               [  started  ]
 binfmt                                                                                                                                               [  started  ]
 hostname                                                                                                                                             [  started  ]
 urandom                                                                                                                                              [  started  ]
 sysctl                                                                                                                                               [  started  ]
 bootmisc                                                                                                                                             [  started  ]
 termencoding                                                                                                                                         [  started  ]
 keymaps                                                                                                                                              [  started  ]
 loopback                                                                                                                                             [  started  ]
 net.lo                                                                                                                                               [  started  ]
Runlevel: shutdown
 killprocs                                                                                                                                            [  stopped  ]
 savecache                                                                                                                                            [  stopped  ]
 mount-ro                                                                                                                                             [  stopped  ]
Runlevel: sysinit
 sysfs                                                                                                                                                [  started  ]
 devfs                                                                                                                                                [  started  ]
 kmod-static-nodes                                                                                                                                    [  started  ]
 udev                                                                                                                                                 [  started  ]
 dmesg                                                                                                                                                [  started  ]
 udev-trigger                                                                                                                                         [  started  ]
Dynamic Runlevel: hotplugged
Dynamic Runlevel: needed/wanted
 avahi-daemon                                                                                                                                         [  started  ]
 rpcbind                                                                                                                                              [  started  ]
 rpc.statd                                                                                                                                            [  started  ]
 rpc.pipefs                                                                                                                                           [  started  ]
 rpc.idmapd                                                                                                                                           [  started  ]
 nfsclient                                                                                                                                            [  started  ]
 xdm-setup                                                                                                                                            [  started  ]
 modules-load                                                                                                                                         [  started  ]
Dynamic Runlevel: manual

pulseaudio --start output:

pulseaudio --start
E: [pulseaudio] main.c: Daemon startup failed.

Output for "pulseaudio" without options or switches:

E: [pulseaudio] module-console-kit.c: GetSessionsForUnixUser() call failed: org.freedesktop.DBus.Error.ServiceUnknown: The name org.freedesktop.ConsoleKit was not provided by any .service files
E: [pulseaudio] module.c: Failed to load module "module-console-kit" (argument: ""): initialization failed.
E: [pulseaudio] main.c: Module load failed.
E: [pulseaudio] main.c: Failed to initialize daemon.

Looks like elogind was never started. Try sudo rc-service elogind start and see if anything works better.


That worked and solved both issues. Now the question: how can I make sure that elogind is started on system boot? I had rebooted my system several time, apparently elogind never started successfully.

Have you tried adding it?

sudo rc-update add elogind default

That worked, elogind is now started on boot. No idea why it was not added during installation.

Thanks again to thefallenrat and cimarrononline for the help. Much appreciated!

This topic was automatically closed 30 days after the last reply. New replies are no longer allowed.

Forum kindly sponsored by