SOLVED / My new Linux Manjaro 19 system / wifi support / Missing or only not visible ?

Dear Manjaro mates,

I' can't see any wifi network from my fresh Manjaro 19 System on Lenovo 340 laptop, I installed it from a live USB flash mem disc over LAN connection some days ago.

Yesterday I tried to activate the wifi from Panel and via

Manjaro Menu -> Settings -> Advanced Network Config

: nothing reminiscent of wifi only the VPN or ethernet stuff was visible, as if the installer had ignored the existence of the wifi hardware of my PC.

Actually only the LAN connects me.

Before getting into the longish kernel and system config described in [SOLVED] RTL8821CE Wi-Fi not working and hoping it would be overkill in my situation:

is there a simple way to use the wifi hardware in case it is already supported by my Manjaro system ? For example I tried also with

# nmcli dev wifi list 
# 

, unftly any output is missig.

Any suggestion for using the wifi support in case it has been installed ?

Thank you

Groen

PS I got

hwinfo --netcard --bluetooth

[...]

14: PCI 100.0: 0280 Network controller
  [Created at pci.386]
  Unique ID: VCu0.e_pxpmpLJP8
  Parent ID: 1GTX.Ijneoxq_8yF
  SysFS ID: /devices/pci0000:00/0000:00:1d.0/0000:01:00.0
  SysFS BusID: 0000:01:00.0
  Hardware Class: network
  Model: "Realtek RTL8821CE 802.11ac PCIe Wireless Network Adapter"
  Vendor: pci 0x10ec "Realtek Semiconductor Co., Ltd."
  Device: pci 0xc821 "RTL8821CE 802.11ac PCIe Wireless Network Adapter"
  SubVendor: pci 0x17aa "Lenovo"
  SubDevice: pci 0xc024 
  I/O Ports: 0x4000-0x4fff (rw)
  Memory Range: 0xa1200000-0xa120ffff (rw,non-prefetchable)
  IRQ: 11 (no events)
  Module Alias: "pci:v000010ECd0000C821sv000017AAsd0000C024bc02sc80i00"
  Config Status: cfg=new, avail=yes, need=no, active=unknown
  Attached to: #21 (PCI bridge)

When you have such issue - there is no easy way - look over some of the other topics

The problem is SOLVED, I'm writing you all over my brand new wifi connection right now !!!


Thank you linux-aarhus , after your advice I accepted the challenge of doing my first not-simple kernel maintenance under Manjaro.

It took time, I think next time I install Manjaro I won't connect to LAN in order to tell the installer to include wifi support.

Unftly your link omits the final cml invocations towards the happy end , I got spells at [SOLVED] RTL8821CE Wi-Fi not working ...

... but it was hard, I had to try and retry with mistakes ... to be honest my adventure was more complicated than below where I try to produce a simpler fairy tale with all necessary commands, and where I pretty pretend to know what I'm doing :slight_smile:


I wanted to look at the hardware with some cool inxi cml, but I don't remember a full invocation spell thus I skipped this step.

I said as a normal user

$ sudo bash

, after this I was like root.

Then I looked for the exact kernel version :

# uname -a
Linux colibri-96840 5.4.36-1-MANJARO #1 SMP PREEMPT Wed Apr 29 18:47:01 UTC 2020 x86_64 GNU/Linux

Here I ran pacman -S linux54-headers , but before saying Yes I checked that '5.4.36-1' is exactly the same current kernel version above

# pacman -S linux54-headers 
resolving dependencies...
looking for conflicting packages...

Packages (1) linux54-headers-5.4.36-1

Total Download Size:    9.42 MiB
Total Installed Size:  47.31 MiB

:: Proceed with installation? [Y/n]

Yes! :slight_smile:

:: Retrieving packages...
 linux54-headers-5.4.36-1-x86_64                                     9.4 MiB  11.3 MiB/s 00:01 [########################################################] 100%
 [...]

I installed trizen :

# pacman -S trizen base-devel --needed 
warning: autoconf-2.69-7 is up to date -- skipping
[...]

SURPRISINGLY THE NEXT COMMAND LINE FAILED AS ROOT, I had to run it as a normal user WITHOUT SUDO :

Dont root! Dont sudo!! Be a normalo here !!!

    $ trizen -S rtl8821ce-dkms-git --noconfirm

Installing dkms ...

$ sudo pacman -S dkms

... enjoying it :

$ dkms status
rtl8821ce, 1.0.5.r95.g69765eb, 5.4.36-1-MANJARO, x86_64: installed

Before rebooting I updated the boot subsystem ("mkinitcpio is a Bash script used to create an initial ramdisk ) :

$ sudo depmod -a
$ sudo mkinitcpio -P

Btw before rebooting I tried to run soon the new piece of kernel with

# modprobe rtl8821ce

but this failed , kinda the file of the driver rtl8821ce was kinda missing nevertheless ...

... nevertheless after rebooting the notebook the problem was over I could immediatly enjoy my first wifi connection with my Manjaro system -- I' m writing over it right now :slight_smile:

1 Like

A word about my hardware / It's the

    Lenovo V340-17IWL 
    Model name: 81RG
    81RG000SGE

The price was only 360 EUR two months ago, but I added mless 100 EUR for having 20GB RAM instead of 4GB. No MS Windows included.

To be sure to have a hardware highly compatible with linux I bought it at a online shop known for preinstalled linux.

The PC is really good, my emacs + browsing experience really cool and fast, maybe a little flaw is only the 1600 x 900 res, nevertheless the 17,3" Display is good for watching video. A DVD burner is shipped.

Some specs:

Series Lenovo V340

Color: Grey

20 GB RAM DDR 4 (2400 MHz)

Price ~ 460 EUR , as of 2020-03

Display 43,9 cm (17,3 Zoll) 1600 x 900 Pixel Anti Glare

IntelĀ® UHD Graphics 610

DVD burner

HDD 1 TB 2.5", via SATA, HDD, 5400 rpm

Processor IntelĀ® PentiumĀ® Gold 5405U
2 Core
Whiskey Lake
300 MHz
4 Threads
Boost 2500 MHz

1x HDMI , 1x RJ-45, 2x USB-A 3.2 (5 Gbit/s), 1x USB-C 3.2 (5 Gbit/s)
USB 3.2 Gen 1 it' s more or less the older USB 3.1 Gen 1 or USB 3.0

1 Webcam

Audio 2.0 Channel
SoundChip Dolby Audio Premium
Microphone

LAN 10/100/1000 MBit/s
WLAN Wi-Fi 5 (802.11ac)
Bluetooth 4.1

Trusted Platform Module (TPM)

Li-Ion (36 Wh) Battery
45 Watt power supply

413 mm x 24,3 mm x 284,6 mm
2,8 kg

And a word about the shop : ixsoft.de

They don't have US keyboards, I got a german one.

This topic was automatically closed 30 days after the last reply. New replies are no longer allowed.

Forum kindly sponsored by