[SOLVED] Network Manager not starting after update; libicuuc.so.58 seems to be cause

Afer the last update I cannot boot into desktop environment.

The error message says that NetworkManager failed to start.

I can get hold of a console and run
journalctl -u NetworkManager

In it there is one unusual line which goes like this:
/usr/bin/NetworkManager: error while loading shared library: libicuuc.so.58: cannot open shared object file: No such file or directory

What should I do? I have no network connection on this machine and I am not really savvy when it comes to mounting usb drives.

I'm kinda out of my competence zone here and very close to turning my back on Linux again, cause I am just too frustrated by it. I spent a couple of hours searching forums, but I have gotten no further. Help would be appreciated.

plz install downgrade

sudo pacman -S downgrade

and do downgrade networkmanager from 1.8.0 to .1.6.x

sudo downgrade networkmanager

you will be asked for a number for version to failback

@loquito said he doesn't have internet connection, how can he install anything with pacman -S ?(no offence)

ok, to downgrade (if it is the solution), look for networknanager version in /var/cache/pacman/pkg

then you have to type in a terminal
sudo pacman -U /var/cache/pacman/pkg/networkmanager-1.X.X.X.X.X the version you need

tips, you can use TAB to auto complet

if you can try to plug your computer to ethernet could be really nice
and do
wget -c http://manjarolinux.polymorf.fr/stable/core/x86_64/icu-59.1-1-x86_64.pkg.tar.xz
and then sudo pacman -U icu-59.1-1-x86_64.pkg.tar.xz

if you can't.

plug your stick with the package,

on a tty log in and do
ls /dev/sd*
it will list all the avalable drive, if you have only one hdd(or ssd) they will appear as sda(1-9) number depend on the numbers of partition you have

the you know your usb stick will be sdb*

then you do mount /dev/sd** /mnt/usb/

cd /mnt/usb/

then pacman -U icu.59.XX.XX.XX

and should be ok

Downgrading (from local cache) did not work. I downgraded from 1.6.2 to 1.6.0 and then to 1.4.? ; I stopped at that version and went back up to 1.6.2;

Thanks for the suggestion though

I did the USB steps. It didn't change the problem though.

Are you sure about the ice-59 bit in the URLs?

I'm just asking, because what is missing is the libicuuc.so.58 file and 58 and 59 are suspiciously close to one another. I also tried guessing the URL, but the 58 one isn't in that path. I tried other URL roots after searching the internet, but I couldn't find it yet. And maybe i'm just misled and the 58/59 thing is just a coincidence.

Thanks for the suggestion, though. If you have any follow up ideas, I would be happy to try them.

And I will fetch my old ethernet cable from the attic and scramble my router from behind the cupboard to establish an ethernet connection :slight_smile:

You're going about it the wrong way. ICU got updated from version 58 to version 59. That's why you can't find 58, it's obsolete. What you need is networkManager that works with version 59 of ICU library. Which should be the one currently in the Manjaro repos. The state of your system indicates you've started an update and then somehow interupted it before it finished updating all the components; that's why you're stuck with old networkManager that doesn't work with ICU version 59.

1 Like

i assumed you have a x86-64
maybe you have icu-58 in /var/cache/pacman/pkg

but like said, this package is used for many things, if you can have a ethernet connection, just upgrade and should fix all
or you can try to chroot (a little more tricky and time consuming)

download a live version of manjaro and do

once you have the terminal(on step 6) do a sudo pacman -Syyu

it will update your missing package.

ok, thanks everybody for the suggestions. Nice community!

Forum kindly sponsored by