[SOLVED] Network manager shows limited connectivity

This is happening on all three of my Manjaro KDE desktops with intel gigabit ethernet cards on the same network.

nmcli -f all general

running  1.20.0   connected (site only)  started  limited       enabled     enabled  disabled  enabled  enabled

Sorry for the above paste from the terminal. You can see "limited" under connectivity.

The network manager plasma icon has a red circle with a line through it.

My internet seems to be working fine on all three machines despite these errors but perhaps it is underfunctioning and I'm not able to notice it.

Anyone know how to fix this issue?

Update: I use Mullvad commercial VPN service and the error disappears when I disconnect from the VPN so we're trying to figure out if my ISP is throttling my connection when connected to the VPN vs. degraded performance due to the VPN connection.

Did you disable or block the Network Manager connectivity check?

1 Like

If I did do that, I didn't do it knowingly since I'm not sure what the connectivity check is. It is happening on all three desktop machines with KDE connected through ethernet. I did some searching on network manager connectivity check but couldn't find anything.

One of the machines is a fresh install about a week ago and I know I didn't change anything in the network settings on that machine for sure.

Any other ideas why this is showing up on all three of my Manjaro KDE desktops?

Perhaps you might be willing to help us help you.

1 Like



I made the adjustment to the code. Anything else not clear?

I'll try downgrading since I'm using v1.20. I'm not sure how to downgrade but I'll do some research on it.

I made some small progress by setting the DNS to my router to my default settings rather than Cloudflare and now I don't get the error until the machine has be running for about one minute. After a minute or so the red circle appears on the tray icon. Strange.

Please post:

inxi -Fxxxz
cat /etc/resolv.conf

I have gotten closer to figuring this out. I use Mullvad commercial VPN service on all my machines and I figured out that if I disconnect from the VPN the connectivity issue goes away in about a minute. The question is whether or not my ISP is throttling my traffic when connected to the VPN or if it is just limited connectivity due to the VPN.

I did a test with traceroute to try and figure this out:

Traceroute connected to VPN:

traceroute to google.com (, 30 hops max, 60 byte packets 1 ( 27.952 ms 27.913 ms 27.891 ms 2 ( 27.923 ms 28.049 ms 28.183 ms 3 vl82.br02.atl02.as46562.net ( 27.724 ms 27.757 ms 27.737 ms 4 aix.pr1.atl.google.com ( 27.719 ms 27.761 ms 27.651 ms 5 ( 27.913 ms ( 27.677 ms ( 27.656 ms 6 ( 28.141 ms ( 21.011 ms ( 21.908 ms 7 ( 20.954 ms ( 28.469 ms ( 20.960 ms 8 ( 22.792 ms ( 23.219 ms ( 21.853 ms 9 * * * 10 * * * 11 * * * 12 * * * 13 * * * 14 * * * 15 * * * 16 * * * 17 * * * 18 ( 21.610 ms 21.606 ms 21.652 ms

Traceroute disconnected from VPN:

traceroute to google.com (, 30 hops max, 60 byte packets 1 _gateway ( 0.263 ms 0.261 ms 0.335 ms 2 * * * 3 96-34-95-2.static.unas.la.charter.com ( 17.000 ms 17.498 ms 17.564 ms 4 crr01spbgsc-bue-202.spbg.sc.charter.com ( 22.478 ms 22.465 ms 21.463 ms 5 bbr01spbgsc-bue-3.spbg.sc.charter.com ( 27.375 ms 23.437 ms 24.369 ms 6 bbr02slidla-tge-0-1-0-4.slid.la.charter.com ( 26.384 ms 29.802 ms 32.944 ms 7 prr01snjsca-tge-0-0-0-1.snjs.ca.charter.com ( 32.016 ms 23.033 ms 22.904 ms 8 96-34-150-71.static.unas.mo.charter.com ( 22.426 ms 28.423 ms ( 25.003 ms 9 ( 31.106 ms ( 28.321 ms ( 28.466 ms 10 ( 26.018 ms ( 32.080 ms ( 31.922 ms 11 ( 28.337 ms ( 28.410 ms ( 27.498 ms 12 ( 22.979 ms ( 28.309 ms ( 26.121 ms 13 * * * 14 * * * 15 * * * 16 * * * 17 * * * 18 * * * 19 * * * 20 * * * 21 * * * 22 yv-in-f113.1e100.net ( 28.410 ms * 25.002 ms

I called my ISP and they said they do not throttle VPN traffic but some users online say that Charter Spectrum is untruthful about this.

inxi -Fxxxz

System:    Host: 2600x Kernel: 4.19.66-1-MANJARO x86_64 bits: 64 compiler: gcc v: 9.1.0 Desktop: KDE Plasma 5.16.4 
           tk: Qt 5.13.0 wm: kwin_x11 dm: SDDM Distro: Manjaro Linux 
Machine:   Type: Desktop System: Gigabyte product: B450 I AORUS PRO WIFI v: N/A serial: <filter> 
           Mobo: Gigabyte model: B450 I AORUS PRO WIFI-CF v: x.x serial: <filter> UEFI: American Megatrends v: F40 
           date: 05/16/2019 
Battery:   Device-1: hidpp_battery_0 model: Logitech Wireless Keyboard K360 serial: <filter> charge: 100% (should be ignored) 
           rechargeable: yes status: Discharging 
CPU:       Topology: 6-Core model: AMD Ryzen 5 2600X bits: 64 type: MT MCP arch: Zen+ rev: 2 L2 cache: 3072 KiB 
           flags: avx avx2 lm nx pae sse sse2 sse3 sse4_1 sse4_2 sse4a ssse3 svm bogomips: 86257 
           Speed: 2512 MHz min/max: 2200/3600 MHz boost: enabled Core speeds (MHz): 1: 2512 2: 2027 3: 2135 4: 2974 5: 2897 
           6: 2681 7: 2041 8: 2172 9: 2820 10: 2005 11: 2393 12: 2477 
Graphics:  Device-1: NVIDIA GP107 [GeForce GTX 1050 Ti] vendor: eVga.com. driver: nvidia v: 430.40 bus ID: 0a:00.0 
           chip ID: 10de:1c82 
           Display: x11 server: X.Org 1.20.5 driver: nvidia compositor: kwin_x11 resolution: 1920x1200~60Hz 
           OpenGL: renderer: GeForce GTX 1050 Ti/PCIe/SSE2 v: 4.6.0 NVIDIA 430.40 direct render: Yes 
Audio:     Device-1: NVIDIA GP107GL High Definition Audio vendor: eVga.com. driver: snd_hda_intel v: kernel bus ID: 0a:00.1 
           chip ID: 10de:0fb9 
           Device-2: Advanced Micro Devices [AMD] Family 17h HD Audio vendor: Gigabyte driver: snd_hda_intel v: kernel 
           bus ID: 0c:00.3 chip ID: 1022:1457 
           Device-3: Logitech Headset H390 type: USB driver: hid-generic,snd-usb-audio,usbhid bus ID: 3-2.2:5 
           chip ID: 046d:0a44 
           Sound Server: ALSA v: k4.19.66-1-MANJARO 
Network:   Device-1: Intel Wireless-AC 9260 driver: iwlwifi v: kernel bus ID: 07:00.0 chip ID: 8086:2526 
           IF: wlp7s0 state: down mac: <filter> 
           Device-2: Intel I211 Gigabit Network vendor: Gigabyte driver: igb v: 5.4.0-k port: f000 bus ID: 09:00.0 
           chip ID: 8086:1539 
           IF: enp9s0 state: up speed: 1000 Mbps duplex: full mac: <filter> 
           IF-ID-1: tun0 state: unknown speed: 10 Mbps duplex: full mac: N/A 
Drives:    Local Storage: total: 953.87 GiB used: 118.46 GiB (12.4%) 
           ID-1: /dev/nvme0n1 vendor: Intel model: SSDPEKNW010T8 size: 953.87 GiB speed: 31.6 Gb/s lanes: 4 serial: <filter> 
           rev: 002C scheme: GPT 
Partition: ID-1: / size: 920.63 GiB used: 74.57 GiB (8.1%) fs: ext4 dev: /dev/nvme0n1p2 
           ID-2: swap-1 size: 17.24 GiB used: 0 KiB (0.0%) fs: swap dev: /dev/nvme0n1p3 
Sensors:   System Temperatures: cpu: 43.6 C mobo: 27.0 C gpu: nvidia temp: 28 C 
           Fan Speeds (RPM): cpu: 0 fan-1: 0 fan-3: 0 gpu: nvidia fan: 30% 
           Voltages: 12v: N/A 5v: N/A 3.3v: 1.68 vbat: 1.59 
Info:      Processes: 275 Uptime: 14m Memory: 15.67 GiB used: 2.53 GiB (16.2%) Init: systemd v: 242 Compilers: gcc: 9.1.0 
           Shell: bash v: 5.0.7 running in: yakuake inxi: 3.0.35

cat /etc/resolv.conf

# Generated by NetworkManager

The above commands are done with me connected through the VPN service.

Do you understand the traceroute output? If we can figure out if it is ISP throttling vs. the VPN service this issue will be solved. Thanks for all your help @tbg !!!

Well... I mean... it would probably have been useful to have mentioned that at the start.

Yes, the connectivity check is likely being interfered with by your VPN setup.


Not all users have the technical knowledge to understand what may or may not be relevant information when asking for help. What may seem obvious to a seasoned Linux user may not be on the radar of a newbie.

Perhaps I should have posted this in the newbie section to avoid any assumptions.

Sadly many don't realize that VPN's and VM's add another level of complexity to network issues. I generally steer clear of any network requests that use either, as it just makes troubleshooting too much of a headache.

It's not your fault, you didn't know. It can just get frustrating for helpers when it is not mentioned straight away.

Glad you figured it out.


That's true to an extent, however

"My car's fuel light keeps coming on but I know there's fuel in the tank."
"Oh by the way I put some fuel additive in just before the issue started."

A VPN is a network-related item so it should probably be something you think of when considering network-related issues.


Thanks for your help and understanding @tbg

Linux has a reputation in some circles for turning off new users who are trying to learn and it's people like you that make newbie's feel welcome.

I've been using Mullvad VPN with my Manjaro KDE desktops for about 9 months and this is just a recent issue so it isn't necessarily obvious that the VPN is the issue. Perhaps if it had started from day one using the VPN one would deduct the connection between the two. A newbie Linux user might not connect the two since they didn't happen even close to the same time.

Like any human being, I'll make mistakes sometimes which is why I always give everyone the benefit of the doubt.

In any case, I appreciate your help and support on the Manjaro forums.


This topic was automatically closed 90 days after the last reply. New replies are no longer allowed.

Forum kindly sponsored by