[Solved] Network slow after suspend

After I wake my laptop up from sleep my network is much slower. Instead of the usual 2 MB/s I only get 200 kb/s at most. Tried restarting network manager without much effect. Any help on what might be going wrong?
Wireless card: intel wireless 3165.

Does it give any errors when waking up?


You can use the journalctl -f switch in an open terminal to easily see what is happening.

Open terminal type journalctl -f put or let the laptop go to sleep for a few minutes, wake it up and look at the output in the terminal to see what happened. Use your network too.

This is what keeps appearing repeatedly. Don't know if it says more...

Jan 10 13:06:36 giraffe-pc systemd[1]: Started Network Manager Script Dispatcher Service.
Jan 10 13:06:36 giraffe-pc nm-dispatcher[4681]: req:1 'dhcp6-change' [wlo1]: new request (1 scripts)
Jan 10 13:06:36 giraffe-pc nm-dispatcher[4681]: req:1 'dhcp6-change' [wlo1]: start running ordered scripts...
Jan 10 13:06:53 giraffe-pc NetworkManager[32763]: <info>  [1515586013.9900] dhcp6 (wlo1):   address 2001:4c4c:1f6a:8500:de53:60ff:fe48:1da9/128 lft 60sec pref 30sec lifetime 4072-4072[30,60] src dhcp
Jan 10 13:06:53 giraffe-pc NetworkManager[32763]: <info>  [1515586013.9902] dhcp6 (wlo1):   nameserver 2001:4c48:1::1
Jan 10 13:06:53 giraffe-pc NetworkManager[32763]: <info>  [1515586013.9903] dhcp6 (wlo1):   nameserver 2001:4c48:2::1
Jan 10 13:06:53 giraffe-pc NetworkManager[32763]: <info>  [1515586013.9903] dhcp6 (wlo1): state changed bound -> bound
Jan 10 13:06:53 giraffe-pc dbus-daemon[555]: [system] Activating via systemd: service name='org.freedesktop.nm_dispatcher' unit='dbus-org.freedesktop.nm-dispatcher.service' requested by ':1.12227' (uid=0 pid=32763 comm="/usr/bin/NetworkManager --no-daemon ")
Jan 10 13:06:54 giraffe-pc systemd[1]: Starting Network Manager Script Dispatcher Service...
Jan 10 13:06:54 giraffe-pc dbus-daemon[555]: [system] Successfully activated service 'org.freedesktop.nm_dispatcher'

Okay, I think it was an issue of using a bluetooth speaker and wifi at the same time. Added

options iwlwifi bt_coex_active=0

to /etc/modprobe.d/linux414-broadcom-wl.conf.
Seems okay now.

1 Like

This topic was automatically closed 90 days after the last reply. New replies are no longer allowed.

Forum kindly sponsored by