{Solved] Nvidia PRIME and Bumblebee Conflict

Hello Helpers,

I messed up bad and I think I completely screwed up my Nvidia driver install. I installed manjaro on my laptop successfully and to wanted to setup the Nvidia and Intel graphics in hybrid mode. Without reading into the manjaro forum I referred the Arch wiki and installed Nvidia drivers and tried to get PRIME running without realizing bumblebee is already installed by default on manjaro.

Currently, I am using manjaro 18 with 4.19 LTS kernel and what I want to do is get bumblebee running properly.

I ran the inxi -G command to see what is installed and got the following

[jose@jose ~]$ inxi -G
Graphics:  Device-1: Intel UHD Graphics 630 driver: i915 v: kernel 
           Device-2: NVIDIA TU106M [GeForce RTX 2070 Mobile] driver: N/A 
           Display: x11 server: X.org 1.20.7 driver: N/A resolution: <xdpyinfo missing> 
           OpenGL: renderer: Mesa DRI Intel UHD Graphics 630 (Coffeelake 3x8 GT2) v: 4.6 Mesa 19.3.2 

Then I ran sudo mhwd -a pci nonfree 0300 to see if mhwd can fix my blunders, and got the following

[jose@jose ~]$ sudo mhwd -a pci nonfree 0300
[sudo] password for jose: 
> Using config 'video-hybrid-intel-nvidia-440xx-prime' for device: 0000:01:00.0 (0300:10de:1f10) Display controller nVidia Corporation TU106M [GeForce RTX 2070 Mobile]
> Using config 'video-hybrid-intel-nvidia-440xx-prime' for device: 0000:00:02.0 (0300:8086:3e9b) Display controller Intel Corporation UHD Graphics 630 (Mobile)
Error: config 'video-hybrid-intel-nvidia-440xx-prime' conflicts with config(s): video-hybrid-intel-nvidia-430xx-bumblebee

However when I run mhwd -li I get the following

[jose@jose ~]$ mhwd -li
> Installed PCI configs:
--------------------------------------------------------------------------------
                  NAME               VERSION          FREEDRIVER           TYPE
--------------------------------------------------------------------------------
video-hybrid-intel-nvidia-430xx-bumblebee            2019.10.25               false            PCI


Warning: No installed USB configs!

My end game, would be to have the nvidia powering graphics heavy stuff like unreal engine and steam, while intel gpu is used for lighter tasks to save battery.

As I understand it, Linux can't currently do this dynamically, you need to switch manually with either a reboot or logout/in depending on whether you're using manager or switch. In any case you should be fine to just uninstall bumblebee and either continue using that 440 offload option or try optimus-manager or switch, they'll all do what you're trying to do in an ever so slightly different way.

See here for more on all that and decide which suits you best




1 Like

remove bumblebee first, then install the prime (render-offload) package

sudo mhwd -r pci video-hybrid-intel-nvidia-430xx-bumblebee 
sudo mhwd -i pci video-hybrid-intel-nvidia-440xx-prime

Thank you @10yearslate for the huge collection of resources. I read through them all and decided that PRIME offloading would better suit my needs. I tried going through the following thread to get PRIME to work

But I couldn't find the modified mhwd package to install the PRIME drivers. So tired the following tutorial to get PRIME working

However, while trying to uninstall Bumblebee drivers as required in the tutorial and suggested by @dglt. I ran into the issue

Error: config 'video-hybrid-intel-nvidia-440xx-prime' conflicts with config(s): video-hybrid-intel-nvidia-430xx-bumblebee

Upon further inspection I found that the package lib32-nvidia_vk was causing the issue while trying to install or uninstall the drivers using mhwd

As of now I got PRIME running

[jose@jose ~]$ glxinfo | grep -i vendor
server glx vendor string: NVIDIA Corporation
client glx vendor string: NVIDIA Corporation
OpenGL vendor string: NVIDIA Corporation

I didn't get time to run and test any graphics heavy task. I'll update my finding as soon get time do it.

Thank you very much @10yearslate & @dglt for your help.

1 Like

this is where referring to render-offload as "PRIME" was a dumb idea on nvidia's part. PRIME and PRIME (render-load) are 2 completely different setups with the same name. :roll_eyes:

this is render-offload prime :point_up:

this is the "old" PRIME that works better and doesnt have the limitations of render-offload prime. but hey, at least it's not confusing right?

1 Like

This topic was automatically closed 30 days after the last reply. New replies are no longer allowed.

Forum kindly sponsored by