[Solved]Pale Moon Preferences Window not respond

Hi! I'm a Pale Moon user, today my browser have an update, and i notice a problem. I already write in palemoon forum, but some guys said that is not browser problem. So, i decide to share with you...

The problem is, when i open the preferences window, cannot navigate between tabs.

For example, preferences window is open with "General" tab active. I try to switch to "Content" (or whatever), and nothing happened. I close the preferences window and open it again, now he open with tab "Content" active. When i click on some checkbox, again no visible changes, but when i close and open preferences again, saw that the checkbox status is changed...

Error console show no errors.

Seems like the events are not picked up by X server... Browser do the change, but graphic remain the same. This behavior is happen only with this, new version on the browser.

Any ideas? Thank you!

Manjaro 17.1.2 with Xfce4, integrated Intel graphics.

To which version?


Any output when you run palemoon from a terminal?

Have you tried with a fresh, clean profile?

Palemoon troubleshooting is also similar to Firefox troubleshooting, so also read:

I'm sorry, i forgot to mention that!

Pale Moon is up to 28.0.0 version now.
I try in safe mode, and yes i try in brand new profile. Yes, i remove the folder '~/.cache/moonchild productions'. Do all of that. The same problem.

Link to the PaleMoon forum theme: https://forum.palemoon.org/viewtopic.php?f=37&t=19941

1 Like

That is the terminal output, when i close the bowser:

|1534680067726|Sync.ErrorHandler|ERROR|Sync was interrupted due to the application shutting down|
|1534680068534|Sync.LogManager|ERROR|Failed to cleanup logs: Error: OS.File has been shut down. Rejecting request to DirectoryIterator_prototype_next (resource://gre/modules/osfile/osfile_async_front.jsm:412:8) JS Stack trace: post/<@osfile_async_front.jsm:412:8 < TaskImpl_run@Task.jsm:319:42 < TaskImpl@Task.jsm:277:3 < asyncFunction@Task.jsm:252:14 < process@Promise-backend.js:932:23 < walkerLoop@Promise-backend.js:813:7 < scheduleWalkerLoop/<@Promise-backend.js:747:11 < observe@AsyncShutdown.jsm:550:9|

Hmm... I can't replicate this with Palemoon 28.0 from the repos on my MATE+NVIDIA system. All UI elements respond normally.

Are you running with e.g. Compton or Compiz? Have you tried enabling/disabling the Xfwm compositor?

Yes, i play with xfwm settings, but nothing happen. Now i'll install Compton and will see...

hmm... Antix32, Manjaro32. What is it you are using actually? Manjaro is Arch based not Debian.

I use Manjaro 17.1.2 Hakoila with Xfce.

I tried with compton. No luck. Tried with metacity with and without compiz. Again, no luck. :frowning:

On LMDE (64bit Cinnamon kernel 4.9) preferences window do work. I'll keep digging.

Solved! The problem was in gtk theme!
Thank you for the suggestions and for the help!

1 Like

Actually, it's not solved entirely... In order to make preferences windows to work, i must change the gtk theme, after the preferences window is opened... No matter which one theme, but must change the theme, otherwise preferences window remain frozen...

Final solution! In about:config find browser.preferences.animateFadeIn, set as true. Problem solved, finally! :yum:

1 Like

Finally, i figured it out! It wasn't Pale Moon issue...

I uninstall default intel video-linux driver and install video-vesa driver, from "manjaro settings > hardware configuration" and generate xorg.conf file, now everything works just fine, regardless 'animateFadein' setting.

Intel cards are known not to work with xf86-video-intel at some cases. Therefore uninstalling that driver will fall back to xf86-video-modesetting drivers. vesa is normally not needed. More about it here.

1 Like

Yes, you are right, vesa is not needed. But now i have some tearing on screen, especially when play video... :frowning:

Edit few minutes later: But this tutorial make all fixed! Thank you! :slight_smile:

This is fixed in XFCE-GTK3 already. That is why we use that version for our Spitfire laptop.

1 Like

With AUR version of the xf86-video-intel, Pale Moon works like a charm! :slight_smile:

This topic was automatically closed 90 days after the last reply. New replies are no longer allowed.

Forum kindly sponsored by