[SOLVED] Poor wifi speeds

Hello! I have searched and am not finding an issue quite like the one I am experiencing. Wifi speeds are slow, ethernet is snappy and quick. I am running a mid 2012 Macbook Pro. macos, windows, and KDE Neon do not have the wifi problems.

I assumed this was due to the broadcom wifi drivers which have proven to be a headache in the past, but I have a USB wifi adapter (Alfa AWUS036NEH) which has worked perfectly - plug & play - with every distro I've tried. However, I get the slow wifi speeds on the Alfa as well as with the internal wifi.

inxi -Fxz outputs the following:

  Host: heisenberg Kernel: 4.19.28-1-MANJARO x86_64 bits: 64 compiler: gcc 
  v: 8.2.1 Desktop: KDE Plasma 5.15.2 Distro: Manjaro Linux 
  Type: Laptop System: Apple product: MacBookPro9,1 v: 1.0 serial: <filter> 
  Mobo: Apple model: Mac-4B7AC7E43945597E v: MacBookPro9,1 serial: <filter> 
  UEFI: Apple v: date: 09/21/2018 
  ID-1: BAT0 charge: 30.0 Wh condition: 44.3/75.2 Wh (59%) 
  model: SMP bq20z451 status: Charging 
  Topology: Quad Core model: Intel Core i7-3615QM bits: 64 type: MT MCP 
  arch: Ivy Bridge rev: 9 L2 cache: 6144 KiB 
  flags: lm nx pae sse sse2 sse3 sse4_1 sse4_2 ssse3 vmx bogomips: 36728 
  Speed: 1197 MHz min/max: 1200/3300 MHz Core speeds (MHz): 1: 1197 2: 1197 
  3: 1198 4: 1197 5: 1197 6: 1197 7: 1197 8: 1197 
  Device-1: Intel 3rd Gen Core processor Graphics vendor: Apple driver: i915 
  v: kernel bus ID: 00:02.0 
  Device-2: NVIDIA GK107M [GeForce GT 650M Mac Edition] vendor: Apple 
  driver: nvidia v: 390.116 bus ID: 01:00.0 
  Display: x11 server: X.Org 1.20.4 driver: nvidia resolution: 1440x900~60Hz 
  OpenGL: renderer: GeForce GT 650M/PCIe/SSE2 v: 4.6.0 NVIDIA 390.116 
  direct render: Yes 
  Device-1: Intel 7 Series/C216 Family High Definition Audio 
  driver: snd_hda_intel v: kernel bus ID: 00:1b.0 
  Device-2: NVIDIA GK107 HDMI Audio vendor: Apple driver: snd_hda_intel 
  v: kernel bus ID: 01:00.1 
  Sound Server: ALSA v: k4.19.28-1-MANJARO 
  Device-1: Broadcom and subsidiaries NetXtreme BCM57765 Gigabit Ethernet 
  driver: tg3 v: 3.137 port: 2000 bus ID: 02:00.0 
  IF: enp2s0f0 state: down mac: <filter> 
  Device-2: Broadcom and subsidiaries BCM4331 802.11a/b/g/n 
  driver: bcma-pci-bridge v: N/A port: 2000 bus ID: 03:00.0 
  IF-ID-1: wlp3s0b1 state: up mac: <filter> 
  Local Storage: total: 931.51 GiB used: 27.04 GiB (2.9%) 
  ID-1: /dev/sda vendor: Samsung model: SSD 850 EVO 1TB size: 931.51 GiB 
  ID-1: / size: 159.42 GiB used: 27.02 GiB (16.9%) fs: ext4 dev: /dev/dm-0 
  System Temperatures: cpu: 71.0 C mobo: N/A gpu: nvidia temp: 60 C 
  Fan Speeds (RPM): N/A 
  Processes: 241 Uptime: 12m Memory: 7.73 GiB used: 2.85 GiB (36.9%) 
  Init: systemd Compilers: gcc: 8.2.1 Shell: bash v: 5.0.0 inxi: 3.0.32

lscpi -v gives me this (obv I've cut out a lot of irrelevant stuff):

03:00.0 Network controller: Broadcom Inc. and subsidiaries BCM4331 802.11a/b/g/n (rev 02)
        Subsystem: Broadcom Inc. and subsidiaries BCM4331 802.11a/b/g/n
        Flags: bus master, fast devsel, latency 0, IRQ 17
        Memory at c1a00000 (64-bit, non-prefetchable) [size=16K]
        Capabilities: [40] Power Management version 3
        Capabilities: [58] Vendor Specific Information: Len=78 <?>
        Capabilities: [48] MSI: Enable- Count=1/1 Maskable- 64bit+
        Capabilities: [d0] Express Endpoint, MSI 00
        Capabilities: [100] Advanced Error Reporting
        Capabilities: [13c] Virtual Channel
        Capabilities: [160] Device Serial Number 00-00-00-ff-ff-00-00-00
        Capabilities: [16c] Power Budgeting <?>
        Kernel driver in use: bcma-pci-bridge
        Kernel modules: bcma

iwconfig gives me this:

enp2s0f0  no wireless extensions.

wlp3s0b1  IEEE 802.11  ESSID:"milksteak"  
          Mode:Managed  Frequency:2.462 GHz  Access Point: DC:FE:07:9C:D7:58   
          Bit Rate=36 Mb/s   Tx-Power=30 dBm   
          Retry short limit:7   RTS thr:off   Fragment thr:off
          Encryption key:off
          Power Management:off
          Link Quality=63/70  Signal level=-47 dBm  
          Rx invalid nwid:0  Rx invalid crypt:0  Rx invalid frag:0
          Tx excessive retries:321  Invalid misc:1758   Missed beacon:0

lo        no wireless extensions.

All of that is without the Alfa USB adapter plugged in. I assume some of that will be irrelevant given the fact this happens with either device, but I hope that's enough information. I appreciate any assistance.

Possibly you have a DNS issue if both your wireless and wired connections are slow. The pci-bridge for a driver is a tell tale sign that you have problems with your Wi-Fi driver.

I would suggest testing older and new kernels for improvement. Test out at least 4.14, 4.20, and kernel 5.


Thank you for the reply. Changing the kernel did not work, but you were still very helpful!

I did some more searching using what you pointed out, the bcma-pci-bridge. I was able to solve my issue with the information here: Broadcom wifi driver fails to install properly

Thanks for putting me on the right track!

Glad to see that fixed you up. I was going to post that link, but as I already posted it on similar thread a few hours ago I figured you'd suss it out.

Good stuff.

This topic was automatically closed 90 days after the last reply. New replies are no longer allowed.

Forum kindly sponsored by