[SOLVED] Problem with wpa_supplicant on my Dell XPS 13 (Broadcom BCM4352)


over the past three months I noticed that my Dell XPS 13 (9343) has issues with the wirless card. It keeps disconnecting randomly after a few minutes. After rebooting the network seems to work directly but it crashes after time. I noticed that the driver keeps getting worse in the last months. Last year the driver had no problems. The problematic driver is "network-broadcom-wl".

Here is what I already tried:

  • I recently updated my kernel and software.
  • As from another old post mentioned I flashed to the new A20 BIOS, also reset the Bios Settings to default, with no luck (Old Topic)
  • Pressed FN+Print to turn on / off the wireless.

Now I read to try another broadcom driver so I removed the broadcom wl driver - now it shows:

$ mhwd -li                            
> Installed PCI configs:
                  NAME               VERSION          FREEDRIVER           TYPE
           video-linux            2018.05.04                true            PCI

Warning: No installed USB configs!

My question is, how to generally fix this and how can I get my wifi driver back without an ethernet cable. I have another computer from which I can copy driver files via usb. So I cant do "sudo pacman -S broadcom-wl-dmks" and so on. I already downloaded the offical broadcom-wl-dmks.tar.gz but it fails due to the bunch of dependent librarys. My Dell XPS 13 has no ethernet link.

Here are my Hardware specs:

$ inxi -Fxxxz                    
  Host: tm-laptop Kernel: 4.19.113-1-MANJARO x86_64 bits: 64 compiler: gcc 
  v: 9.3.0 Desktop: Gnome 3.36.0 wm: gnome-shell dm: GDM 3.34.1 
  Distro: Manjaro Linux 
  Type: Laptop System: Dell product: XPS 13 9343 v: N/A serial: <filter> 
  Chassis: type: 9 serial: <filter> 
  Mobo: Dell model: 0TM99H v: A00 serial: <filter> UEFI: Dell v: A20 
  date: 06/06/2019 
  ID-1: BAT0 charge: 47.8 Wh condition: 47.8/54.0 Wh (88%) volts: 8.6/7.5 
  model: Sanyo DELL 0DRRP54 type: Li-poly serial: <filter> status: Full 
  Topology: Dual Core model: Intel Core i5-5200U bits: 64 type: MT MCP 
  arch: Broadwell rev: 4 L2 cache: 3072 KiB 
  flags: avx avx2 lm nx pae sse sse2 sse3 sse4_1 sse4_2 ssse3 vmx 
  bogomips: 17558 
  Speed: 798 MHz min/max: 500/2700 MHz Core speeds (MHz): 1: 798 2: 798 
  3: 798 4: 798 
  Device-1: Intel HD Graphics 5500 vendor: Dell driver: i915 v: kernel 
  bus ID: 00:02.0 chip ID: 8086:1616 
  Display: x11 server: X.org 1.20.7 driver: i915 compositor: gnome-shell 
  resolution: <xdpyinfo missing> 
  OpenGL: renderer: Mesa DRI Intel HD Graphics 5500 (Broadwell GT2) 
  v: 4.6 Mesa 19.3.5 compat-v: 3.0 direct render: Yes 
  Device-1: Intel Broadwell-U Audio vendor: Dell driver: snd_hda_intel 
  v: kernel bus ID: 00:03.0 chip ID: 8086:160c 
  Device-2: Intel Wildcat Point-LP High Definition Audio vendor: Dell 
  driver: snd_hda_intel v: kernel bus ID: 00:1b.0 chip ID: 8086:9ca0 
  Sound Server: ALSA v: k4.19.113-1-MANJARO 
  Device-1: Broadcom and subsidiaries BCM4352 802.11ac Wireless Network 
  vendor: Dell driver: bcma-pci-bridge v: N/A port: f040 bus ID: 02:00.0 
  chip ID: 14e4:43b1 
  Local Storage: total: 267.48 GiB used: 61.60 GiB (23.0%) 
  ID-1: /dev/sda vendor: Toshiba model: THNSNJ256G8NU M.2 2280 256GB 
  size: 238.47 GiB speed: 6.0 Gb/s serial: <filter> rev: 0102 scheme: GPT 
  ID-2: /dev/sdb type: USB vendor: Generic model: Flash Disk size: 29.00 GiB 
  serial: <filter> rev: 8.07 
  ID-1: / size: 233.43 GiB used: 60.83 GiB (26.1%) fs: ext4 dev: /dev/sda2 
  System Temperatures: cpu: 50.0 C mobo: 45.5 C 
  Fan Speeds (RPM): N/A 
  Processes: 215 Uptime: 4h 19m Memory: 7.70 GiB used: 847.9 MiB (10.8%) 
  Init: systemd v: 244 Compilers: gcc: 9.3.0 Shell: zsh v: 5.8 
  running in: gnome-terminal inxi: 3.0.37 

Best Regards,


Is that a different one than mentioned here

Hi, before I removed it, it was named "network-broadcom-wl" and not "broadcom-wl". But it can be the same..
I installed the broadcom-wl driver now from here.

Unfortunately the xps doesnt recognize the wifi card anymore..

$ inxi -Fxxxz                    
  Device-1: Broadcom and subsidiaries BCM4352 802.11ac Wireless Network 
  vendor: Dell driver: N/A port: f040 bus ID: 02:00.0 chip ID: 14e4:43b1 

I would uninstall the driver and reset your bios to the factory default.

Power down the laptop and remove the battery and power plug. Let the laptop sit without power for a few minutes. Then, hold down the power button for approximately 30 seconds. Pressing the power button will help drain all left over power from the unit’s motherboard.

Then reattach the AC power (no battery), and restart. Boot into your bios, then reset the bios to the factory defaults, save the default settings. See if it will boot correctly with the factory default settings. If not, you may have to change a few settings in the BIOS (such as secure boot) to get Manjaro to boot correctly.

Then follow this driver installation guide:

1 Like

Thank you very much, my I was able to get my wifi card running again. The USB Tethering via IPhone did the trick. I will keep you up to date if it works stable now. I needed to follow the guide until installation of " broadcom-wl-dkms".

1 Like

Yes, I am not sure exactly why, but the dkms driver variant often seems to work better with many broadcom adapters. I hope your connection will be more stable with the new driver.

If not, be sure to test at least three different kernels for improvements.


Small update:
After facing the same problems for the last days, I found a guy from here who fixed it by downgrading the networkmanager with ALA. So I tried this, yesterday I got it working again, but I think it keeps crashing when it connects to the wifi automatically. When removing the wifi and re-creating the connection it seems to work until next boot.

I will investigate further in the next days..

Downgrade wpa_supplicant as well, or switch to iwd.

1 Like


The downgrade of wpa_supplicant made my wifi connectiong great again :wink:
It its working stable now. I also changed the networkmanager to conman, but was not able to connect to my wifi, so I switched back to the downgraded networkmanager (1.14.5dev+17+gba83251bb-2

Especially with a Broadcom adapter I think you would be better off switching to iwd rather than downgrading wpa_supplicant. There are bugs with numerous Broadcom adapters relating to wpa_supplicant. You will encounter less bugs with a Broadcom adapter by using iwd and you will connect faster.

I would highly advise anyone with a Broadcom adapter to mask wpa_supplicant and install and enable iwd.

I'm glad your issue seems resolved for now.

This topic was automatically closed 90 days after the last reply. New replies are no longer allowed.

Forum kindly sponsored by