[SOLVED] Problems fter interrupted update process. (First missing kernel img then seems there's problems with mesa-vdpau package)

So manjaro update failed (stucked and didn't go foward) I forgot that while I was away from laptop and when I ame back I shutted down the machine.

Well after that I can't boot back to my system, I just got errormessage:

manjaro error: file '/boot/initframs-4.19-x86_64.img' not found

I did ty to fix this by following this guide:

But no luck! It accepts the command

linux /boot/vmlinuz-4.19-x86_64 root=UUID=$abc rw

where I replace $abc with my UUID but when trying the next step:

initrd /boot/initramfs-4.19-x86_64.img

It omce again cannot find img file.

Is there anything I can do to fix this issue?

This whole solution with arch base is so much different than my ealier experiences fixing grub via live usb at ubuntu based distros sesveral years ago.

Anyway I hope you can help me the way to fix my setup.


Edit: Could I basily use this (see link) with live usb and try to generate img file? I actyally tried this also but don't know the right way to do it via live session it just gave message that cannot write or similar when tried with

mkinitcpio -g vmlinuz-4.19-x86_64 (when is suggested -g with image file well thats'd not image but...) Anyway what is orrect way to use this via live session or is this just wrong?



PS. Everything here has gone wrong by me now Had to create new useraccount cause cannot login with pevious one cause 2-phase authentiation (have lost my app cause broken phone)... :sweat_smile::joy:

Please edit your post to be readable.
Or any available moderator?

You shut down the computer while halfway doing updates. Not good. Do you have another kernel besides 4.19? You can try with it. If it still has same issue, you need to chroot into the system and complete the updates one more time.

Thanks for answers! (seemed that chroot was part of solution also with manjaro)

I'm writing this fom my seconday machine again (keyboad doesn't work nicely so sorry for bad typos. I managed to chroot and completed upgrade process with packman -Syyu ad now I have kernel image installed BUT when stating system there's just black screen after grub.

Now reading threads how to solve that but haven't find any yet. Many cases seems to be related to the radeon graphics, but I have fully intel based oldish thinkpad, so need to find some other solution.

Manjaro changed on how the initramfs gets generated. You may install another kernel to see if that helps. Radeon drivers are integrated into the kernel, so mostly no extramodules involved there. Try to boot into a TTY shell and see if the update is really finished. Most likely issue mkinitcpio -P and update-grub to be sure.

Can you post of /boot/grub/grub.cfg ?

Thanks fo information!

And now to the stupid question since I've never installed kernel from pacman what is the right way to install 5.3 kenel which seems to come with latest manjaro-cinnamon live image an be also newer if recommended. Also I believe intel drivers and all needed are at kernel, no need fo modules and everything should be updated now.

Btw. If by TTY shell you mean ctrl+alt+f2 when starting manjaro from grub I can't access there screen remains black. But at least chroot method works. :slight_smile:

Ok pacman -S linux53 is way to install newer kernel but that fails. Seems that there is probblem with mesa-vdpau package it didn't install completely at original update process. (now error is can't find file) but can't reinstall that either, will try again since that is probably causing this problem now.. Should I try to update this title to desribe more changed situation, or marked as solved bu original error message (couldn't find .img file) and open new topi related ro situation now..

Or just try to solve this all under this and then let thread be locked and fogotten?

You can boot to TTY directly, editing grub menu option (Use kernel 4.19 to boot, so you can try re-installing kernel 5.3) add 3 at the end of the line that starts with linux.

sudo pacman -Syu
sudo mhwd-kernel -i linux53
sudo update-grub

If it still boots to black screen, read more advice to fix and report what happens, including info as suggested in the tutorial(s).

1 Like

As @Agents stated the best way to install an new kernel is using mhwd.

Ok I try my best to provide better information, it's bit hard though sine I have to use this crappy windows machine to write here.

I also cannot enter to TTY, black sreen again. So at this point only way to use teminal is via chroot at live session. From there I cannot install kernel 5.3 with command
sudo mhwd-kernel -i linux53
since it is same kernel version as in live session. But I can try to install linux53 via pacman but installation fails cause there's problem with package mesa-vdpau.

In fact that mesa-vdpau was the pakage which update got stucked, for that reason I left computer and ame back later, was in hurry so forgot and shutted down the machine with not completely installed mesa-vdpau.

I'm sorry I probably just got you all frustrated but I try to do best I can at this point but it obviously isn't enough sorry for that.

Do you mean you have tried this and did not land in TTY?
Please explain, if you need help, or have fun yourself :wink:

First of all I chrooted again, removed mesa-vdpau and then installed mesa-vdpau again and after that installed linux53 via pacman. Now everything works!

But to answer that quoted part, I newer saw any direct option to TTY but selecting kernel pressing e and at linux line pressing End to get end of te line adding space and 3 and either ctrl+x or F10 to boot TTY1 (I believe) but ended to black screen.

But as said now machine is working again.

Thanks a lot to you all! I may have not found direct answer which worked for me out of the box (or followed introdutions wrong way) but this was good experience, got more knowledge of arch based disto this way that just using as I have so far.

1 Like

This topic was automatically closed 30 days after the last reply. New replies are no longer allowed.

Forum kindly sponsored by