[SOLVED] Problems with boot

I used to dual-boot Manjaro with Windows 8.1 and everything worked fine back then, but once I encountered an error with drivers when I forced a shutdown on Windows I decided to wipe Windows and make a clean install of Manjaro. Ever since I'm having several problems booting Manjaro, it takes me 3 or 4 times of forcing a shutdown (which gives me an fsck error in return usually :smiley: ) to finally get into a working system, and from time to time booting takes incredibly long.

I tried other distros from Antergos/ArchLabs to Debian-based distros as well, unfortunately none of them worked hassle-free. I also tried different kernels (4.18, 4.14), no hope. Maybe it is just my hardware? idk.

This is one of the problematic boots I managed to capture:

2018-10-06_17-41

Here is the inxi -Fxz output:

[baris@liberty ~]$ inxi -Fxz
System:
  Host: liberty Kernel: 4.14.71-1-MANJARO x86_64 bits: 64 compiler: gcc 
  v: 8.2.1 Desktop: i3 4.15.0.1 Distro: Manjaro Linux 
Machine:
  Type: Laptop System: ASUSTeK product: K56CB v: 1.0 serial: <filter> 
  Mobo: ASUSTeK model: K56CB v: 1.0 serial: <filter> BIOS: American Megatrends 
  v: K56CB.204 date: 01/25/2013 
Battery:
  ID-1: BAT0 charge: 17.1 Wh condition: 24.8/32.6 Wh (76%) 
  model: ASUSTeK K56--30 status: Charging 
CPU:
  Topology: Dual Core model: Intel Core i5-3317U bits: 64 type: MT MCP 
  arch: Ivy Bridge rev: 9 L2 cache: 3072 KiB 
  flags: lm nx pae sse sse2 sse3 sse4_1 sse4_2 ssse3 vmx bogomips: 13573 
  Speed: 798 MHz min/max: 800/2600 MHz Core speeds (MHz): 1: 797 2: 798 3: 798 
  4: 798 
Graphics:
  Device-1: Intel 3rd Gen Core processor Graphics driver: i915 v: kernel 
  bus ID: 00:02.0 
  Device-2: NVIDIA GK107M [GeForce GT 740M] driver: N/A bus ID: 01:00.0 
  Display: x11 server: X.Org 1.20.1 driver: modesetting 
  resolution: 1366x768~60Hz 
  OpenGL: renderer: Mesa DRI Intel Ivybridge Mobile v: 4.2 Mesa 18.2.1 
  direct render: Yes 
Audio:
  Device-1: Intel 7 Series/C216 Family High Definition Audio 
  driver: snd_hda_intel v: kernel bus ID: 00:1b.0 
  Sound Server: ALSA v: k4.14.71-1-MANJARO 
Network:
  Device-1: Qualcomm Atheros AR9485 Wireless Network Adapter driver: ath9k 
  v: kernel bus ID: 03:00 
  IF: wlp3s0 state: up mac: <filter> 
  Device-2: Realtek RTL8111/8168/8411 PCI Express Gigabit Ethernet 
  driver: r8168 v: 8.045.08-NAPI port: d000 bus ID: 04:00.2 
  IF: enp4s0f2 state: down mac: <filter> 
  Device-3: IMC Networks Atheros AR3012 Bluetooth 4.0 Adapter type: USB 
  driver: usb-network bus ID: 3-1.1:3 
  IF-ID-1: tun0 state: unknown speed: 10 Mbps duplex: full mac: N/A 
Drives:
  Local Storage: total: 931.51 GiB used: 15.22 GiB (1.6%) 
  ID-1: /dev/sda vendor: Toshiba model: MQ01ABD100 size: 931.51 GiB 
Partition:
  ID-1: / size: 907.23 GiB used: 15.22 GiB (1.7%) fs: ext4 dev: /dev/sda1 
  ID-2: swap-1 size: 8.80 GiB used: 0 KiB (0.0%) fs: swap dev: /dev/sda2 
Sensors:
  System Temperatures: cpu: 66.0 C mobo: N/A 
  Fan Speeds (RPM): cpu: 3500 
Info:
  Processes: 156 Uptime: 7m Memory: 5.71 GiB used: 1.11 GiB (19.5%) 
  Init: systemd Compilers: gcc: 8.2.1 Shell: bash v: 4.4.23 inxi: 3.0.21 

Have you also tried this guide?

I'm not dual-booting right now. I only have Manjaro installed.

I see that your graphics is not set up. It would not explain your problem, but it could add to it. Also try older kernels (4.9, 4.4, etc). Did you perhaps edit configs (think about: mkinitcpio.conf, grub, etc.) or disabled a service from systemd?

There could also be a problem with your entropy pool. You could try enabling haveged.service.

sudo pacman -S haveged
sudo systemctl enable haveged.service
sudo systemctl start haveged.service

I'm using the free drivers. I still had these problems with nonfree drivers too.

disabled a service from systemd?

Yes, I disabled the ModemManager.service hoping that it would help with the boot time -which did not help :D- and no, I haven't edited any config files.

Will try that. I will post here if problems persist.

Regarding graphics the xf86-video-intel package and possibly this could be needed.

Thank you for your help.

Maybe it is just my hardware? idk.

Yup. I replaced my RAM and everything is back to normal now. It was my hardware all along.

2 Likes

This topic was automatically closed 30 days after the last reply. New replies are no longer allowed.

Forum kindly sponsored by