[SOLVED] QCA9377 Wifi is dead

Hi everybody,
I've been using Manjaro 18.0 on a Lenovo Ideapad 310 with an AtherosQCA9377 for some time without issues, but since yesterday I am unable to connect to any wifi network, actually I can't even detect them (left-click on NetworkManager applet only shows Ethernet Networks and VPN Connections).
I tried a few things, but I can't understand what happened:
1)Right-click on NetworkManager applet: it says network and notifications are enabled.

2)Here is part of the "lspci" command output: "02:00.0 Network controller: Qualcomm Atheros QCA9377 802.11ac Wireless Network Adapter (rev 30)"

3)Here is the output of "ip a":

1:lo: <LOOPBACK,UP,LOWER_UP> mtu 65536 qdisc noqueue state UNKNOWN group default qlen 1000
    link/loopback 00:00:00:00:00:00 brd 00:00:00:00:00:00
    inet 127.0.0.1/8 scope host lo
       valid_lft forever preferred_lft forever
    inet6 ::1/128 scope host 
       valid_lft forever preferred_lft forever
2: enp1s0: <BROADCAST,MULTICAST,UP,LOWER_UP> mtu 1500 qdisc fq_codel state UP group default qlen 1000
    link/ether c8:5b:76:28:7d:da brd ff:ff:ff:ff:ff:ff
    inet 10.175.133.171/15 brd 10.175.255.255 scope global dynamic noprefixroute enp1s0
       valid_lft 708sec preferred_lft 708sec
    inet6 2a00:1508:1:f010:fd59:58f:d86f:7e46/64 scope global dynamic noprefixroute 
       valid_lft 1779sec preferred_lft 1779sec
    inet6 fe80::3820:be0:622e:5c58/64 scope link noprefixroute 
       valid_lft forever preferred_lft forever

4)Here is the output of "dmesg | grep ath10k":

[   13.937355] ath10k_pci 0000:02:00.0: pci irq msi oper_irq_mode 2 irq_mode 0 reset_mode 0
[   14.369152] ath10k_pci 0000:02:00.0: Direct firmware load for ath10k/pre-cal-pci-0000:02:00.0.bin failed with error -2
[   14.369163] ath10k_pci 0000:02:00.0: Direct firmware load for ath10k/cal-pci-0000:02:00.0.bin failed with error -2
[   14.459214] ath10k_pci 0000:02:00.0: qca9377 hw1.0 target 0x05020000 chip_id 0x003820ff sub 17aa:4035
[   14.459216] ath10k_pci 0000:02:00.0: kconfig debug 0 debugfs 1 tracing 0 dfs 0 testmode 0
[   14.459660] ath10k_pci 0000:02:00.0: firmware ver WLAN.TF.2.1-00021-QCARMSWP-1 api 6 features wowlan,ignore-otp crc32 42e41877
[   17.526675] ath10k_pci 0000:02:00.0: unable to read from the device
[   17.526677] ath10k_pci 0000:02:00.0: could not execute otp for board id check: -110
[   17.526711] ath10k_pci 0000:02:00.0: failed to get board id from otp: -110
[   17.526756] ath10k_pci 0000:02:00.0: could not probe fw (-110)

Can you help me?
Thanks in advance C:

Lots of problems and tons of threads on this card. See this one solved today, or use the forum search engine to turn up many more.

1 Like

I tried to search for other threads regarding this topic, but I couldn't find any. My bad:)
I tried runningt the script but I all I get is "Cannot find device "wlp2s0".
Anyway I'm using xfce, if you could tell me how to set the script to execute automatically that would be very useful.
Thanks:)

Honest question - what did you search for?

This search shows multiple relevant threads: https://archived.forum.manjaro.org/search?q=qca9377

You can not use the same script if your adapter ID is different. You need to substitute your adapter ID into the script for “wlp2s0”.

Please post the output of tbe following commands:

hwinfo --netcard --wlan --bluetooth | grep -Ei "model\:|driver\:|status\:|cmd\:|file\:|detected\:" | grep -v "Config Status" 
inxi -Fxxxz

Did you read the entire thread, or simply the posted solution, there is more than 1 issue with thar adapter?

I searched on search engines writing "Manjaro forum", probably not a good idea, sorry again.
The output of the first command is:

Model: "Qualcomm Atheros QCA9377 802.11ac Wireless Network Adapter"
  Driver: "ath10k_pci"
    Driver Status: ath10k_pci is active
    Driver Activation Cmd: "modprobe ath10k_pci"
  Model: "Realtek RTL8111/8168/8411 PCI Express Gigabit Ethernet Controller"
  Driver: "r8168"
  Device File: enp1s0
  Link detected: yes
    Driver Status: r8169 is not active
    Driver Activation Cmd: "modprobe r8169"
    Driver Status: r8168 is active
    Driver Activation Cmd: "modprobe r8168"
  Model: "Qualcomm Atheros Bluetooth Device"
  Driver: "btusb"
    Driver Status: btusb is active
    Driver Activation Cmd: "modprobe btusb"

The output of the second one is:

System:    Host: lorenzo-pc Kernel: 4.14.85-1-MANJARO x86_64 bits: 64 compiler: gcc v: 8.2.1 
           Desktop: N/A wm: xfwm4 dm: LightDM 1.28.0 Distro: Manjaro Linux 
Machine:   Type: Laptop System: LENOVO product: 80SM v: Lenovo ideapad 310-15ISK serial: <filter> 
           Chassis: type: 10 v: Lenovo ideapad 310-15ISK serial: <filter> 
           Mobo: LENOVO model: Toronto 5A2 v: SDK0J40709 WIN serial: <filter> UEFI: LENOVO v: 0XCN44WW 
           date: 04/12/2018 
Battery:   ID-1: BAT0 charge: 13.8 Wh condition: 25.9/30.0 Wh (86%) volts: 7.3/7.4 model: SMP L15M2PB3 
           type: Li-poly serial: <filter> status: Discharging 
CPU:       Topology: Dual Core model: Intel Core i7-6500U bits: 64 type: MT MCP arch: Skylake rev: 3 
           L2 cache: 4096 KiB 
           flags: lm nx pae sse sse2 sse3 sse4_1 sse4_2 ssse3 vmx bogomips: 20744 
           Speed: 500 MHz min/max: 400/3100 MHz Core speeds (MHz): 1: 500 2: 500 3: 500 4: 500 
Graphics:  Device-1: Intel Skylake GT2 [HD Graphics 520] vendor: Lenovo driver: i915 v: kernel 
           bus ID: 00:02.0 chip ID: 8086:1916 
           Device-2: NVIDIA GM108M [GeForce 920MX] driver: N/A bus ID: 03:00.0 chip ID: 10de:134f 
           Display: x11 server: X.org 1.20.3 driver: intel resolution: <xdpyinfo missing> 
           OpenGL: renderer: Mesa DRI Intel HD Graphics 520 (Skylake GT2) v: 4.5 Mesa 18.2.6 
           compat-v: 3.0 direct render: Yes 
Audio:     Device-1: Intel Sunrise Point-LP HD Audio vendor: Lenovo driver: snd_hda_intel v: kernel 
           bus ID: 00:1f.3 chip ID: 8086:9d70 
           Sound Server: ALSA v: k4.14.85-1-MANJARO 
Network:   Device-1: Realtek RTL8111/8168/8411 PCI Express Gigabit Ethernet vendor: Lenovo 
           driver: r8168 v: 8.045.08-NAPI port: 4000 bus ID: 01:00.0 chip ID: 10ec:8168 
           IF: enp1s0 state: up speed: 100 Mbps duplex: full mac: <filter> 
           Device-2: Qualcomm Atheros QCA9377 802.11ac Wireless Network Adapter vendor: Lenovo 
           driver: ath10k_pci v: kernel port: 4000 bus ID: 02:00.0 chip ID: 168c:0042 
           Device-3: Qualcomm Atheros type: USB driver: btusb bus ID: 1-7:4 chip ID: 0cf3:e360 
Drives:    Local Storage: total: 1.82 TiB used: 18.87 GiB (1.0%) 
           ID-1: /dev/sda vendor: Seagate model: ST2000LM003 HN-M201RAD size: 1.82 TiB speed: 6.0 Gb/s 
           rotation: 5400 rpm serial: <filter> rev: 0001 scheme: GPT 
Partition: ID-1: / size: 47.00 GiB used: 14.85 GiB (31.6%) fs: ext4 dev: /dev/sda5 
           ID-2: /home size: 54.87 GiB used: 4.00 GiB (7.3%) fs: ext4 dev: /dev/sda6 
           ID-3: swap-1 size: 1024.0 MiB used: 0 KiB (0.0%) fs: swap dev: /dev/sda4 
Sensors:   System Temperatures: cpu: 31.0 C mobo: N/A 
           Fan Speeds (RPM): N/A 
Info:      Processes: 162 Uptime: 20m Memory: 7.70 GiB used: 1.07 GiB (13.9%) Init: systemd v: 239 
           Compilers: gcc: 8.2.1 Shell: bash v: 4.4.23 running in: xfce4-terminal inxi: 3.0.27

Update to kernel 4.19 through Manjaro settings manager. Did you read the entire thread, the solution also involves being on the right kernel for the version of firmware you are using.

I thought "pacman -Syu" was supposed to update the kernel too, anyway updating through Manjaro Settings Manager fixed it, the wifi is working again.
Thank you very very very very much for your quick and exhaustive replies:)

1 Like

“pacman -Syu” only updates your currently installed kernel, it does not install every new kernel.

So you searched for "manjaro forum" ?

I want to know why people don't/can't find information so I can make the site easier if possible.

I searched (on DuckDuckGo) a lot of things including:
"Manjaro forum" Atheros QAC9377
"manjaro forum" wifi atheros QAC9377
"manjaro forum" wifi not working

Next time I'll go to the forum and use the search tool included

1 Like

That might explain it. If you mistype a keyword you won't find the relevant information. OK, good to know.

1 Like

This topic was automatically closed 30 days after the last reply. New replies are no longer allowed.

Forum kindly sponsored by