[SOLVED] R8168 Wired network connection not working

Hello, I'm having an issue with the wired network connection. A couple of weeks ago it was working fine but after doing some changes in the resolv.conf and resolv.conf.head files now I cannot connect by cable. It gets stuck at getting network address.

I have the distribution 18.0.4

Using lspci on net:

3b:00.0 Ethernet controller: Realtek Semiconductor Co., Ltd. RTL8111/8168/8411 PCI Express Gigabit Ethernet Controller (rev 15)
3c:00.0 Network controller: Intel Corporation Wireless 8265 / 8275 (rev 78)

Checking the journal:

policy: auto-activating connection 'New 802-3-ethernet connection' (f367efa7-85a1-466e-b6c2-fa177b01c46c)
may 20 04:43:38 Amroth-pc NetworkManager[498]: [1558349018.0611] device (enp59s0): Activation: starting connection 'New 802-3-ethernet connection' (f367efa7-85a1-466e-b6c2-fa177b01c46c)
may 20 04:43:38 Amroth-pc NetworkManager[498]: [1558349018.0613] device (enp59s0): state change: disconnected -> prepare (reason 'none', sys-iface-state: 'managed')
may 20 04:43:38 Amroth-pc NetworkManager[498]: [1558349018.0618] manager: NetworkManager state is now CONNECTING
may 20 04:43:38 Amroth-pc NetworkManager[498]: [1558349018.0827] device (enp59s0): state change: prepare -> config (reason 'none', sys-iface-state: 'managed')
may 20 04:43:38 Amroth-pc NetworkManager[498]: [1558349018.0831] device (enp59s0): state change: config -> ip-config (reason 'none', sys-iface-state: 'managed')
may 20 04:43:38 Amroth-pc NetworkManager[498]: [1558349018.0833] dhcp4 (enp59s0): activation: beginning transaction (timeout in 45 seconds)
may 20 04:43:45 Amroth-pc NetworkManager[498]: [1558349025.0857] device (enp59s0): state change: ip-config -> unavailable (reason 'carrier-changed', sys-iface-state: 'managed')
may 20 04:43:45 Amroth-pc NetworkManager[498]: [1558349025.1121] dhcp4 (enp59s0): canceled DHCP transaction
may 20 04:43:45 Amroth-pc NetworkManager[498]: [1558349025.1121] dhcp4 (enp59s0): state changed unknown -> done
may 20 04:43:45 Amroth-pc NetworkManager[498]: [1558349025.1157] manager: NetworkManager state is now DISCONNECTED

My wireless connection is quite bad so Im struggling with it because I cant connect to the wired one.

Thanks

Edit: Dump your "inxi -Fxxxza --no-host" here and bookmark it

Edit2: solution presented failed after some minutes

you might have the same nic as me...this is my inxi -n

Network:   Device-1: Realtek RTL8111/8168/8411 PCI Express Gigabit Ethernet driver: r8169 
           IF: enp6s0 state: up speed: 1000 Mbps duplex: full mac: 18:31:bf:30:51:48 

you could go into Manajro settings manager, remove the r8168 then when you reboot it should load the r8169 driver.....
not saying it'll fix it but you'll avoid problems with later kernels :wink:
and fingers crossed it might just fix your problem...
Edit: after that I'd do a 'sudo pacman -Syyu' to update everything......

2 Likes

Oh great!! Thank you, that worked :sweat_smile::joy: have a nice day

1 Like

you too dude, my invoice is in the post.......:crazy_face:

Sad to say it failed after some minutes, not working again :frowning:

policy: auto-activating connection 'Wired connection' (f367efa7-85a1-466e-b6c2-fa177b01c46c)
may 20 05:27:19 Amroth-pc NetworkManager[518]: [1558351639.3281] device (enp59s0): Activation: starting connection 'Wired connection' (f367efa7-85a1-466e-b6c2-fa177b01c46c)
may 20 05:27:19 Amroth-pc NetworkManager[518]: [1558351639.3283] device (enp59s0): state change: disconnected -> prepare (reason 'none', sys-iface-state: 'managed')
may 20 05:27:19 Amroth-pc NetworkManager[518]: [1558351639.3334] device (enp59s0): state change: prepare -> config (reason 'none', sys-iface-state: 'managed')
may 20 05:27:19 Amroth-pc NetworkManager[518]: [1558351639.3349] device (enp59s0): state change: config -> ip-config (reason 'none', sys-iface-state: 'managed')
may 20 05:27:19 Amroth-pc NetworkManager[518]: [1558351639.3353] dhcp4 (enp59s0): activation: beginning transaction (timeout in 45 seconds)
may 20 05:27:25 Amroth-pc NetworkManager[518]: [1558351645.3405] device (enp59s0): state change: ip-config -> unavailable (reason 'carrier-changed', sys-iface-state: 'managed')
may 20 05:27:25 Amroth-pc NetworkManager[518]: [1558351645.3643] dhcp4 (enp59s0): canceled DHCP transaction
may 20 05:27:25 Amroth-pc NetworkManager[518]: [1558351645.3644] dhcp4 (enp59s0): state changed unknown -> done
may 20 05:27:26 Amroth-pc NetworkManager[518]: [1558351646.8869] device (enp59s0): state change: unavailable -> unmanaged (reason 'removed', sys-iface-state: 'removed')
may 20 05:27:27 Amroth-pc NetworkManager[518]: [1558351647.0189] manager: (eth0): new Ethernet device (/org/freedesktop/NetworkManager/Devices/5)
may 20 05:27:27 Amroth-pc NetworkManager[518]: [1558351647.0413] device (eth0): interface index 4 renamed iface from 'eth0' to 'enp59s0'
may 20 05:27:27 Amroth-pc NetworkManager[518]: [1558351647.0522] device (enp59s0): state change: unmanaged -> unavailable (reason 'managed', sys-iface-state: 'external')

Just change the blacklist from 8169 to 8168 - that is what I do on a clevo system.

1 Like

How and why?

in /etc/modprobe.d/

there is a couple of threads on the why - search is your friend

1 Like

Open any file located in /etc/modprobe.d and ensure there is no reference to r8169.

Any file that contains the line:

blacklist r8169

Change to:

blacklist r8168

Save the edited conf file with root permissions, and then reboot

1 Like

I don't have any r8169 reference in modprobe.d, there's a mhwd-bbswith.conf file and a mhwd-nvidia.conf, both with no references to it.

Please post the output of the following command:

grep -r "blacklist\|install\|options"  /etc/modprobe.d/ /etc/modules-load.d/ /usr/lib/modprobe.d/ 

/etc/modprobe.d/mhwd-nvidia.conf:blacklist nouveau
/etc/modprobe.d/mhwd-nvidia.conf:blacklist nvidia
/etc/modprobe.d/mhwd-nvidia.conf:blacklist nvidia-modeset
/etc/modprobe.d/mhwd-nvidia.conf:blacklist nvidia-uvm
/etc/modprobe.d/mhwd-nvidia.conf:blacklist ttm
/etc/modprobe.d/mhwd-nvidia.conf:blacklist drm_kms_helper
/etc/modprobe.d/mhwd-nvidia.conf:blacklist drm
/etc/modprobe.d/mhwd-bbswitch.conf:options bbswitch load_state=0 unload_state=0
/usr/lib/modprobe.d/bumblebee.conf:blacklist nvidia
/usr/lib/modprobe.d/bumblebee.conf:blacklist nvidia-drm
/usr/lib/modprobe.d/bumblebee.conf:blacklist nvidia-modeset
/usr/lib/modprobe.d/bumblebee.conf:blacklist nvidia-uvm
/usr/lib/modprobe.d/bumblebee.conf:blacklist nouveau
/usr/lib/modprobe.d/systemd.conf:options bonding max_bonds=0
/usr/lib/modprobe.d/systemd.conf:options dummy numdummies=0
/usr/lib/modprobe.d/uvesafb.conf:# options uvesafb mode=x[-][@] scroll=<ywrap|ypan|redraw> ...
/usr/lib/modprobe.d/uvesafb.conf:options uvesafb mode_option=1024x768-32 scroll=ywrap
/usr/lib/modprobe.d/nvdimm-security.conf:install libnvdimm /usr/bin/ndctl load-keys ; /sbin/modprobe --ignore-install libnvdimm $CMDLINE_OPTS
/usr/lib/modprobe.d/bluetooth-usb.conf:options btusb reset=1

Please post the output of the following command:

hwinfo --netcard --wlan --bluetooth | grep -Ei "model\:|driver\:|status\:|cmd\:|file\:|detected\:" | grep -v "Config Status"

:|detected:" | grep -v "Config Status"
Model: "Realtek RTL8111/8168/8411 PCI Express Gigabit Ethernet Controller"
Driver: "r8169"
Device File: enp59s0
Link detected: no
Driver Status: r8169 is active
Driver Activation Cmd: "modprobe r8169"
Model: "Intel Wireless 8265 / 8275"
Driver: "iwlwifi"
Device File: wlp60s0
Link detected: yes
Driver Status: iwlwifi is active
Driver Activation Cmd: "modprobe iwlwifi"
Model: "Intel Bluetooth Device"
Driver: "btusb"
Driver Status: btusb is active
Driver Activation Cmd: "modprobe btusb"

cat /etc/resolv.conf

The problem is it's only working with Wifi, wired connection is not even showing now.

Generated by NetworkManager

search ucr.ac.cr
nameserver 163.178.88.2
nameserver 163.178.84.2
nameserver 2801:15:800f:ffff:cfff:ffff:ffff:ffd2

Change /etc/resolv.conf to this:

#search ucr.ac.cr
#nameserver 163.178.88.2
#nameserver 163.178.84.2
#nameserver 2801:15:800f:ffff:cfff:ffff:ffff:ffd2
nameserver 1.1.1.1
nameserver 1.0.0.1

Save, then reboot both your router and computer.

I will work on raising your adapter next.

When you have restarted please post:

lsmod | grep r816

lsmod | grep r816
r8169 86016 0
libphy 77824 3 r8169,realtek

Adapter is still down?

Forum kindly sponsored by