[SOLVED] R8168 Wired network connection not working

it is, in manjaro settings Manager, network-r9168 is not installed, there doesnt appear to be any other controller for it available. I installed it before but then uninstalled it again to check if the driver 169 would click, it hasnt.

image

Turn your wifi off via the function key, airplane mode etc.

Reboot with the wifi turned off.

Save the instructions below and run them after you reboot with no wifi on.

Run the set of commands below to see if your connection can be properly initiated.

Please do not cut and paste all the commands together at once.

Enter and run each command separately with a few seconds between each command.

Please post all inputs, and all outputs of that sequence of commands once they are finished being run.

Please do not give me a summary, such as "there were no outputs".

It is very important that you post each input and output for troubleshooting purposes.

nmcli networking off

sudo systemctl stop NetworkManager

sudo ip link set enp59s0 down

sudo modprobe -r r8168

sudo modprobe -r r8169

sudo modprobe r8169

sudo ip link set enp59s0 mode default

sudo ip link set enp59s0 up

sudo systemctl start NetworkManager

nmcli networking on

nmcli r wifi off

nmcli r wifi on

Turn your wifi back on if the LAN connection is not working, then post all the outputs from those commands.

nmcli networking off
[gabriel@Amroth-pc modprobe.d]$ sudo systemctl stop NetworkManager
[sudo] password for gabriel:
[gabriel@Amroth-pc modprobe.d]$ sudo ip link set enp59s0 down
[gabriel@Amroth-pc modprobe.d]$ sudo modprobe -r r8168
modprobe: FATAL: Module r8168 not found.
[gabriel@Amroth-pc modprobe.d]$ sudo modprobe -r r8169
[gabriel@Amroth-pc modprobe.d]$ sudo modprobe r8169
[gabriel@Amroth-pc modprobe.d]$ sudo ip link set enp59s0 mode default
[gabriel@Amroth-pc modprobe.d]$ sudo ip link set enp59s0 up
[gabriel@Amroth-pc modprobe.d]$ sudo systemctl start NetworkManager
[gabriel@Amroth-pc modprobe.d]$ nmcli networking on
[gabriel@Amroth-pc modprobe.d]$ nmcli r wifi on
[gabriel@Amroth-pc modprobe.d]$ nmcli r wifi off

And was there any change in the network status?

Please post the output of the following command:

hwinfo --netcard --wlan --bluetooth | grep -Ei "model\:|driver\:|status\:|cmd\:|file\:|detected\:" | grep -v "Config Status"

Still no signal from the wired connection.

Model: "Realtek RTL8111/8168/8411 PCI Express Gigabit Ethernet Controller"
Driver: "r8169"
Device File: enp59s0
Link detected: no
Driver Status: r8169 is active
Driver Activation Cmd: "modprobe r8169"
Model: "Intel Wireless 8265 / 8275"
Driver: "iwlwifi"
Device File: wlp60s0
Link detected: yes
Driver Status: iwlwifi is active
Driver Activation Cmd: "modprobe iwlwifi"
Model: "Intel Bluetooth Device"
Driver: "btusb"
Driver Status: btusb is active
Driver Activation Cmd: "modprobe btusb"

I would install and test kenel 5.0.

if not working

then install kernel 5.1

Install kernels through Manjaro Settings Manager, and always have at least two kernels installed at all times for safety.

It works now, I disconnected from the wifi again just to be sure and now it's working again, thank you very much. Visually the wired connection doesnt show in the network window, so it just connects to the wired one. In system settings module it does appear and it connecting so all good.

Thank you.

1 Like

Have you swapped in alternate cables and tested other ports on the router. Are the lights on-the back of the LAN connection on the back of the computer lit.

Glad to hear it's working now. You had me worried there for a bit.

1 Like

Me two, not sure what to check as to solved, swapping drivers?

Hard to say, because a lot of things were tested out. Take your pick. You want to check that you have different IP addresses being assigned to both adapters. They could be conflicting and causing problems. I would suggest disabling WiFi if using LAN, and vice versa.

Yep, I'm gonna keep doing that and get a second kernel.

1 Like

This topic was automatically closed 90 days after the last reply. New replies are no longer allowed.

Forum kindly sponsored by