[SOLVED] Random wifi card deauthentifications

Hello everyone ^^
I have many problems with my wifi connection in Manjaro, especially with the kernel 414.
The problem is sometimes I lost my connection randomly.

[  188.216244] wlp2s0: deauthenticated from 8c:f8:13:39:e9:fe (Reason: 2=PREV_AUTH_NOT_VALID)
[  189.214756] wlp2s0: authenticate with 8c:f8:13:39:e9:fe
[  189.218176] wlp2s0: send auth to 8c:f8:13:39:e9:fe (try 1/3)
[  189.222053] wlp2s0: authenticated
[  189.224971] wlp2s0: associate with 8c:f8:13:39:e9:fe (try 1/3)
[  189.229675] wlp2s0: RX AssocResp from 8c:f8:13:39:e9:fe (capab=0x431 status=0 aid=2)
[  189.235706] wlp2s0: associated
[  193.691136] wlp2s0: deauthenticated from 8c:f8:13:39:e9:fe (Reason: 2=PREV_AUTH_NOT_VALID)
[  197.330981] wlp2s0: authenticate with 8c:f8:13:39:e9:fe
[  197.334725] wlp2s0: send auth to 8c:f8:13:39:e9:fe (try 1/3)

(I have this text a lot of times in my dmesg.)
I already disabled the wifi card's power service by changing this in /etc/default/tlp

# WiFi power saving mode: on=enable, off=disable; not supported by all adapters.
WIFI_PWR_ON_AC=off
WIFI_PWR_ON_BAT=on

by

# WiFi power saving mode: on=enable, off=disable; not supported by all adapters.
WIFI_PWR_ON_AC=off
WIFI_PWR_ON_BAT=off

And also I think I have more problems when my bluetooth earphones are connected (maybe it's just an impression)
Here is my inxi -Fxz

System:    Host: TheDevKiller-PC-Manjaro Kernel: 4.19.2-1-MANJARO x86_64 bits: 64 compiler: gcc v: 8.2.1 Desktop: i3 4.16 
           Distro: Manjaro Linux 
Machine:   Type: Laptop System: Micro-Star product: CX62 6QD v: REV:1.0 serial: <filter> 
           Mobo: Micro-Star model: MS-16J6 v: REV:1.0 serial: <filter> UEFI [Legacy]: American Megatrends v: E16J6IMS.104 
           date: 01/19/2016 
Battery:   ID-1: BAT1 charge: 11.1 Wh condition: 32.1/43.2 Wh (74%) model: MSI Corp. MS-16J6 status: Discharging 
CPU:       Topology: Dual Core model: Intel Core i3-6100H bits: 64 type: MT MCP arch: Skylake-S rev: 3 L2 cache: 3072 KiB 
           flags: lm nx pae sse sse2 sse3 sse4_1 sse4_2 ssse3 vmx bogomips: 21704 
           Speed: 800 MHz min/max: 800/2700 MHz Core speeds (MHz): 1: 800 2: 800 3: 802 4: 800 
Graphics:  Device-1: Intel HD Graphics 530 vendor: Micro-Star MSI driver: i915 v: kernel bus ID: 00:02.0 
           Device-2: NVIDIA GM108M [GeForce 940MX] vendor: Micro-Star MSI driver: N/A bus ID: 01:00.0 
           Display: x11 server: X.Org 1.20.3 driver: intel resolution: 1366x768~60Hz 
           OpenGL: renderer: Mesa DRI Intel HD Graphics 530 (Skylake GT2) v: 4.5 Mesa 18.2.5 direct render: Yes 
Audio:     Device-1: Intel Sunrise Point-H HD Audio vendor: Micro-Star MSI driver: snd_hda_intel v: kernel bus ID: 00:1f.3 
           Sound Server: ALSA v: k4.19.2-1-MANJARO 
Network:   Device-1: Intel Wireless 3165 driver: iwlwifi v: kernel port: e000 bus ID: 02:00.0 
           IF: wlp2s0 state: up mac: <filter> 
           Device-2: Qualcomm Atheros QCA8171 Gigabit Ethernet vendor: Micro-Star MSI driver: alx v: kernel port: d000 
           bus ID: 03:00.0 
           IF: enp3s0 state: down mac: <filter> 
Drives:    Local Storage: total: 465.76 GiB used: 124.28 GiB (26.7%) 
           ID-1: /dev/sda vendor: Western Digital model: WD5000LPCX-22VHAT0 size: 465.76 GiB 
Partition: ID-1: / size: 183.89 GiB used: 124.28 GiB (67.6%) fs: ext4 dev: /dev/sda3 
Sensors:   System Temperatures: cpu: 41.0 C mobo: N/A 
           Fan Speeds (RPM): N/A 
Info:      Processes: 155 Uptime: 37m Memory: 3.77 GiB used: 1.29 GiB (34.1%) Init: systemd Compilers: gcc: 8.2.1 Shell: zsh 
           v: 5.6.2 inxi: 3.0.27```

Try different driver options.

Create:

/etc/modprobe.d/iwlwifi.conf

With the content of the file as following:

options iwlwifi 11n_disable=1 
options iwlwifi swcrypto=1
options iwlwifi power_save=0 
options iwlwifi d0i3_disable=0 
options iwlwifi uapsd_disable=0

You can place a comment "#" before any option to deactivate it.

Has the adapter ever worked well on any Linux distribution, because this adapter does not have a good reputation for stability.

1 Like

I tried it I don't have problems for now so I'll see later if it changes anything.

start with the crypto one only. Then try power save. etc.
(ex: it would be best if you kept N enabled if you can)

Please post the options you are using so others know which worked for you.

Glad you got it working.

What do you mean by the crypto one ?

^^^ this

options iwlwifi swcrypto=1

It is the most likely culprit and has next to 0 drawbacks .. so try with that alone.

I don't got it working. In fact, I don't know because sometimes I don't have any problem (it's the case now). What options do you want ?

I think I'll keep

options iwlwifi 11n_disable=1 
options iwlwifi swcrypto=1
options iwlwifi power_save=0 
options iwlwifi d0i3_disable=0 
options iwlwifi uapsd_disable=0

And see if it works. If it works, I'll be too lazy to change this later ^^

Thats your right in a free world :slight_smile:
[ it aint but we can dream cant we? first our computers - tomorrow the commons! :sweat_smile: ]

Its just a few things like the 11n_disable option means you wont have that wireless protocol .. meaning you might get slower speeds. So, it may be worth trying to avoid. But hey, again, thats up to you.

Oh, my connection is already too slow :sweat_smile: I think I'll remove this so

You could try this option instead if you want to experiment with which options work best.

options iwlwifi 11n_disable=8

At the risk of stating the obvious here, but in my humble experience the vast majority of WiFi problems are router/network based, rather than WiFi card/device driver based.

Not once in your posts here have you told us whether or not you have tried your WiFi at other routers/networks. That is the first thing I would do before assuming software issues. A couple of free WiFi coffee shops for instance??

1 Like

I have this with all the networks and I don't have this on my tablet with the sames AP. I'm think it's only my PC

Also I don't have this problem now (maybe it's fixed, I don't know) but I have another problem, my connection becomes very slow when I connect my bluetooth earphones. Should I make another post ?

bt_coex maybe.

Now I have things like

 wlp2s0: disconnect from AP 00:17:33:42:cd:14 for new auth to 00:13:33:ff:f2:c6
[ 8658.015818] wlp2s0: authenticate with 00:13:33:ff:f2:c6
[ 8658.019652] wlp2s0: send auth to 00:13:33:ff:f2:c6 (try 1/3)
[ 8658.042715] wlp2s0: authenticated
[ 8658.042910] iwlwifi 0000:02:00.0 wlp2s0: disabling HE/HT/VHT due to WEP/TKIP use
[ 8658.046044] wlp2s0: associate with 00:13:33:ff:f2:c6 (try 1/3)
[ 8658.061415] wlp2s0: RX ReassocResp from 00:13:33:ff:f2:c6 (capab=0x411 status=0 aid=2)
[ 8658.081683] wlp2s0: associated

What is bt_coex ?

Forum kindly sponsored by