[SOLVED] RTL8821CE on Asus TUF gaming FX705DY

Hi everyone! I was searching on this forum but did not find the answer to my problem. I can not make my wi-fi module work. I already have installed rtl8821ce-dkms-git package. Btw I have dual-boot with Win10 on my laptop. Here is inxi -Fxxxz --no-host

System:    Kernel: 5.2.8-pf x86_64 bits: 64 compiler: gcc v: 9.1.0 Desktop: KDE Plasma 5.16.4 
           tk: Qt 5.13.0 wm: kwin_x11 dm: SDDM Distro: Manjaro Linux 
Machine:   Type: Laptop System: ASUSTeK product: TUF Gaming FX705DY_FX705DY v: 1.0 
           serial: <filter> 
           Mobo: ASUSTeK model: FX705DY v: 1.0 serial: <filter> UEFI: American Megatrends 
           v: FX705DY.311 date: 06/27/2019 
Battery:   ID-1: BAT0 charge: 60.8 Wh condition: 60.8/64.0 Wh (95%) volts: 15.6/15.6 
           model: ASUSTeK ASUS Battery type: Li-ion serial: <filter> status: Not charging 
CPU:       Topology: Quad Core model: AMD Ryzen 5 3550H with Radeon Vega Mobile Gfx bits: 64 
           type: MT MCP arch: Zen+ rev: 1 L2 cache: 2048 KiB 
           flags: avx avx2 lm nx pae sse sse2 sse3 sse4_1 sse4_2 sse4a ssse3 svm bogomips: 33537 
           Speed: 1223 MHz min/max: 1400/2100 MHz boost: enabled Core speeds (MHz): 1: 1668 
           2: 1650 3: 1287 4: 1886 5: 1307 6: 1897 7: 1231 8: 1260 
Graphics:  Device-1: AMD Baffin [Radeon RX 460/560D / Pro 450/455/460/555/555X/560/560X] 
           vendor: ASUSTeK driver: amdgpu v: kernel bus ID: 01:00.0 chip ID: 1002:67ef 
           Device-2: AMD Picasso vendor: ASUSTeK driver: amdgpu v: kernel bus ID: 04:00.0 
           chip ID: 1002:15d8 
           Display: x11 server: X.Org 1.20.5 driver: amdgpu FAILED: ati unloaded: modesetting 
           alternate: fbdev,vesa compositor: kwin_x11 resolution: 1920x1080~60Hz 
           OpenGL: renderer: AMD RAVEN (DRM 3.32.0 5.2.8-pf LLVM 8.0.1) v: 4.5 Mesa 19.1.5 
           direct render: Yes 
Audio:     Device-1: AMD Raven/Raven2/Fenghuang HDMI/DP Audio vendor: ASUSTeK 
           driver: snd_hda_intel v: kernel bus ID: 04:00.1 chip ID: 1002:15de 
           Device-2: AMD Family 17h HD Audio vendor: ASUSTeK driver: snd_hda_intel v: kernel 
           bus ID: 04:00.6 chip ID: 1022:15e3 
           Sound Server: ALSA v: k5.2.8-pf 
Network:   Device-1: Realtek RTL8821CE 802.11ac PCIe Wireless Network Adapter vendor: AzureWave 
           driver: N/A port: e000 bus ID: 02:00.0 chip ID: 10ec:c821 
           Device-2: Realtek RTL8111/8168/8411 PCI Express Gigabit Ethernet vendor: ASUSTeK 
           driver: r8169 v: kernel port: d000 bus ID: 03:00.0 chip ID: 10ec:8168 
           IF: enp3s0 state: down mac: <filter> 
           IF-ID-1: enp4s0f3u3 state: unknown speed: N/A duplex: N/A mac: <filter> 
Drives:    Local Storage: total: 931.51 GiB used: 37.18 GiB (4.0%) 
           ID-1: /dev/sda vendor: Toshiba model: MQ04ABF100 size: 931.51 GiB speed: 6.0 Gb/s 
           rotation: 5400 rpm serial: <filter> rev: 0J scheme: GPT 
Partition: ID-1: / size: 388.11 GiB used: 37.15 GiB (9.6%) fs: ext4 dev: /dev/sda6 
Sensors:   System Temperatures: cpu: 40.8 C mobo: N/A 
           Fan Speeds (RPM): N/A 
           GPU: device: amdgpu temp: 40 C device: amdgpu temp: 43 C 
Info:      Processes: 240 Uptime: 15m Memory: 7.53 GiB used: 3.34 GiB (44.4%) Init: systemd v: 242 
           Compilers: gcc: 9.1.0 clang: 8.0.1 Shell: fish v: 3.0.2 running in: konsole 
           inxi: 3.0.36

Did you install the correct Linux headers package.

sudo pacman -S linux52-headers
4 Likes

Yes, i have pf-kernel btw.

What is the source of that kernel.

I would suggest installing the normal 5.3 kernel from the Manjaro repositories. Then install the proper kernel headers.

sudo pacman -S linux53-headers

Then when on kernel 5.3 reinstall the driver.

Try 4.19 and repeat if no success with more recent kernels.

1 Like


I can install 5.3 but it`s only experimental. Are you sure about it?
image

I think you should stick to installing kernels only with Manjaro Settings Manager. You can try kernel 4.19, 5.2, or 5.3. None of those should cause your computer to burst into flames.

Be sure to install the specific headers for each kernel. Also rebuild the driver on each kernel if it is not working correctly.

2 Likes

Ok, you can mark this problem as Solved, i don`t know how, but i forgot to install linux-pf-headers. So Im installed it and now wi-fi works properly.

1 Like

This topic was automatically closed 90 days after the last reply. New replies are no longer allowed.

Forum kindly sponsored by