[SOLVED] Secondary Wifi Dongle not prompting for password

Hi Community!

I have a Sony Vaio Fit 14 laptop with a Broadcom integrated WiFi adapter which never worked on Ubuntu/Mint. Therefore I have been using a WiFi dongle with a Qualcomm Atheros chip.

I've installed the Manjaro i3 community release. During the installation, the Broadcom adapter didn't work, but that didn't bother me. I can keep using the dongle after all.

After installation finished, I plugged in the dongle and tried to connect to my network. By default, the Broadcom adapter (which does not work - it asks for the password indefinitely) is selected.

My problem is: When I change it to Qualcomm Atheros, the field to type in the network password disappears.

The Broadcom is displayed as status "dormant" and the Atheros is "down". I tried sudo ip link set [atheros-name] up but it stays down.

I'm going to try and get the output of inxi -Fx and paste it here as a reply in a moment, since I'm writing this from Windows.

Please let me know if you need anything else, and thank you very much for your time!

When booting up leave the usb adapter unplugged. Maybe @tbg will get that thing running.

Thank you @calvous.

I started Manjaro with the usb dongle unplugged and ran inxi -Fx. This is the output:

System:    Host: yaiyaichu-manjaro-pc Kernel: 4.14.67-1-MANJARO x86_64 bits: 64 compiler: gcc v: 8.2.0 
           Desktop: i3 4.15.0.1 Distro: Manjaro Linux 
Machine:   Type: Laptop System: Sony product: SVF14A16CLB v: CA001U3X serial: 54576278-0001594 
           Mobo: Sony model: VAIO serial: N/A UEFI [Legacy]: Insyde v: R0220DA date: 11/18/2013 
Battery:   ID-1: BAT1 charge: 19.0 Wh condition: 19.0/44.2 Wh (43%) model: SONY Corp. VGP-BPS34 status: Full 
CPU:       Topology: Dual Core model: Intel Core i5-3337U bits: 64 type: MT MCP arch: Ivy Bridge rev: 9 
           L2 cache: 3072 KiB 
           flags: lm nx pae sse sse2 sse3 sse4_1 sse4_2 ssse3 vmx bogomips: 14374 
           Speed: 798 MHz min/max: 800/2700 MHz Core speeds (MHz): 1: 799 2: 799 3: 798 4: 800 
Graphics:  Device-1: Intel 3rd Gen Core processor Graphics driver: i915 v: kernel bus ID: 00:02.0 
           Display: server: X.Org 1.20.1 driver: intel unloaded: modesetting 
           resolution: 1600x900~60Hz, 1360x768~60Hz 
           OpenGL: renderer: Mesa DRI Intel Ivybridge Mobile v: 4.2 Mesa 18.1.7 direct render: Yes 
Audio:     Device-1: Intel 7 Series/C216 Family High Definition Audio driver: snd_hda_intel v: kernel 
           bus ID: 00:1b.0 
           Sound Server: ALSA v: k4.14.67-1-MANJARO 
Network:   Device-1: Broadcom Limited BCM43142 802.11b/g/n driver: wl v: kernel bus ID: 07:00 
           IF: wlp7s0 state: dormant mac: 32:a9:82:70:d6:0e 
           Device-2: Realtek RTL8111/8168/8411 PCI Express Gigabit Ethernet driver: r8168 v: 8.045.08-NAPI 
           port: 2000 bus ID: 0e:00 
           IF: enp14s0 state: down mac: 00:13:a9:70:0f:34 
Drives:    Local Storage: total: 447.13 GiB used: 41.91 GiB (9.4%) 
           ID-1: /dev/sda vendor: Kingston model: SA400S37480G size: 447.13 GiB 
Partition: ID-1: / size: 190.93 GiB used: 7.16 GiB (3.8%) fs: ext4 dev: /dev/sda3 
           ID-2: swap-1 size: 8.00 GiB used: 0 KiB (0.0%) fs: swap dev: /dev/sda4 
Sensors:   System Temperatures: cpu: 52.0 C mobo: N/A 
           Fan Speeds (RPM): N/A 
Info:      Processes: 146 Uptime: N/A Memory: 7.68 GiB used: 297.3 MiB (3.8%) Init: systemd Compilers: 
           gcc: 8.2.0 Shell: bash v: 4.4.23 inxi: 3.0.21 

I am not saying it is impossible to get the 43142 adapter working in Linux, but it is the worst Broadcom adapter for Linux support. Very few get that adapter working with adequate performance. You might be able get it working, but it generally drops connections constantly.

I have numerous posts on the forum dealing with that adapter and a dormant adapter. Use the search function to find suggested solutions. In all honesty I can't justify spending time trying to fix an adapter that is notorious for not working properly in Linux.

@tbg sounds reasonable. What do you think about my Qualcomm Atheros wifi dongle?
That one is not working either because I don't get a password field to try to connect when I select it instead of the Broadcom. Also, it appears as down in inxi -Fx and doesn't go up when I run sudo ip link set [name] up.

Are there any chances to make that one work in Manjaro?

There was a recent firmware issue with the QCA9377 Atheros adapter. If this is your adapter model use this fix.

If that is not your adapter we we will need to know your adapters model. Try identifying it on the live boot disk.

From inxi I get that my adapter is

Device-3: Qualcomm Atheros AR9271 802.11n type: USB driver: ath9k_htc 
           IF: wlp0s20u2u2 state: down mac: 6a:6b:60:7c:af:4e

is that useful enough? Or should I boot with the live disk and throw some command?

PD: Surprisingly, the Ethernet adapter doesn't seem to be working either.

For future reference when you are requested to provide an output please do not edit the response because you are only prolonging the troubleshooting process.

If you had posted the output I requested I would know several recommendations I could definitively make, now I will have to guess as to my advice.

Install kernels 4.18, 4.19, and 4.14 and test for operation of your adapters. Install all kernels through Manjaro settings manager. Always have at least two kernels installed.

If your wired adapter is rtl8168, blacklist the rtl8168 module. Remove the blacklist on rtl8169 and reboot.

Thanks, I'll keep that in mind.

I just solved it by removing the Broadcom driver. This seems to have forced the wifi manager applet to let me input the password for when connecting with the Atheros adapter.

Before it was removing the password field whenever I switched from Broadcom to Atheros in the network manager GUI menu, but now it's using the Atheros directly.

Thanks @tbg

1 Like

Forum kindly sponsored by