[Solved] Several issues since May 26th update

Hi dear community,

I will try to do my best to explain what is going wrong since last update.
I did last update thru TTY, and did not have any issue.
Right after applying the update, I fist notice the lock screen (possibly GDM?) is not active anymore when resume from sleep. It just seems the option of typing my pwd is just off, no freeze/bug.
I noticed in Settings -> Privacy -> Lock screen is grey out
Post here mention a solution I'm not able to apply


Four weeks ago I've installed optimus-switch with the help of @dgit, and everything was working well. But after last Manjaro update, I noticed an over-consumption of my laptop once I resume from sleep. Facts are that after sleep, in Intel mode, consumption is higher (7/8 W) than before sleep (4/5 W). Nvidia is also showing up in powertop at 100%.
100,0% PCI Device: NVIDIA Corporation GM108M [GeForce 930MX]
Something breaks the optimus-switch power control over the GPU as it should be 0%

Last, I have an 2 network issues as my bluetooth mousse that could not get synchronize at all. And also it is impossible to connect via Ethernet after suspend.:disappointed:

I try to boot on kernel 5.0.18 and 4.19.45 but no luck. I did not try the RT kernel as some threads here might suggest to get rid of the bluetooth issue.
Also disable all Gnome extensions and reboot: no luck neither
Any help is appreciated

thats odd, the MX series are pretty good with power management and usually disable themselves given there are no nvidia modules loaded and the power management set to "auto"

when you setup optimus-switch did the turn-off-gpu.sh scripts return a "Works!" result?
if your not sure, run it again (from intel mode)

post output of these commands (intel mode):

inxi -Fxxxz
systemctl status disable-nvidia.service
sudo /usr/share/acpi_call/examples/turn_off_gpu.sh
ls -laR /etc/X11
cat /etc/X11/xorg.conf.d/*.conf
cat /etc/modprobe.d/*.conf
cat /etc/modules-load.d/*.conf
cat /etc/switch/intel/no-optimus.sh

as for the lock screen, i dont know, it's been a while since i used gnome.

Hi dglt !
Here's all you ask
I did all these commands after resuming from sleep, so it should show the Nvidia GPU

philippe@Probook-450 ~]$ inxi -Fxxxz
System:    Host: Probook-450 Kernel: 5.0.18-1-MANJARO x86_64 bits: 64 compiler: gcc v: 8.3.0 
           Desktop: Gnome 3.32.2 wm: gnome-shell dm: GDM 3.32.0 Distro: Manjaro Linux 
Machine:   Type: Laptop System: HP product: HP ProBook 450 G5 v: N/A serial: <filter> Chassis: type: 10 
           serial: <filter> 
           Mobo: HP model: 837D v: KBC Version 02.32.00 serial: <filter> UEFI: HP v: Q85 Ver. 01.06.00 
           date: 01/03/2019 
Battery:   ID-1: BAT0 charge: 24.3 Wh condition: 42.0/42.0 Wh (100%) volts: 12.4/11.4 
           model: Hewlett-Packard Primary type: Li-ion serial: <filter> status: Charging 
CPU:       Topology: Quad Core model: Intel Core i5-8250U bits: 64 type: MT MCP arch: Kaby Lake rev: A 
           L2 cache: 6144 KiB 
           flags: avx avx2 lm nx pae sse sse2 sse3 sse4_1 sse4_2 ssse3 vmx bogomips: 28808 
           Speed: 3400 MHz min/max: 400/3400 MHz Core speeds (MHz): 1: 3400 2: 3401 3: 3400 4: 3400 
           5: 3400 6: 3400 7: 3401 8: 3400 
Graphics:  Device-1: Intel UHD Graphics 620 vendor: Hewlett-Packard driver: i915 v: kernel bus ID: 00:02.0 
           chip ID: 8086:5917 
           Device-2: NVIDIA GM108M [GeForce 930MX] vendor: Hewlett-Packard driver: N/A bus ID: 01:00.0 
           chip ID: 10de:134e 
           Display: x11 server: X.Org 1.20.4 driver: N/A compositor: gnome-shell 
           resolution: 1920x1080~60Hz 
           OpenGL: renderer: Mesa DRI Intel UHD Graphics 620 (Kabylake GT2) v: 4.5 Mesa 19.0.4 
           compat-v: 3.0 direct render: Yes 
Audio:     Device-1: Intel Sunrise Point-LP HD Audio vendor: Hewlett-Packard driver: snd_hda_intel 
           v: kernel bus ID: 00:1f.3 chip ID: 8086:9d71 
           Sound Server: ALSA v: k5.0.18-1-MANJARO 
Network:   Device-1: Realtek RTL8111/8168/8411 PCI Express Gigabit Ethernet vendor: Hewlett-Packard 
           driver: r8168 v: 8.047.01-NAPI port: 3000 bus ID: 02:00.0 chip ID: 10ec:8168 
           IF: enp2s0 state: down mac: <filter> 
           Device-2: Intel Wireless 8265 / 8275 driver: iwlwifi v: kernel port: 3000 bus ID: 03:00.0 
           chip ID: 8086:24fd 
           IF: wlp3s0 state: up mac: <filter> 
Drives:    Local Storage: total: 577.55 GiB used: 110.18 GiB (19.1%) 
           ID-1: /dev/sda vendor: Kingston model: SA400S37120G size: 111.79 GiB speed: 6.0 Gb/s 
           serial: <filter> rev: B1D1 scheme: GPT 
           ID-2: /dev/sdb vendor: Samsung model: SSD 850 EVO M.2 500GB size: 465.76 GiB speed: 6.0 Gb/s 
           serial: <filter> rev: 1B6Q scheme: GPT 
Partition: ID-1: / size: 152.80 GiB used: 31.14 GiB (20.4%) fs: ext4 dev: /dev/sdb2 
           ID-2: swap-1 size: 8.29 GiB used: 0 KiB (0.0%) fs: swap dev: /dev/sdb8 
Sensors:   System Temperatures: cpu: 47.0 C mobo: 44.0 C 
           Fan Speeds (RPM): N/A 
Info:      Processes: 280 Uptime: 45m Memory: 7.68 GiB used: 1.88 GiB (24.4%) Init: systemd v: 242 
           Compilers: gcc: 8.3.0 Shell: bash v: 5.0.7 running in: gnome-terminal inxi: 3.0.34 
philippe@Probook-450 ~]$ systemctl status disable-nvidia.service
â—Ź disable-nvidia.service - run root script at resume
   Loaded: loaded (/etc/systemd/system/disable-nvidia.service; enabled; vendor preset: disabled)
   Active: inactive (dead) since Fri 2019-05-31 23:17:05 CEST; 45min ago
  Process: 743 ExecStart=/usr/bin/sleep 8 (code=exited, status=0/SUCCESS)
  Process: 1131 ExecStart=/usr/local/bin/optimus.sh (code=exited, status=0/SUCCESS)
 Main PID: 1131 (code=exited, status=0/SUCCESS)

mai 31 23:16:57 Probook-450 systemd[1]: Starting run root script at resume...
mai 31 23:17:05 Probook-450 optimus.sh[1131]: Can't open display
mai 31 23:17:05 Probook-450 systemd[1]: disable-nvidia.service: Succeeded.
mai 31 23:17:05 Probook-450 systemd[1]: Started run root script at resume.
[philippe@Probook-450 ~]$ 
[philippe@Probook-450 ~]$ sudo /usr/share/acpi_call/examples/turn_off_gpu.sh
[sudo] Mot de passe de philippe : 
Trying \_SB.PCI0.P0P1.VGA._OFF: /usr/share/acpi_call/examples/turn_off_gpu.sh: ligne 39: avertissement :substitution de commande: octet nul ignoré en entrée
failed
Trying \_SB.PCI0.P0P2.VGA._OFF: /usr/share/acpi_call/examples/turn_off_gpu.sh: ligne 39: avertissement :substitution de commande: octet nul ignoré en entrée
failed
Trying \_SB_.PCI0.OVGA.ATPX: /usr/share/acpi_call/examples/turn_off_gpu.sh: ligne 39: avertissement :substitution de commande: octet nul ignoré en entrée
failed
Trying \_SB_.PCI0.OVGA.XTPX: /usr/share/acpi_call/examples/turn_off_gpu.sh: ligne 39: avertissement :substitution de commande: octet nul ignoré en entrée
failed
Trying \_SB.PCI0.P0P3.PEGP._OFF: /usr/share/acpi_call/examples/turn_off_gpu.sh: ligne 39: avertissement :substitution de commande: octet nul ignoré en entrée
failed
Trying \_SB.PCI0.P0P2.PEGP._OFF: /usr/share/acpi_call/examples/turn_off_gpu.sh: ligne 39: avertissement :substitution de commande: octet nul ignoré en entrée
failed
Trying \_SB.PCI0.P0P1.PEGP._OFF: /usr/share/acpi_call/examples/turn_off_gpu.sh: ligne 39: avertissement :substitution de commande: octet nul ignoré en entrée
failed
Trying \_SB.PCI0.MXR0.MXM0._OFF: /usr/share/acpi_call/examples/turn_off_gpu.sh: ligne 39: avertissement :substitution de commande: octet nul ignoré en entrée
failed
Trying \_SB.PCI0.PEG1.GFX0._OFF: /usr/share/acpi_call/examples/turn_off_gpu.sh: ligne 39: avertissement :substitution de commande: octet nul ignoré en entrée
failed
Trying \_SB.PCI0.PEG0.GFX0.DOFF: /usr/share/acpi_call/examples/turn_off_gpu.sh: ligne 39: avertissement :substitution de commande: octet nul ignoré en entrée
failed
Trying \_SB.PCI0.PEG1.GFX0.DOFF: /usr/share/acpi_call/examples/turn_off_gpu.sh: ligne 39: avertissement :substitution de commande: octet nul ignoré en entrée
failed
Trying \_SB.PCI0.PEG0.PEGP._OFF: /usr/share/acpi_call/examples/turn_off_gpu.sh: ligne 39: avertissement :substitution de commande: octet nul ignoré en entrée
failed
Trying \_SB.PCI0.XVR0.Z01I.DGOF: /usr/share/acpi_call/examples/turn_off_gpu.sh: ligne 39: avertissement :substitution de commande: octet nul ignoré en entrée
failed
Trying \_SB.PCI0.PEGR.GFX0._OFF: /usr/share/acpi_call/examples/turn_off_gpu.sh: ligne 39: avertissement :substitution de commande: octet nul ignoré en entrée
failed
Trying \_SB.PCI0.PEG.VID._OFF: /usr/share/acpi_call/examples/turn_off_gpu.sh: ligne 39: avertissement :substitution de commande: octet nul ignoré en entrée
failed
Trying \_SB.PCI0.PEG0.VID._OFF: /usr/share/acpi_call/examples/turn_off_gpu.sh: ligne 39: avertissement :substitution de commande: octet nul ignoré en entrée
failed
Trying \_SB.PCI0.P0P2.DGPU._OFF: /usr/share/acpi_call/examples/turn_off_gpu.sh: ligne 39: avertissement :substitution de commande: octet nul ignoré en entrée
failed
Trying \_SB.PCI0.P0P4.DGPU.DOFF: /usr/share/acpi_call/examples/turn_off_gpu.sh: ligne 39: avertissement :substitution de commande: octet nul ignoré en entrée
failed
Trying \_SB.PCI0.IXVE.IGPU.DGOF: /usr/share/acpi_call/examples/turn_off_gpu.sh: ligne 39: avertissement :substitution de commande: octet nul ignoré en entrée
failed
Trying \_SB.PCI0.RP00.VGA._PS3: /usr/share/acpi_call/examples/turn_off_gpu.sh: ligne 39: avertissement :substitution de commande: octet nul ignoré en entrée
failed
Trying \_SB.PCI0.RP00.VGA.P3MO: /usr/share/acpi_call/examples/turn_off_gpu.sh: ligne 39: avertissement :substitution de commande: octet nul ignoré en entrée
failed
Trying \_SB.PCI0.GFX0.DSM._T_0: /usr/share/acpi_call/examples/turn_off_gpu.sh: ligne 39: avertissement :substitution de commande: octet nul ignoré en entrée
failed
Trying \_SB.PCI0.LPC.EC.PUBS._OFF: /usr/share/acpi_call/examples/turn_off_gpu.sh: ligne 39: avertissement :substitution de commande: octet nul ignoré en entrée
failed
Trying \_SB.PCI0.P0P2.NVID._OFF: /usr/share/acpi_call/examples/turn_off_gpu.sh: ligne 39: avertissement :substitution de commande: octet nul ignoré en entrée
failed
Trying \_SB.PCI0.P0P2.VGA.PX02: /usr/share/acpi_call/examples/turn_off_gpu.sh: ligne 39: avertissement :substitution de commande: octet nul ignoré en entrée
failed
Trying \_SB_.PCI0.PEGP.DGFX._OFF: /usr/share/acpi_call/examples/turn_off_gpu.sh: ligne 39: avertissement :substitution de commande: octet nul ignoré en entrée
failed
Trying \_SB_.PCI0.VGA.PX02: /usr/share/acpi_call/examples/turn_off_gpu.sh: ligne 39: avertissement :substitution de commande: octet nul ignoré en entrée
failed
Trying \_SB.PCI0.PEG0.PEGP.SGOF: /usr/share/acpi_call/examples/turn_off_gpu.sh: ligne 39: avertissement :substitution de commande: octet nul ignoré en entrée
failed
Trying \_SB.PCI0.AGP.VGA.PX02: /usr/share/acpi_call/examples/turn_off_gpu.sh: ligne 39: avertissement :substitution de commande: octet nul ignoré en entrée
failed
[philippe@Probook-450 ~]$ 
philippe@Probook-450 ~]$ ls -laR /etc/X11
/etc/X11:
total 40
drwxr-xr-x   5 root root  4096 28 oct.   2018 .
drwxr-xr-x 111 root root 12288 31 mai   23:29 ..
drwxr-xr-x   2 root root  4096 30 mai   01:21 mhwd.d
drwxr-xr-x   3 root root  4096 13 mars  22:05 xinit
drwxr-xr-x   2 root root  4096 30 mai   01:21 xorg.conf.d

/etc/X11/mhwd.d:
total 12
drwxr-xr-x 2 root root 4096 30 mai   01:21 .
drwxr-xr-x 5 root root 4096 28 oct.   2018 ..

/etc/X11/xinit:
total 28
drwxr-xr-x 3 root root 4096 13 mars  22:05 .
drwxr-xr-x 5 root root 4096 28 oct.   2018 ..
-rw-r--r-- 1 root root  739  4 mars  19:31 xinitrc
drwxr-xr-x 2 root root 4096 21 mai   22:54 xinitrc.d
-rw-r--r-- 1 root root   45  4 mars  19:31 xserverrc

/etc/X11/xinit/xinitrc.d:
total 20
drwxr-xr-x 2 root root 4096 21 mai   22:54 .
drwxr-xr-x 3 root root 4096 13 mars  22:05 ..
-rwxr-xr-x 1 root root  318  9 nov.   2018 40-libcanberra-gtk-module.sh
-rwxr-xr-x 1 root root  203 11 mai   13:13 50-systemd-user.sh

/etc/X11/xorg.conf.d:
total 20
drwxr-xr-x 2 root root 4096 30 mai   01:21 .
drwxr-xr-x 5 root root 4096 28 oct.   2018 ..
-rw-r--r-- 1 root root  311 29 déc.  21:46 00-keyboard.conf
-rw-r--r-- 1 root root  672 30 mai   01:21 99-intel.conf
[philippe@Probook-450 ~]$
[philippe@Probook-450 ~]$ cat /etc/X11/xorg.conf.d/*.conf
# Written by systemd-localed(8), read by systemd-localed and Xorg. It's
# probably wise not to edit this file manually. Use localectl(1) to
# instruct systemd-localed to update it.
Section "InputClass"
        Identifier "system-keyboard"
        MatchIsKeyboard "on"
        Option "XkbLayout" "fr"
EndSection
# xorg configuration for use with intel driver.
# xf86-video-intel package required
#
# This driver now uses DRI3 as the default Direct Rendering
# Infrastructure. You can try falling back to DRI2 if you run
# into trouble. To do so, save a file with the following 
# content as /etc/X11/xorg.conf.d/20-intel.conf :
 
    Section "Device"
        Identifier  "Intel Graphics"
        Driver      "intel"
        Option      "DRI" "3"             # DRI2 and DRI1 are alternatives if DRI3 performs performs poorly
        Option      "TearFree" "True"
        #Option      "AccelMethod"  "sna" # default
        #Option      "AccelMethod"  "uxa" # fallback
     EndSection
[philippe@Probook-450 ~]$
[philippe@Probook-450 ~]$ cat /etc/modprobe.d/*.conf
#blacklists all nouveau/nvidia modules
#so they are not loaded.

blacklist nouveau
blacklist ttm
install nvidia /bin/false
install nvidia-modeset /bin/false
install nvidia-drm /bin/false
install nvidia-uvm /bin/false

#######################################
#this following section can be removed#
#if you plan to use the modesetting   #
#driver intead of the intel driver    #
#######################################

#stops display from "blinking" or "flashing"
#during boot when using the intel driver.

options i915 enable_fbc=1
options i915 fastboot=1

blacklist r8169
[philippe@Probook-450 ~]
[philippe@Probook-450 ~]$ cat /etc/modules-load.d/*.conf
vboxdrv
vboxnetadp
vboxnetflt
vboxpci
# List of modules to load at boot
[philippe@Probook-450 ~]$
philippe@Probook-450 ~]$ cat /etc/switch/intel/no-optimus.sh
#!/bin/sh

#this script is run as a display setup script
#that replaces the one used by nvidia/prime.
##
#this powers-down/disables the nvidia dGPU and
#removes it from /sys/bus/pce/devices
#for the current boot. this is reset after reboot.
# PLEASE READ BELOW TO ENABLE THIS

xrandr --auto
echo 'auto' > '/sys/bus/pci/devices/0000:01:00.0/power/control'  #adjust busid if needed

#############
##make sure the line below is the correct acpi_call to disable your nvidia gpu. 
#to find out what call disables your nvidia gpu,
#run this (not while using nvidia gpu, this is why i left it commented out.
#
#` sudo /usr/share/acpi_call/examples/turn_off_gpu.sh ` 
#
#and see which acpi_call is returned as "works!" and then uncomment and edit this file to match.
#same goes for the the BusID of nvidia card, 
#default is set to 0000:01:00.0 (syntax is important) 
#if your nvidia gpu has a 1:0:1 busID, just uncomment the line, no change needed.

#echo '\_SB.PCI0.PEG0.PEGP._OFF' > /proc/acpi/call 
echo -n 1 > '/sys/bus/pci/devices/0000:01:00.0/remove'
[philippe@Probook-450 ~]$ 

At install time, the output of the turn_off_gpu script was all failed!, like today

For bluetooth: test the real time kernels

For wired LAN suspend issues:

1 Like

the MX series cards so far have not needed an acpi call to be powered down but thats not the only thing that doesnt make sense.

after waking from suspend, the nvidia gpu should still not be visible, and even if sysfs rescans for devices there is a service that runs the no-optimus script after waking from suspend.

sudo nano /etc/mkinitcpio.conf
find/edit this line

MODULES="intel_agp i915"

save/exit
sudo mkinitcpio -P
sudo update-grub

thats actually copy/paste from my mkinitcpio.conf

1 Like

Yep, I will

Wow, never did system service before... I will have to dig a bit for a "howto".
And thank you for showing me the possible solution.
As I dont know so much about how linux works, I'm wondering if this network issues will be solved in the next update, then what about the 2 NetworkManager scripts ? Will have to remove or disable it manually ?

Thank you for helping me again!

Yes, it was working fine before the last update, and the Nvidia GPU was not visible in Intel mode

Well, it's not working, reboot twice and verify the modification done on file mkinitcpio.conf. I do not need to input my pwd.
I try first closing the lid (no change) and then with the suspend key (w/ moon icon). And with the suspend key, I was surprise that even if the led was blinking as it does in normal sleep, I was able to resume from suspend by pressing the return keyboard key. That's mean the sleeping process was NOT really on, as far as I know. Will have to look closer for real computer sleep method.
Just checking Powertop, it still show up Nvidia Ă  100%, always in Intel mode
Don't know what to do next :expressionless:
Maybe some install broke something ? I installed Virtualbox before the Manjaro update.
I made a (small) mistake installing cuda for dev before Manjaro update, and I had to download around 3 Go when updating. After the update, I remove cuda for dev with pamac.
To be complete I also installed intel-media-driver, is it conflicting with libva-intel-driver ?
Don't know if this will help

i think it's more probable to assume that it's a GDM issue and not a situation where suspend doesnt work. i would read logs and gdm output before/after suspend. give these a read and see if you find what your looking for.
https://wiki.archlinux.org/index.php/Power_management/Suspend_and_hibernate
https://wiki.archlinux.org/index.php/Session_lock
https://wiki.archlinux.org/index.php/GDM

also, when your trying different kernels for the networking issue, also test the gpu/suspend issue on each kernel and see if the unwanted behavior goes away.

also also, when something stops working with gdm/gnome, always start by disabling any/all extensions before doing anything else, and reset gdm to it's original configuration.

Your problem can usually be fixed with a single service file for suspend and resume. The service below will likely fix your suspend issue:
It is generally better to use the r8169 kernel driver rather than the r8168 driver. You can easily switch to the r8169 kernel driver with this command:

sudo mhwd -r pci network-r8168 

Then reboot:

After switching to the r8169 driver, if you are still experiencing issues you can create a service to hopefully resolve suspend problems related to your adapter.

Network Restart Service

Create the following file with a root capable text editor:

/etc/systemd/system/network-restart.service

Add the following contents to the file:

#/etc/systemd/system/network-restart.service
#sudo systemctl enable network-restart.service
#sudo systemctl start network-restart.service
#sudo systemctl stop network-restart.service
#sudo systemctl disable network-restart.service
#systemctl status network-restart.service

[Unit]
Description=Network Suspend/Resume Service 
Before=sleep.target
StopWhenUnneeded=yes

[Service]
User=root
Type=oneshot
RemainAfterExit=yes
ExecStartPre=-/usr/bin/sudo -u $USER /bin/bash -lc 'nmcli networking off'
ExecStart=/usr/bin/sleep 1
ExecStart=-/usr/bin/systemctl stop NetworkManager
ExecStart=/usr/bin/sleep 1
ExecStart=-/usr/bin/ip link set enp2s0 down
ExecStart=/usr/bin/sleep 1
ExecStart=-/usr/bin/modprobe -r r8169
ExecStop=-/usr/bin/modprobe r8169
ExecStop=/usr/bin/sleep 2
ExecStop=-/usr/bin/ip link set enp2s0 up
ExecStop=/usr/bin/sleep 2
ExecStop=-/usr/bin/systemctl start NetworkManager
ExecStop=/usr/bin/sleep 1
ExecStop=-/usr/bin/sudo -u $USER /bin/bash -lc 'nmcli networking on'

[Install]
WantedBy=sleep.target

The sleep units in the service may be reduced, (or eliminated) if you do not like the delay it creates. Be aware though, that doing so may reduce the reliability of the service.

Once you have created and saved the service file, enable the service:

sudo systemctl enable network-restart.service

Then reboot the computer.


For others wishing to adapt this service to their installation (if different than above).

If your adapter's designation is different than “enp2s0” you will need to substitute you own adapter’s ID into the service file.

If you are using a different driver module you will also need to substitute it in place of “r8168” or “r8169”in the service file.

R8169 is the currently the recommended driver for this adapter. The r8168 driver should generally be uninstalled through Manjaro Settings Manger or the terminal command given above. I would highly suggest switching to the r8169 kernel module rather than using the r8168 driver.You can substitute "r8168" or "r8169" in the above service file depending on which driver you are using.

You can find your adapter driver/module and device ID to substitute in the service with the following command:

inxi -n

Alternate methods to switch to the r8169 driver:

The r8168 driver has been experiencing major problems lately.

The r8169 kernel module is now the preferred driver.

Follow the instructions below to get your LAN adapter working properly.

Uninstall the linuxXXX-r8168 driver:

Open Manjaro Settings Manager -> Hardware configuration -> Network controller

Right click on the RTL8111/8168/8411 ethernet device and select “Remove”.

After the uninstall process has finished, restart.

After you restart the computer, the 8169 kernel module should now be automatically loaded.

If the r8169 kernel module is not loaded automatically when you reboot (after uninstalling r8168) then do this:

Open any file located in /etc/modprobe.d and ensure there is no reference to r8169.

Any file that contains the line:

blacklist r8169

Change to:

blacklist r8168

Save the edited conf file with root permissions, and then reboot

Alternately, you may delete the conf file entirely, (if it only contains the entry "blacklist r8169").

Example:

If /etc/modprobe.d contains a file named r8169_blacklist.conf then you can delete it with this command:

sudo rm /etc/modprobe.d/r8169_blacklist.conf

Be very careful, you do not make any errors when using the "rm" command with sudo privileges.

Reboot after making any changes to files in /etc/modprobe.d.


5 Likes

Pretty brilliant explanations for my poor knowledge. Thank you !
I will do it as soon as possible, but to be sure of what I've got so far, is there typo in this sentence ?

I understand as : r8168 is an old fashion driver ; r8169 is brand new (automatic) kernel module.
Hope you say yes :roll_eyes:
Already found the '8169_blacklist.conf' file...

[philippe@Probook-450 ~]$ inxi -n
Network:
  Device-1: Realtek RTL8111/8168/8411 PCI Express Gigabit Ethernet 
  driver: r8168 
  IF: enp2s0 state: down mac: <filter> 
  Device-2: Intel Wireless 8265 / 8275 driver: iwlwifi 
  IF: wlp3s0 state: up mac: <filter> 
[philippe@Probook-450 ~]$ 

Yes, sorry I missed that typo. I edited it to be more clear.

Yes, you have the general gist of it. The kernel module will load automatically as long as it is not blacklisted.

You may find using the r8169 kernel module that your suspend issue goes away. If the driver switch fixes your suspend problem then there is no need to write a service.

Cheers.

All extensions are disable for now.
Well, I follow bogdancovaciu advice to do a reset


But no luck after reboot, than I have to do manually ALT+F2, r, enter show "rebooting" but nothing append...
Is there other ways to reset GDM in my case ? (did not find anything in the forum)

dconf-editor maybe? my memory of gnome is fuzzy :face_with_head_bandage:. i enjoyed using it at the time but i dont miss it by any means. sorry i cant be more helpful on that front.

Find "Manjaro Gnome Resetting Tool" app which aim to get a vanilla gnome session. Will try it later as I badly need my laptop tomorrow for a workshop. It has to work for two hours :wink:

Good news: 2 issues solved. Thanks tbg !
Reboot today on 5.0.14rt 9-1 kernel: bluetooth is working fine !
I did what you suggest to switch to r8169, and it automatically get installed. Ethernet is working fine even on resume after sleep !
And this file also disappear

/etc/modprobe.d/r8168_blacklist.conf

I even create the service file you advice me to do with r8169 text instead of r8168 . But I did not enable it at first. Ethernet and bluetooth was working fine after reboot, so I enable the
network-restart.service and reboot (w/ the rt kernel)
Computer was not able to finish boot and get stuck after grub :slight_smile:`

mount: /sys/firmware/efi/efivars: unknow filesystem type 'efivars'.
[   5.026905] 000: : BUG: scheduling while atomic:...
...

=> Hard reboot
So I came back to Kernel 5.0.18-1 without bluetooth and ethernet... Maybe I should try to stop and disable the network-restart.service ?:confused:

Will see. I hope other issues gets better with next updates (Nvidia driver always show up at 100% with powertop, and no lockscreen anymore :disappointed: )

Glad to hear your making some progress.

Disabling the service is very simple if you want:

sudo systemctl disable network-restart.service

Yes, I was guessing that, but wondering if it has to be stop first ?
And I feel stuck to the issues rather than progressing

Best practice is to stop it first but I don't think it matters that much. After disabling do a reboot.

I just disable the service and reboot but still the same message and no other way than a hard reboot. Back to kernel 5.0.18:

Edit: service is till loaded, should I remove the file ?

[philippe@Probook-450 ~]$ systemctl status network-restart.service
â—Ź network-restart.service - Network Suspend/Resume Service
   Loaded: loaded (/etc/systemd/system/network-restart.service; disabled; vendor preset: disabled)
   Active: inactive (dead)

What about the latest linux-firmware update, should I installed it ? or wait ?:thinking:

Forum kindly sponsored by