[Solved] Steam: Unity game: Party Panic - Game runs but screen is all glitchy

Edit: Cleaned up title and post. Figure I would update it on the off chance it could help some one too. Also marked the topic as solved since it now works. And thanks to everyone who replied, your help is very much appreciated.

I hope this is the right place to post this and sorry for the title, couldn't figure out a better way to word it. I am contacting the official support, but figure I will ask here and see if any one has any suggestions.

Recently got a game from steam, "Party Panic". The game will start and I can hear the audio playing fine but the screen is all glitchy. No graphics, just crazy colorful jagged random boxes and zigzags of random colors flash all over the screen, I can't take a screenshot, cause when I try the screenshot is just black. Now I have many other 3D games that play just fine, plus this game does have Linux support, so I don't know. I did a Google search but nothing helpful really came up. It does appear to be a unity game, and I have had problems with unity games before. Any help, suggestions or advice would be greatly appreciated.

Edit:
One thing that did work to get the game to run was to add
β€œ-screen-fullscreen 0”
to the launch options in Steam (In Steam, in your library, right click on the game and click properties, in the window that opens, inside the "general" tab, click "set launch options", and add "-screen-fullscreen 0" without the quotes). This worked for me, no promises it will work for everyone.

While this did get the game to run, performance was questionable. However, I have been in communication with the developer and he has been working on the issue. Already he has released updates in beta that you can opt into. And last time I tried, the game was working much better and the performance was good too (user results may vary). If I were to guess, I would say the problem was with unity more than anything else.

inxi output---->Dump your "inxi -Fxxxza --no-host" here and bookmark it

What does glinfo return? And just for grins, if you run glxgears do you see the 3 gears spinning? What is the FPS you get?

thank you for the reply.

glinfo returns this

GL_VERSION: 3.0 Mesa 17.3.0
GL_RENDERER: Radeon RX 580 Series (POLARIS10 / DRM 3.23.0 / 4.15.0-1-MANJARO, LLVM 5.0.0)
GL_VENDOR: X.Org
GL_EXTENSIONS: GL_ARB_multisample GL_EXT_abgr GL_EXT_bgra GL_EXT_blend_color GL_EXT_blend_minmax GL_EXT_blend_subtract GL_EXT_copy_texture GL_EXT_polygon_offset GL_EXT_subtexture GL_EXT_texture_object GL_EXT_vertex_array GL_EXT_compiled_vertex_array GL_EXT_texture GL_EXT_texture3D GL_IBM_rasterpos_clip GL_ARB_point_parameters GL_EXT_draw_range_elements GL_EXT_packed_pixels GL_EXT_point_parameters GL_EXT_rescale_normal GL_EXT_separate_specular_color GL_EXT_texture_edge_clamp GL_SGIS_generate_mipmap GL_SGIS_texture_border_clamp GL_SGIS_texture_edge_clamp GL_SGIS_texture_lod GL_ARB_framebuffer_sRGB GL_ARB_multitexture GL_EXT_framebuffer_sRGB GL_IBM_multimode_draw_arrays GL_IBM_texture_mirrored_repeat GL_ARB_texture_cube_map GL_ARB_texture_env_add GL_ARB_transpose_matrix GL_EXT_blend_func_separate GL_EXT_fog_coord GL_EXT_multi_draw_arrays GL_EXT_secondary_color GL_EXT_texture_env_add GL_EXT_texture_filter_anisotropic GL_EXT_texture_lod_bias GL_INGR_blend_func_separate GL_NV_blend_square GL_NV_light_max_exponent GL_NV_texgen_reflection GL_NV_texture_env_combine4 GL_S3_s3tc GL_SUN_multi_draw_arrays GL_ARB_texture_border_clamp GL_ARB_texture_compression GL_EXT_framebuffer_object GL_EXT_texture_compression_s3tc GL_EXT_texture_env_combine GL_EXT_texture_env_dot3 GL_MESA_window_pos GL_NV_packed_depth_stencil GL_NV_texture_rectangle GL_ARB_depth_texture GL_ARB_occlusion_query GL_ARB_shadow GL_ARB_texture_env_combine GL_ARB_texture_env_crossbar GL_ARB_texture_env_dot3 GL_ARB_texture_mirrored_repeat GL_ARB_window_pos GL_ATI_fragment_shader GL_EXT_stencil_two_side GL_EXT_texture_cube_map GL_NV_depth_clamp GL_NV_fog_distance GL_APPLE_packed_pixels GL_ARB_draw_buffers GL_ARB_fragment_program GL_ARB_fragment_shader GL_ARB_shader_objects GL_ARB_vertex_program GL_ARB_vertex_shader GL_ATI_draw_buffers GL_ATI_texture_env_combine3 GL_ATI_texture_float GL_EXT_depth_bounds_test GL_EXT_shadow_funcs GL_EXT_stencil_wrap GL_MESA_pack_invert GL_NV_primitive_restart GL_ARB_depth_clamp GL_ARB_fragment_program_shadow GL_ARB_half_float_pixel GL_ARB_occlusion_query2 GL_ARB_point_sprite GL_ARB_shading_language_100 GL_ARB_sync GL_ARB_texture_non_power_of_two GL_ARB_vertex_buffer_object GL_ATI_blend_equation_separate GL_EXT_blend_equation_separate GL_OES_read_format GL_ARB_color_buffer_float GL_ARB_pixel_buffer_object GL_ARB_texture_compression_rgtc GL_ARB_texture_float GL_ARB_texture_rectangle GL_ATI_texture_compression_3dc GL_EXT_packed_float GL_EXT_pixel_buffer_object GL_EXT_texture_compression_dxt1 GL_EXT_texture_compression_rgtc GL_EXT_texture_mirror_clamp GL_EXT_texture_rectangle GL_EXT_texture_sRGB GL_EXT_texture_shared_exponent GL_ARB_framebuffer_object GL_EXT_framebuffer_blit GL_EXT_framebuffer_multisample GL_EXT_packed_depth_stencil GL_ARB_vertex_array_object GL_ATI_separate_stencil GL_ATI_texture_mirror_once GL_EXT_draw_buffers2 GL_EXT_draw_instanced GL_EXT_gpu_program_parameters GL_EXT_texture_array GL_EXT_texture_compression_latc GL_EXT_texture_integer GL_EXT_texture_sRGB_decode GL_EXT_timer_query GL_OES_EGL_image GL_AMD_performance_monitor GL_ARB_copy_buffer GL_ARB_depth_buffer_float GL_ARB_draw_instanced GL_ARB_half_float_vertex GL_ARB_instanced_arrays GL_ARB_map_buffer_range GL_ARB_texture_rg GL_ARB_texture_swizzle GL_ARB_vertex_array_bgra GL_EXT_texture_swizzle GL_EXT_vertex_array_bgra GL_NV_conditional_render GL_AMD_conservative_depth GL_AMD_draw_buffers_blend GL_AMD_seamless_cubemap_per_texture GL_AMD_shader_stencil_export GL_ARB_ES2_compatibility GL_ARB_blend_func_extended GL_ARB_debug_output GL_ARB_draw_buffers_blend GL_ARB_draw_elements_base_vertex GL_ARB_explicit_attrib_location GL_ARB_fragment_coord_conventions GL_ARB_provoking_vertex GL_ARB_sample_shading GL_ARB_sampler_objects GL_ARB_seamless_cube_map GL_ARB_shader_stencil_export GL_ARB_shader_texture_lod GL_ARB_texture_cube_map_array GL_ARB_texture_gather GL_ARB_texture_multisample GL_ARB_texture_query_lod GL_ARB_texture_rgb10_a2ui GL_ARB_uniform_buffer_object GL_ARB_vertex_type_2_10_10_10_rev GL_ATI_meminfo GL_EXT_provoking_vertex GL_EXT_texture_snorm GL_MESA_texture_signed_rgba GL_NV_texture_barrier GL_ARB_get_program_binary GL_ARB_robustness GL_ARB_separate_shader_objects GL_ARB_shader_bit_encoding GL_ARB_shader_precision GL_ARB_texture_compression_bptc GL_ARB_timer_query GL_ARB_transform_feedback2 GL_ARB_transform_feedback3 GL_NV_vdpau_interop GL_ANGLE_texture_compression_dxt3 GL_ANGLE_texture_compression_dxt5 GL_ARB_base_instance GL_ARB_compressed_texture_pixel_storage GL_ARB_conservative_depth GL_ARB_internalformat_query GL_ARB_map_buffer_alignment GL_ARB_shader_atomic_counters GL_ARB_shader_image_load_store GL_ARB_shading_language_420pack GL_ARB_shading_language_packing GL_ARB_texture_storage GL_ARB_transform_feedback_instanced GL_EXT_framebuffer_multisample_blit_scaled GL_EXT_transform_feedback GL_AMD_shader_trinary_minmax GL_ARB_ES3_compatibility GL_ARB_arrays_of_arrays GL_ARB_clear_buffer_object GL_ARB_compute_shader GL_ARB_copy_image GL_ARB_explicit_uniform_location GL_ARB_framebuffer_no_attachments GL_ARB_invalidate_subdata GL_ARB_program_interface_query GL_ARB_robust_buffer_access_behavior GL_ARB_shader_image_size GL_ARB_shader_storage_buffer_object GL_ARB_stencil_texturing GL_ARB_texture_query_levels GL_ARB_texture_storage_multisample GL_ARB_texture_view GL_ARB_vertex_attrib_binding GL_KHR_debug GL_KHR_robustness GL_AMD_pinned_memory GL_ARB_bindless_texture GL_ARB_buffer_storage GL_ARB_clear_texture GL_ARB_compute_variable_group_size GL_ARB_internalformat_query2 GL_ARB_multi_bind GL_ARB_query_buffer_object GL_ARB_seamless_cubemap_per_texture GL_ARB_shader_draw_parameters GL_ARB_shader_group_vote GL_ARB_texture_mirror_clamp_to_edge GL_ARB_texture_stencil8 GL_ARB_vertex_type_10f_11f_11f_rev GL_EXT_shader_integer_mix GL_NVX_gpu_memory_info GL_ARB_clip_control GL_ARB_conditional_render_inverted GL_ARB_cull_distance GL_ARB_derivative_control GL_ARB_get_texture_sub_image GL_ARB_pipeline_statistics_query GL_ARB_shader_texture_image_samples GL_ARB_sparse_buffer GL_ARB_texture_barrier GL_ARB_transform_feedback_overflow_query GL_EXT_polygon_offset_clamp GL_KHR_context_flush_control GL_KHR_robust_buffer_access_behavior GL_ARB_shader_atomic_counter_ops GL_ARB_shader_ballot GL_ARB_shader_clock GL_KHR_no_error GL_MESA_shader_integer_functions GL_ARB_polygon_offset_clamp GL_ARB_texture_filter_anisotropic GL_EXT_memory_object GL_EXT_memory_object_fd 
GL_SHADING_LANGUAGE_VERSION = 1.30
GLU_VERSION: 1.3
GLU_EXTENSIONS: GLU_EXT_nurbs_tessellator GLU_EXT_object_space_tess 
GLUT_API_VERSION: 4
GLUT_XLIB_IMPLEMENTATION: 13

glxgears shows the 3 gears spinning nice and sturdy like, running at a constant 60fps.

The more I think about it, it seems like its just a problem with unity games(and unreal games too), even when they have linux support, other games have done the same thing as well(I'm sure I am wrong about all this though). Or its a problem with unity games and unreal games with manjaro and certain drivers? maybe, I don't know. some unity games do play though (gang beasts for example) but have an occasion graphical glitch here and there(nothing game breaking).

I was hoping that the GL driver was messed up or a lower version...but Mesa 17.3 supports OpenGL 4.5 and the game only needs 3.2...so you are good there.

Unfortunately my machine with a Radeon graphics card is at work, so I won't have access to it till Tuesday. Could you open the Manjaro Settings Manager, double click on on Hardware Configuration and post a screen shot of that window? I want to see what options you have for the display controller.

here you go, hope I got the right one.

Screenshot_20171221_205308

Yep, that's what I wanted, and it looks fine :confused: I thought there were more options...but I guess not.

As far as I can tell you video system is all hooked up correctly. The only think I can think of now is trying to going back to the LTS kernel 4.14 if possible.

Thank you for the reply, time and help. I will try another kernel in the morning, though I have a feeling I will be requesting a refund for this game. Perhaps in the future things will get better, since there are other games that do the same thing, linux games and windows through wine games, for quite awhile now, maybe its just because its arch linux?. anywho, my hands are tied up at the moment but when I get a chance I will try 4.14 and see if it changes any thing and report back.

yeah.. dont try a Development Kernel. Always stay at stable kernels if you want a working system.

Lets hope switching to a stable kernel will aready do the trick

Just tried it a little while ago, and sadly changing kernels does not make a difference. :disappointed:
One reason I was using the latest kernel, is I was told some time ago that it supports audio over HDMI, and I wanted to test it to make sure everything is stable, cause I will be visiting some family, and I was going to bring my PC to play some couch games. As a side note, with kernel 4.15, it also almost cleared up a boot problem I have been having(assuming its even kernel related, maybe it was another components update that helped, not sure). Not completely, it still happens but very rarely now. I have been meaning to make a topic to get help with it but I have not had time yet(between work and procrastination). Perhaps next week I will. I did contact the developers, will probably be a while till I get a reply though. I am guessing its a problem with the game it self as other games still work fine, but I dunno. Was just hoping to have another couch game for family time. No big deal if I can't get it working, there are other options, still would be nice if it did work(seems other Linux users can play it just fine on other ditros). Any way, I'm kind of rambling here. Thank you all for your time and help, I really appreciate it, if the developer has nothing, I'm thinking I will just refund it, time will tell.

p.s. the game does have a log file, if any one does not mind, I can post it here? I don't know if it has helpful info, I skimmed through it, buts its over my head at the moment.

1 Like

If there is a log nobody would say no :smiley: Maybe it helps somehow

I can't answer for a Radeon card but . audio through HDMI works just fine with an Nvidia card and kernel 4.14 .

There's quite a number of games that have updated recently after rebuilding with a new Unity3D version to fix graphical glitches; if other games work fine I suspect this one could do with being rebuilt too.

HDMI Audio will come to amdgpu with 4.15 (and DC enabled). He's right with that.

What a long day, any way, if any one is interested, I posted the log file on pastebin. I had to split it in half since I'm not a pro member on pastebin, I'm sure there's better options for posting files but none come to me at the moment.

https://pastebin.com/Ty6WuEyq
https://pastebin.com/JbRf4BE4

If the developer responds back, I will certainly ask this.

I gotta see if my other topic is still active about this and post it there(edit: nope, locked some time ago, oh well, no biggie), but on an unrelated note, the HDMI audio still would not work unless I changed the refresh rate from auto (which I am assuming is 60 Hz) to 59.94 Hz, under the "Display and Monitor" in system settings. This may be an issue with the reciever I have the HDMI going to, not sure, it was just a happy accedent I found this out.

And as always, thank you all for your kind help and time and replys, much appreciated.

1 Like

This definitely look like an issue with the game rather than Manjaro.

Well, so far the developer has been very helpful, its rare to see someone go out of their way to help their customers like he seems to. Though the game still wont run, but he said he will be updating unity soon, hopfully that will help. here's one of the e-mails he sent.

using β€œ-screen-fullscreen 0” did get the game to start but it keeps freezing(edit: no longer freezes, might have been something with manjaro, setting this command in launch options in steam did help the game run). Nothing else seemed to help however. Guess I will just wait and see what happens when he updates unity.

Thank you for your time looking into this, I appreciate it. Perhaps that is similar to what the developer was talking about with the issue with full screen.

Well I will wait and see, thank you all for your time and help.
Edit: updated 1st post, game now works much better, more or less.

1 Like

Forum kindly sponsored by