[Solved] Strange GRUB behaviour - sda GRUB not working

In the hope of solving a faulty GRUB problem in the second HDD I called grub-install but the end result is now a strange mess ...

In a nutshell:
I have a MBR sda ( containing windows and manjaro ) and a mbr sdb (Proxmox ) and a GPT sdc ( Anti-X , Red Core, Centos 7 )

After calling explicitly sudo install-grub /dev/sdc in Manjaro Termina,
I got some /boot/efi warnings so I forced with sudo --force install-grub

After the reboot everything is messed up as I boot the system I get only an error in grub:

_error: symbol 'grub_file_filters' not found _

and then the grub_rescue shell...

I am still making the Manjaro USB live install in the laptop ...

Any ideas ?

sudo is a hammer and should be used carefully. Didn't you read the memo?
Warnings are for a reason (to warn for a very probable damage). At least that's what GTranslate says.

Now.. fix it!

OK. Here is a hint..

Solved it by using the Manjaro Live and mhwd-chroot ...
Thanks for the fast reply .... I pannicked ...

Although as I stated before I never called install-grub to /dev/sda ! ...

So how can solve the other broken grub ?

In a nutshell, your problem is.

How could set mbr of an msdos bioslegacy OS to a gpt disk?

Ive told you long ago not to mix
Ive also told you to get rid of grub cudtomiser, have yiu?

And the delay in update grub. Didnt we fixed that when i askef you to set up lsb release in antergos? Why the same topic you made separately?

Hi , Gohlip ...
I have removed "grub-customizer" since the moment you helped me in the first time ...

Nonetheless I am writing this still in the laptop, as I already have the /dev/sda grub in place and fully working ...
Now my question is why did the grub-install "edited" something in /dev/sda if I explictily called /dev/sdc ?

Sorry for the duplicated topics ...

Your sdc is gpt. You cannot set mbr to it. Gpt disk has no mbr( tecnically speaking). Hence the error of /boot/efi

Ps. Good to hear you got rid of grub customizer.
But fix antergos with installing lsb- release package.

The Antergos lsb-release package is already solved ...
Although my question now if I may is :
How can I correct | install GRUB in the GPT HDD ?
Can I point it to the 2mb initial partition ?

Uefi OS must never use msdos disk to boot.

But you can use a uefi grub to boot a bios legacy linux os. Not recommended though. It cannot boot windows.

Ok ... Understood...

But my scenario is this :
The sda is a small SSD with MBR ( Manjaro) ... Default boot device .
the sdc is the large HDD ( GPT partition table ) with all the other distros ( Centos , Antergos ...)

In the BIOS I change manually the boot device from sda to sdc ...
But now in sdc I am greeted with the blinking cursor only ...

( sorry for my english ...)

Use antergos or centos grub to boot manjaro then. Neef mofifulication to its grub.cfg.

Assuming they are in uefi

Your blinking cursor is that you selected the wromg mode. It needs the UEFI: ptefix in front.

Your english is fine.
Better than my spelling here.

thank you ...

This topic was automatically closed 180 days after the last reply. New replies are no longer allowed.

Forum kindly sponsored by