[SOLVED] Telegram Desktop without sound adjustment while running JACK audio server

Using Manjaro MATE (community edition) and running JACK2 audio-server, with Cadence and the integrated audio-device Intel NM10/ICH7, Telegram Desktop sends its eventual sounds (notifications, audio- and video-files' sound...) via Alsoft, so I can't adjust its volume, even if I deactivate the sound.
irudia
[Carla Audio Plugin Host's Patchbay above]

Consequently I cannot control the volume of Telegram anyway, no by the sound controls, nor by Pavucontrol, neither by alsamixer.

When running Telegram without Jack server running, the sound is sent via PulseAudio, so I do can adjust the volume.

This is a issue that I don't really understand and it's annoying. Does anyone have the same issue or know how to solve it?

Audio Device: Intel NM10/ICH7 Family High Definition Audio
Audio Driver: snd_hda_intel

Related posts:


1 Like

This occurs because Telegram Desktop uses OpenAL Soft for it's sound and when running JACK, OpenAL Soft, also known as Alsoft, creates an instance which works alongside the JACK server-environment.

That way, there's noway to adjust the volume of Alsoft, even if you mute the system's volume.

To fix that, just do this:

Type on terminal
$ alsoft-config
And that will open a GUI utility. There go to Backends > General . There on Disabled Backends , right click and choose JACK, in order to force Alsoft not to work as a JACK instance.

irudia

Doing this, OpenAL Soft will run under general volume control.

Solved issue on GitHub: https://github.com/kcat/openal-soft/issues/428

This topic was automatically closed 180 days after the last reply. New replies are no longer allowed.

Forum kindly sponsored by