[Solved]Terrible wireless connection with modem after fresh install. Fine with phone hotspot

Seems like everything else is running fine except for my wireless connection.
I am sitting in the same room as the modem and only getting 75% connectivity and all mirrors for pacman are being timed out.

On a side note, it was working perfectly fine on Xubuntu until yesterday and the connection is perfect when I use my phone's hotspot.

For the card:
Qualcomm Atheros QCA6174 802.11ac Wireless Network Adapter driver: ath10k_pci

And the rest:

System:    Host: Gogo-Nitro Kernel: 4.9.35-1-MANJARO x86_64 (64 bit gcc: 7.1.1) Desktop: N/A
           Distro: Manjaro Linux
Machine:   Device: laptop System: Acer product: Aspire VN7-592G v: V1.12
           Mobo: Acer model: Aspire VN7-592G v: V1.12 UEFI: Insyde v: V1.12 date: 10/06/2016
Battery    BAT0: charge: 46.6 Wh 100.0% condition: 46.6/46.0 Wh (101%) model: LGC AC14A8L status: Discharging
CPU:       Quad core Intel Core i5-6300HQ (-MCP-) cache: 6144 KB
           flags: (lm nx sse sse2 sse3 sse4_1 sse4_2 ssse3 vmx) bmips: 18436
           clock speeds: max: 3200 MHz 1: 800 MHz 2: 800 MHz 3: 799 MHz 4: 872 MHz
Graphics:  Card-1: Intel HD Graphics 530 bus-ID: 00:02.0
           Card-2: NVIDIA GM107M [GeForce GTX 960M] bus-ID: 01:00.0
           Display Server: N/A drivers: intel (unloaded: nvidia) tty size: 151x25
Audio:     Card Intel Sunrise Point-H HD Audio driver: snd_hda_intel bus-ID: 00:1f.3
           Sound: Advanced Linux Sound Architecture v: k4.9.35-1-MANJARO
Network:   Card-1: Qualcomm Atheros QCA6174 802.11ac Wireless Network Adapter driver: ath10k_pci bus-ID: 06:00.0
           IF: wlp6s0 state: up mac: <filter>
           Card-2: Realtek RTL8111/8168/8411 PCI Express Gigabit Ethernet Controller
           driver: r8168 v: 8.044.02-NAPI port: 3000 bus-ID: 07:00.0
           IF: enp7s0 state: down mac: <filter>
Drives:    HDD Total Size: 256.1GB (5.8% used)
           ID-1: /dev/sda model: LITEON_CV1 size: 256.1GB
Partition: ID-1: / size: 225G used: 5.5G (3%) fs: ext4 dev: /dev/sda2
           ID-2: swap-1 size: 9.45GB used: 0.00GB (0%) fs: swap dev: /dev/sda3
Sensors:   System Temperatures: cpu: 46.0C mobo: 37.0C
           Fan Speeds (in rpm): cpu: N/A
Info:      Processes: 162 Uptime: 18 min Memory: 835.4/7851.5MB Init: systemd Gcc sys: 7.1.1
           Client: Shell (bash 4.4.121) inxi: 2.3.23

What about web pages? Mirrors might be just down temporarily.

For more stable connections , you can try disabling MAC address randomization in NetworkManager :

  • Edit /etc/NetworkManager/NetworkManager.conf with any editor as a root
  • Added the following lines in NetworkManager.conf :
[device]
wifi.scan-rand-mac-address=no
  • Save it, then restart networkmanager or reboot your computer...

Hope this helps....

What does this mean? That sites load 75% of the time?

Refresh your mirror list:

sudo pacman-mirrors -g

This means wifi is working. Does your router AP support 2.4GHz and 5GHz?

I think it means if router is 100Mbls, then he's getting 75Mbps.

I think it's time you re-sync your mirrors, and oh ya, @jonathon already mentioned it.

The 75% means nothing. I have a 300Mbps wifi router, and I only get a 100Mbps conneciton, (33%), and have no problem with Internet...

I meant to say that the connection between my laptop and the modem is at 75% quality... Just using the value being given by network manager. It's at least 90% with my phone.

For the mirrors, every single one got timed out (and websites do load, but very slowly in comparaison as when I use my phone's hotspot.

Will try to edit the NetworkManager.conf and see if it changes anything.

EDIT: Adding the line for stopping the randomization of MAC address didn't change anything. Restarting the modem didn't have any effect too.

Ok you are in the same room as your modem.

Go to your junk drawer and get your cat5 cable and plug it into the back of your modem, (router, wifi, - you've not told us what is across the room). (If your wifi router is separate from your actual modem, temporarily disconnect the wifi router from the modem (warn other users) and plug your cat 5 directly into the modem.

(This is a test, its only a test).

If its just as crappy, call your service provider.
If its super fast, then you definitely have a wifi problem. Tell us more about your router.

Very sorry, I have been using wrong terminology here. There is no router, just a modem which we connect to via wireless.

Will try the Cat5 later today.

Hi,
I'm gonna toss my hat in here, and clear some things up. No meanstreak, just informal :slight_smile:

Wha?

[modem is what handles in/out of internet access .. sometimes connected directly to using an ethernet cable. A router will likewise be attached to the modem and then pump out wireless connection to the network. If you have one 'box' and are connected wirelessly, it is in fact a modem/router combo]

Im just gonna go ahead and assume you arent using that realtek ethernet, but rather the Atheros wireless card.

I have one install running on ath9k, and I am unsure about whether ath10k_pci is the module or simply ath10k..

Please run
lsmod | grep ath10

Depending on whether the module is ath10k or ath10k_pci attempt the following:

sudo nano /etc/modprobe.d/ath10k.conf

and paste the following

options ath10k nohwcrypt=1

and save/exit with Ctrl+X

Then restart (card or machine)

Well as long as we are merely being pedantic here.....

A modem sits between the Internet Provider and the TCP/IP network. Historically converting analog to digital packets. Nowdays maybe some other packet technology to TCP/IP.

A router determines which incoming connections go to which workstations, multiplexes one internet connection to several destinations according to rules. Usually this includes the functions of a "firewall"

An Access Point extends from a wired network to a wireless one.

The OP has all three of those in One Box.
I use to have three boxes, with linux being the router.
Now I'm down to just 2, 1-modem and router-AP combo.

1 Like

OK, OK, fair enough. You'll forgive me for being quick and common about it. Right ? :rose:
(as I was not trying to be a pedant ... and I dont think clarification, including yours, exactly qualifies)
Intention carries some weight, ya kno.
:cookie:

Greater detail about the Combination Router/Modem/WirelessAP will possibly be helpful, also your isp, and whether you are on cable or fiber. All of these could contribute. Any other machines, repeaters, or access points could also affect performance. Also try running iwconfig on your connection to get detailed strength and quality info.

Here's the output of iwconfig:

wlp6s0    IEEE 802.11  ESSID:"BelongURDQ64YR"  
          Mode:Managed  Frequency:2.422 GHz  Access Point: 8C:10:D4:4C:77:C5   
          Bit Rate=1 Mb/s   Tx-Power=20 dBm   
          Retry short limit:7   RTS thr:off   Fragment thr:off
          Power Management:on
          Link Quality=59/70  Signal level=-51 dBm  
          Rx invalid nwid:0  Rx invalid crypt:0  Rx invalid frag:0
          Tx excessive retries:3  Invalid misc:45   Missed beacon:0

enp7s0    no wireless extensions.

lo        no wireless extensions.

And no change after adding the nohwcrypt in modprobe.d. I also tried to turn off the power saving mode for the card with negative results.

All other devices in the house seem to be connecting fine to the wifi and have good connection speed.

EDIT: Just tried with ethernet connection, and it's still the same issue. Very hard to see how it could be the modem/router at fault here... So, xubuntu all fine -> elementary OS goes bad -> problem continues with Manjaro.

Will try at the library tomorrow to see if problem is only with this particular combination or if it's my laptop.

Ok, just went down to the library.
Here are all the iwconfig outputs for comparaison:

Phone Hotspot:
wlp6s0    IEEE 802.11
          Mode:Managed  Frequency:2.437 GHz  Access Point:   
          Bit Rate=6 Mb/s   Tx-Power=20 dBm   
          Retry short limit:7   RTS thr:off   Fragment thr:off
          Power Management:on
          Link Quality=70/70  Signal level=-24 dBm  
          Rx invalid nwid:0  Rx invalid crypt:0  Rx invalid frag:0
          Tx excessive retries:0  Invalid misc:45   Missed beacon:0

Library's wifi
wlp6s0    IEEE 802.11
          Mode:Managed  Frequency:5.805 GHz  Access Point:
          Bit Rate=6 Mb/s   Tx-Power=30 dBm   
          Retry short limit:7   RTS thr:off   Fragment thr:off
          Power Management:on
          Link Quality=45/70  Signal level=-65 dBm  
          Rx invalid nwid:0  Rx invalid crypt:0  Rx invalid frag:0
          Tx excessive retries:0  Invalid misc:0   Missed beacon:0

Home wifi
wlp6s0    IEEE 802.11   
          Mode:Managed  Frequency:2.422 GHz  Access Point:
          Bit Rate=1 Mb/s   Tx-Power=20 dBm   
          Retry short limit:7   RTS thr:off   Fragment thr:off
          Power Management:on
          Link Quality=59/70  Signal level=-51 dBm  
          Rx invalid nwid:0  Rx invalid crypt:0  Rx invalid frag:0
          Tx excessive retries:3  Invalid misc:45   Missed beacon:0

So, the only noticeable thing I see is the difference in bitrate, I get only 1 MB/s on the home Wifi, but 6 MB/s at the library (connection/speed good as usual here) and on with my phone.

I also notice you have power management on. It is odten recommended to turn off - but this would not explain the difference between networks.
(if interested this would be a good way https://superuser.com/questions/629039/disabling-power-save-option-on-wifi-device)

I did try with power management 'off' at home. But there was no change.

The problem is definitely between my laptop and that particular AP...

Have you done a channel scan to check there's not congestion on the particular channel your AP is using?

Yes had a look with Linssid and then changed it, but no change.

Otherwise, the only other info I've found on google is about the firmware for the card that seems problematic. I have this output:
dmesg | grep ath10k [2.220847] ath10k_pci: unknown parameter 'nohwcrypt' ignored [2.226214] ath10k_pci 0000:06:00.0: pci irq msi oper_irq_mode 2 irq_mode 0 reset_mode 0 [2.504688] ath10k_pci 0000:06:00.0: Direct firmware load for ath10k/pre-cal-pci-0000:06:00.0.bin failed with error -2 [2.504702] ath10k_pci 0000:06:00.0: Direct firmware load for ath10k/cal-pci-0000:06:00.0.bin failed with error -2 [2.505362] ath10k_pci 0000:06:00.0: Direct firmware load for ath10k/QCA6174/hw3.0/firmware-5.bin failed with error -2 [2.505366] ath10k_pci 0000:06:00.0: could not fetch firmware file 'ath10k/QCA6174/hw3.0/firmware-5.bin': -2 [2.507890] ath10k_pci 0000:06:00.0: qca6174 hw3.2 target 0x05030000 chip_id 0x00340aff sub 105b:e09d [2.507892] ath10k_pci 0000:06:00.0: kconfig debug 0 debugfs 1 tracing 0 dfs 0 testmode 0 [2.508699] ath10k_pci 0000:06:00.0: firmware ver WLAN.RM.2.0-00180-QCARMSWPZ-1 api 4 features wowlan,ignore-[ 2.590850] ath10k_pci 0000:06:00.0: board_file api 2 bmi_id N/A crc32 07ee144e [4.711153] ath10k_pci 0000:06:00.0: htt-ver 3.26 wmi-op 4 htt-op 3 cal otp max-sta 32 raw 0 hwcrypto 1 [4.796479] ath10k_pci 0000:06:00.0 wlp6s0: renamed from wlan0

It tries to load the firmware from hw3.0 where there is only firmware-4.bin and firmware-5.bin is in a different location...

Told myself I would try live USBs of different distros today to know if it's just Manjaro or the hardware... Well, I am now running live Xubuntu and the connection is pretty back to normal I would say... Not essentially super fast, but faster than with Manjaro.

Forum kindly sponsored by