[solved] Touchpad stopped working since 4.19.14


My touchpad stopped working since the upgrade of the kernel to lunix419 and does not work either with linux420. I can't move the mouse and I can't click.

Each time I try to use the touchpad (to move or click), an error message appears in the journal like [Stable Update] 2019-01-17

elan_i2c i2c-ELAN0501:00: invalid report id data (1)

The touchpad is still well recognized as a libinput device:

Device:           Elan Touchpad
Kernel:           /dev/input/event6
Group:            8
Seat:             seat0, default
Size:             104x75mm
Capabilities:     pointer gesture
Tap-to-click:     disabled
Tap-and-drag:     enabled
Tap drag lock:    disabled
Left-handed:      disabled
Nat.scrolling:    disabled
Middle emulation: disabled
Calibration:      n/a
Scroll methods:   *two-finger edge 
Click methods:    *button-areas clickfinger 
Disable-w-typing: enabled
Accel profiles:   none
Rotation:         n/a

I found this solution on the forum Touchpad Acer. But I have the same issue as Mibo, I have an ACER laptop (and not the serio1 but only serio0 and no protocol file in serio0).

*** SYSTEM ***
Acer Laptop with InsydeH20 Bios (v1.12)
Inxi report
Problem occurrs with Kernel v 4.19 and 4.20

Any idea?

Thanks for your help :slight_smile:

*** SOLUTION ***
Switch the touchpad to basic mode in BIOS menu.

[EDIT] For information: I updated the kernel ACER/Insyde H20 to latest version 1.27). There is no change. Touchpad entry still in basic mode in BIOS and working well (even multiple-finger mode).

1 Like

hmmm.... Not sure this version of laptop falls into the Acer Aspire One group, but on irc chat we learned these Acer laptops have a multi-touch pad not similar to most laptops. We also learned you can set these laptops to basic or advanced in the Acer Bios > doubt it would help with driver issue. But might be an idea to start with Bios or maybe even updating the Bios. I personally would look at a different kernel.

Start Menu > Preferences > Manjaro Settings > Kernel

1 Like

Switch to kernel 4.18 that kernel will likely not have the update that is causing your issue. 4.18 is EOL, so you don't want to remain on it too long. Hopefully newest kernel will remedy your issue before too long.

Problem solved thanks to Culaterout :D.
I checked the touchpad entry in my BIOS menu and indeed it was in advanced mode. I switched to basic and the touchpad works with Kernel 4.19 and Kernel 4.20.

My touchpad works just like before. I've noticed no differences while using it.

For information, if one selects advance mode in BIOS, there is a warning message "Make sure the i2c drivers are properly set".

I've updated the main topic message with BIOS information and solution.
Thanks for your time. :slight_smile:

1 Like

The BIOS setting did the trick for me too. Issue solved:


The BIOS switch works, but it also disables some of the features of the touchpad in Manjaro. Before the update I was able to use the Tap to click, two fingers to right click, and 3 finger to scroll. Now all those options have gone and I'm just left with the basic ones. I know it's a minor complaint, but it is annoying to have to actually click down on the touchpad when i'm so used to tapping or double tapping to click/open something. And it worked before I updated with no issues and the BIOS was on advanced.

On IRC we used

Found on:

Tips and tricks

Button re-mapping

Swapping two- and three-finger tap for a touchpad is a straight forward example. Instead of the default three-finger tap for pasting you can configure two-finger tap pasting by setting the TappingButtonMap option in your Xorgconfiguration file. To set 1/2/3-finger taps to left/right/middle set TappingButtonMap to lrm , for left/middle/right set it to lmr .


Section "InputClass" Identifier "touchpad" Driver "libinput" MatchIsTouchpad "on" Option "Tapping" "on" Option "TappingButtonMap" "lmr" EndSection

Remember to remove MatchIsTouchpad "on" if your device is not a touchpad and adjust the Identifier accordingly.

Manual button re-mapping

For some devices it is desirable to change the button mapping. A common example is the use of a thumb button instead of the middle button (used in X11 for pasting) on mice where the middle button is part of the mouse wheel. You can query the current button mapping via:

$ xinput get-button-map device

where device is either the device name or the device ID, as returned by xinput list . You can freely permutate the button numbers and write them back. Example:

$ xinput set-button-map device 1 6 3 4 5 0 7

Actually, xev should show you all events... it's just that it only monitors one window at a time. Perhaps one could hack a script to launch multiple copies of xev each monitoring one window so that you end up monitoring all of them? –

I'm kinda a newbie. Well not kinda, totally a newbie. So all of that makes very little sense to me.... sorry. By the way on reddit someone told me to make the changes in dconf editor, but the settings were already set.

Open dconf-editor,
Install if not already.

Then go to
org > gnome > desktop > peripherals > touchpad

And see if there is Tap to click option.

Those settings were already in place. Some good news, after an update yesterday, I switched my BIOS touchpad settings back to ADVANCED and booted into Manjaro and my touchpad worked! Sadly, it still doesn't have the same functionality it did prior to all this happening. No tap to click or tap and drag....

So back to square one...


Need to look into the gnome-tweaks..
Xtools may not be idle for this setup.. I assumed you were running anything other than gnome..

Good Luck

This topic was automatically closed after 180 days. New replies are no longer allowed.

Forum kindly sponsored by