[SOLVED] Trying to Install Manjaro with Windows on the same drive

At terminal, print output of

sudo parted -l
efibootmgr -v
sudo blkid

And confirm here that windows is uefi.

Sorry this was a little delayed, so thank you for your patience. I made sure to double check that Windows is UEFI based on your request, and I have verified it is.

As for the commands, I've documented their results below:

parted Command:

Model: ATA ST1000DX001-1CM1 (scsi)
Disk /dev/sda: 1000GB
Sector size (logical/physical): 512B/4096B
Partition Table: gpt
Disk Flags:

Number Start End Size File system Name Flags
1 1049kB 368MB 367MB ntfs msftdata
2 368MB 944GB 944GB ntfs msftdata
3 944GB 945GB 537MB fat32 msftdata
4 945GB 947GB 2147MB linux-swap(v1)
5 947GB 999GB 52.4GB ext4
6 999GB 999GB 105MB fat32 boot, esp
7 1000GB 1000GB 472MB ntfs diag

efibootmgr Command:

BootCurrent: 0010
Timeout: 1 seconds
BootOrder: 0010,0011,0003,0006
Boot0003* UEFI: Built-in EFI Shell VenMedia(5023b95c-db26-429b-a648-bd47664c8012)..BO
Boot0006 Hard Drive BBS(HD,,0x0)..GO..NO........o.S.T.1.0.0.0.D.X.0.0.1.-.1.C.M.1.6.2....................A...........................>..Gd-.;.A..MQ..L. . . . . . . . . . . . .1.Z.D.D.9.1.6.B........BO
Boot0010* UEFI OS (SATA1: ST1000DX001-1CM162) HD(3,GPT,73d44d44-0370-42bc-a64b-bca4cb43231e,0x6de7f800,0x100000)/File(\EFI\BOOT\BOOTX64.EFI)..BO
Boot0011* Windows Boot Manager (SATA1: ST1000DX001-1CM162) HD(7,GPT,0d48ed36-916f-11e8-8fe8-bc14ef621ee6,0x74625000,0xe1000)/File(\EFI\MICROSOFT\BOOT\BOOTMGFW.EFI)..BO

blkid Command:

/dev/sda1: LABEL="System Reserved" UUID="C61CA7AE1CA79847" TYPE="ntfs" PARTUUID="0d48ed33-916f-11e8-8fe8-bc14ef621ee6"
/dev/sda2: UUID="6E14D0BD14D0898B" TYPE="ntfs" PARTUUID="0d48ed34-916f-11e8-8fe8-bc14ef621ee6"
/dev/sda3: UUID="0090-C4B3" TYPE="vfat" PARTUUID="73d44d44-0370-42bc-a64b-bca4cb43231e"
/dev/sda4: UUID="3961732c-58a3-4f9f-9a77-d21919997117" TYPE="swap" PARTUUID="f73ea0bd-684e-4ff1-ad14-0dd4f6c13f3d"
/dev/sda5: UUID="efc9ece3-ec36-4778-80a1-f0680cf3f965" TYPE="ext4" PARTUUID="63e4c591-4452-482e-bc63-4140ba9469b7"
/dev/sda6: UUID="4EB7-4256" TYPE="vfat" PARTUUID="0d48ed35-916f-11e8-8fe8-bc14ef621ee6"
/dev/sda7: UUID="FCA8821FA881D912" TYPE="ntfs" PARTUUID="0d48ed36-916f-11e8-8fe8-bc14ef621ee6"

I appreciate any help that I may get, so thank you!

Let's try this and see if windows boot.
If it does, let us know and we'll make it permanent in the grub menu.

At grub menu, press 'c' and we'll get to the grub prompt (grub> ). Type in the following and press enter after each line.

grub> insmod fat
grub> insmod chain
grub> search --no-floppy --fs-uuid --set=FCA8821FA881D912
grub> chainloader /EFI/Microsoft/Boot/bootmgfw.efi
grub> boot

BTW, when you do 'sudo os-prober', there is no error message, right?
You should tell us if there is any.
Can you do again and post its output?
I think I have an idea and need this to settle your issue.
I think it would show sda7 for windows and you will need to fix it in manjaro bootentry (not grub)
Also open up the file /boot/grub/grub.cfg and confirm whether any windows entry is there or not.
Print out for us this windows entry, if any.

Alright, so I performed the sequence of commands given and that has successfully booted me to Windows after performing the final boot command.

Now whenever I run os-prober, it stalls for a bit and then returns nothing. Probably because it couldn't locate Windows I presume.

Finally, grub.cfg does not contain a Windows entry, only the standard Manjaro + Advanced options/etc. ones.

Thank you for your help so far!

Okay. Now that these commands boot windows, let's put the Windows entry in your grub.
At Manjaro terminal, create a custom.cfg in /boot/grub

sudo touch /boot/grub/custom.cfg

Open this custom.cfg , put this entry in it and save file.

menuentry "Windows"  {
        insmod part_gpt
        insmod fat
        insmod chain
        search --no-floppy --fs-uuid --set=FCA8821FA881D912
        chainloader /EFI/Microsoft/Boot/bootmgfw.efi
}


No need to update-grub (update-grub will not show these entries), and it will appear next time you boot manjaro
Done.

ps: can you provide contents of
ls /etc/grub.d

Awesome! It looks like it's all set and the option boots to windows without any issues.

Based on your request, the contents of that command are:

00_header 10_linux 20_linux_xen 30_os-prober 40_custom 41_custom 60_memtest86+ README

On another note, this now a totally unrelated issue(?), but it seems that grub has started booting to grub recovery for me with the message (error: unknown file system). I can't think of why it's doing that, and what we've done shouldn't have affected it.

So every time based on what I've read I need to set root to where grub is, set the prefix, and run normal to get to the grub boot select. It's a three step process and I can boot to linux/windows that way, but I tried reinstalling grub, and I've had no success.

Thank you for your help so far. I'm not familiar with being hands on with grub, so this is certainly highly informative.

You're welcome, @iArcanex.

As to your new issue of booting to grub recovery (and your old issue of os-prober not detecting windows), I had, right from the beginning, suspect that it is your drive that you converted from mbr to gpt.

I am actually surprised it had worked they way it had. Note too that a msdos grub cannot boot (or detect) a uefi windows (and a gpt grub cannot boot a mbr windows).

Yes, you had converted the drive to gpt; but I thinks such conversion may be fraught with 'errors' (or not the same as a properly made gpt partitioning scheme). "(error: unknown file system)" is a further indication.

This may not be a welcome news to you but I guess unpleasant facts is preferable to blissful ignorance. At least, that's how I feel.

1 Like

I agree that the acknowledgement of information, especially back by evidence, is better than being oblivious, so I thank you for that. I originally wasn't sure how the process of conversion from MBR to GPT would result, as I was treading on new grounds and it certainly has made the process faster for me than completely formatting my drive, but nonetheless the route I've gone has presented difficulties.

I find it odd that grub worked well (I guess at its front) for the first few runs (especially since the initial install the past few days), then to encounter its transition in this manner.

Based on your experience, would you think it would be viable to completely format and configure my drive to GPT/UEFI from a clean slate, or would any solution present at this manner be too tedious to employ?

Thank you!

Yes, it is better to start with a new gpt partitioned drive.

Make sure you use gparted.
At device tab above,
Select "Create Partition 'something'"
Then select 'gpt'
Note it will wipe out all data in that drive.
I prefer to then make partitions ready for installation.

Good luck.

1 Like

Thank you and @linux-aarhus very much for the help. It was highly informative!

This topic was automatically closed 30 days after the last reply. New replies are no longer allowed.

Forum kindly sponsored by