[SOLVED] Unable to lock screen after new stable update

After the most recent Stable update, I can no longer lock the system. I'm currently using Cinnamon. In a terminal if I type cinnamon-screensaver I get the following error"

(cinnamon-screensaver:61080): GLib-GIO-ERROR **: 07:40:53.988: Settings schema 'org.cinnamon.desktop.screensaver' does not contain a key named 'custom-screensaver-command'
Trace/breakpoint trap (core dumped)

Output from inxi -Fxxxz

System:
  Host: carl-manjaro Kernel: 5.6.15-1-MANJARO x86_64 bits: 64 compiler: gcc 
  v: 10.1.0 Desktop: Cinnamon 4.6.2 dm: LightDM 1.30.0 Distro: Manjaro Linux 
Machine:
  Type: Laptop System: Dell product: XPS 15 9570 v: N/A serial: <filter> 
  Chassis: type: 10 serial: <filter> 
  Mobo: Dell model: 02MJVY v: A00 serial: <filter> UEFI: Dell v: 1.16.2 
  date: 04/21/2020 
Battery:
  ID-1: BAT0 charge: 92.9 Wh condition: 92.9/97.0 Wh (96%) volts: 12.6/11.4 
  model: LGC-LGC8.33 DELL 5XJ2885 type: Li-ion serial: <filter> status: Full 
CPU:
  Topology: 6-Core model: Intel Core i7-8750H bits: 64 type: MT MCP 
  arch: Kaby Lake rev: A L2 cache: 9216 KiB 
  flags: avx avx2 lm nx pae sse sse2 sse3 sse4_1 sse4_2 ssse3 vmx 
  bogomips: 52815 
  Speed: 800 MHz min/max: 800/4100 MHz Core speeds (MHz): 1: 800 2: 800 
  3: 800 4: 800 5: 800 6: 800 7: 800 8: 802 9: 800 10: 800 11: 800 12: 800 
Graphics:
  Device-1: Intel UHD Graphics 630 vendor: Dell driver: i915 v: kernel 
  bus ID: 00:02.0 chip ID: 8086:3e9b 
  Display: x11 server: X.Org 1.20.8 driver: intel resolution: 3840x2160~60Hz 
  OpenGL: renderer: Mesa Intel UHD Graphics 630 (CFL GT2) v: 4.6 Mesa 20.0.7 
  direct render: Yes 
Audio:
  Device-1: Intel Cannon Lake PCH cAVS vendor: Dell driver: snd_hda_intel 
  v: kernel bus ID: 00:1f.3 chip ID: 8086:a348 
  Sound Server: ALSA v: k5.6.15-1-MANJARO 
Network:
  Device-1: Qualcomm Atheros QCA6174 802.11ac Wireless Network Adapter 
  vendor: Bigfoot Networks driver: ath10k_pci v: kernel port: efa0 
  bus ID: 3b:00.0 chip ID: 168c:003e 
  IF: wlp59s0 state: up mac: <filter> 
  Device-2: Qualcomm Atheros type: USB driver: btusb bus ID: 1-4:2 
  chip ID: 0cf3:e301 
Drives:
  Local Storage: total: 476.94 GiB used: 96.91 GiB (20.3%) 
  ID-1: /dev/nvme0n1 vendor: Toshiba model: KXG50ZNV512G NVMe 512GB 
  size: 476.94 GiB speed: 31.6 Gb/s lanes: 4 serial: <filter> rev: AADA4105 
  scheme: GPT 
Partition:
  ID-1: / size: 47.81 GiB used: 20.16 GiB (42.2%) fs: ext4 
  dev: /dev/nvme0n1p3 
  ID-2: /home size: 360.19 GiB used: 76.74 GiB (21.3%) fs: ext4 
  dev: /dev/nvme0n1p4 
  ID-3: swap-1 size: 15.62 GiB used: 0 KiB (0.0%) fs: swap 
  dev: /dev/nvme0n1p2 
Sensors:
  System Temperatures: cpu: 49.0 C mobo: N/A 
  Fan Speeds (RPM): cpu: 2531 fan-2: 2483 
Info:
  Processes: 334 Uptime: 9h 39m Memory: 30.99 GiB used: 5.97 GiB (19.3%) 
  Init: systemd v: 245 Compilers: gcc: 10.1.0 clang: 10.0.0 Shell: bash 
  v: 5.0.17 running in: gnome-terminal inxi: 3.0.37

I'm also getting this error when attempting to launch "Display" from System Settings.

(cinnamon-settings.py:62765): GLib-GIO-ERROR **: 08:24:30.060: Settings schema 'org.cinnamon.desktop.interface' does not contain a key named 'upscale-fractional-scaling'
Trace/breakpoint trap (core dumped)

I was able to fix the issues. Looks like the schema files got updated but it never recompiled the schemas. Fixed it by running this:
sudo glib-compile-schemas /usr/share/glib-2.0/schemas/

This topic was automatically closed 90 days after the last reply. New replies are no longer allowed.

Forum kindly sponsored by