(Solved) Unable to set default papersize

Hi, I'm using Manjaro-i3 with Libreoffice with a HP Laset Jet Pro printer.
It seams to be impossible to set default papersize as A4. I tried in all possible popup's, the system starts printing always with "Letter 216mm x 279mm". It has to be changed manually for each new job.
Libreoffice from depot, fom AUR, fron flatpak or from snap : all present the same problem. Same problem with the poor Free-Office and incredibly poor WP-Office !
Problem seams to be related to manjaro system: it works perfectly well with linux Mint and i3.
Who knows a solution for that tiny but annoying problem ?
Great thanks and kind regards

As well as the usual Manjaro Settings and LibreOffice settings, I also set a4 paper size in /etc/papersize.
See man papersize in a Terminal for details.

O yes, I tried manjaro settings as well as libreoffice settings and /etc/papersize.
The format A4 is there, but has to be selected for each new job ! No standard setting possible.

What is result of...
env | grep PAPER

LC_PAPER=fr_FR.UTF-8
I tried also to set A4 in my model documents XXX.ott. It's correctly there but starting an odt documents, it's gone !

In LibreOffice Options > Language Settings I have set User Interface, Locale Setting, Western to my locale (English) rather than a Default setting. Try setting to French.

  • open a browser to localhost:631
  • click administration
  • select your printer
  • select default settings
  • change default paper size
  • save

Provide credentials - done

Can also be done from print settings applet system-config-printer if it is installed

enjoy

It's done, but no improvement at all.

I found no possibility to set papersize in localhost:631 and no possibility to change print-settings (papersize) in system-config-printer. Sorry.

You didn't look very close

localhost:631

image

20200804-201529_566x306_screenshot

print settings applet

20200804-201914_593x444_screenshot

Sorry, I don't have such pulldown menu with "General" settings.
FYI, remember: the problem seams not related to Libreoffice: same problem with other office packages... and absolutely no problem with Linux-Mint. Same office parameter settings under Mint and Manjaro.

I didn't mention libreoffice - I pointed you to the system settings - it is not a fault related to Manjaro it is a configuration issue for your system.

Hi, I just changed my printer in localhost:631 and miracle, the "General" pulldown in there and the papersize by default is A4.
Opening Writer, papersize is by default A4.
Great !
Many thanks for Your inputs and ideas : problem solved.

1 Like

Forum kindly sponsored by