[SOLVED] Virtualbox - USB <no devices available>

Hello everyone. Been using Manjaro XFCE for the past almost 2 months, and it's been great! Was able to pull the OS-installed SSD out of my 10-year old computer that suddenly died, and plonk it into the new Ryzen system and boot it straight up. Wonderful!

Installed VirtualBox 5.2.20 today from the repo to run a Win7 guest for 2 reasons only: audiochecker to check FLAC files, and to back up my phone (Huawei P9 Plus (VIE-AL10)) using HiSuite.

Got the guest Win7 OS up and running, and it sees the shared folder from Manjaro Linux XFCE. Clipboard works bidirectionally. Drag and Drop works from host to guest but not vice-versa despite being set to Bidirectional; not a biggie. Installed audiochecker. Objective #1 accomplished.

However, VirtualBox refuses to see my USB devices despite the addition of the Oracle VM VirtualBox Extension Pack (5.2.20) from the AUR. This is the output of lsusb:

Bus 004 Device 001: ID 1d6b:0003 Linux Foundation 3.0 root hub
Bus 003 Device 002: ID 0a12:0001 Cambridge Silicon Radio, Ltd Bluetooth Dongle (HCI mode)
Bus 003 Device 001: ID 1d6b:0002 Linux Foundation 2.0 root hub
Bus 002 Device 001: ID 1d6b:0003 Linux Foundation 3.0 root hub
Bus 001 Device 004: ID 0d8c:0102 C-Media Electronics, Inc. CM106 Like Sound Device
Bus 001 Device 003: ID 046d:c52b Logitech, Inc. Unifying Receiver
Bus 001 Device 009: ID 12d1:107e Huawei Technologies Co., Ltd. 
Bus 001 Device 005: ID b58e:9e84 Blue Microphones Yeti Stereo Microphone
Bus 001 Device 001: ID 1d6b:0002 Linux Foundation 2.0 root hub

Creating a USB filter with the respective Vendor(12d1) and Product(107e) IDs of my phone didn't help either. Can't see my phone.

This is the output of groups myUserName:

wheel audio disk lp optical storage video network scanner power usbmux autologin vboxusers

Was getting a bit desperate to make things work, and I followed the suggestion of the last post in this thread to make this happen. Still no go; can't see any USB devices on VirtualBox. Doesn't matter whether it's on USB 1.1, 2.0 or 3.0.

So, as it stands at the moment, Objective #2 is still a fail. Am at wits end here and don't know what to do to further troubleshoot. Any help would be very much appreciated.

Thank you in advance.

Download them from their site, on your local HDD and install them from there. After that will always ask to update them when VirtualBox gets an update from Manjaro repos.
Make sure you have also installed the virtualbox-host-modules for your used kernel, and probably the virtualbox-guest-iso ... NEVER install virtualbox-guest-modules in your host machine! (just a heads-up to be sure) :wink:
After that and a reboot, all should be just fine.

1 Like

I did. However, when trying to install it in VirtualBox, the prompt for root password comes up, and when entered, kills the installation with an error message. Should the installation be done just by double-clicking the file and not through VirtualBox itself?

Edit: this is the error message, whether installed throught VirtualBox or double-clicking Oracle_VM_VirtualBox_Extension_Pack-5.2.20.vbox-extpack file:


Failed to run /usr/lib/virtualbox/VBoxExtPackHelperApp --stdout /tmp/VBoxExtPackHelper-qx5q0w/stdout --stderr /tmp/VBoxExtPackHelper-qx5q0w/stderr --elevated install --base-dir /usr/lib/virtualbox/ExtensionPacks --cert-dir /usr/share/virtualbox/ExtPackCertificates --name 'Oracle VM VirtualBox Extension Pack' --tarball /home/max/Oracle_VM_VirtualBox_Extension_Pack-5.2.20.vbox-extpack --sha-256 815d3fafd22e01ad8e69edffa35bab1fce923143c75c0eb010f21ac1a2bd6279.

Failed to execute child process “/usr/lib/virtualbox/VBoxExtPackHelperApp --stdout /tmp/VBoxExtPackHelper-qx5q0w/stdout --stderr /tmp/VBoxExtPackHelper-qx5q0w/stderr --elevated install --base-dir /usr/lib/virtualbox/ExtensionPacks --cert-dir /usr/share/virtualbox/ExtPackCertificates --name 'Oracle VM VirtualBox Extension Pack' --tarball /home/max/Oracle_VM_VirtualBox_Extension_Pack-5.2.20.vbox-extpack --sha-256 815d3fafd22e01ad8e69edffa35bab1fce923143c75c0eb010f21ac1a2bd6279” (No such file or directory)

Hence why I'd to install from the repo instead. That was the only method that worked.

This was also done (for 4.14), but the guest iso was downloaded through VirtualBox itself, since it was causing some issues when downloaded through the repo. That part works fine now.

Thank you for the heads-up! I was wondering about that. Didn't do it though, LOL! :sweat_smile:

You should remove the AUR installed VirtualBox_Extension_Pack prior to try to install them from the official file.

1 Like

Did that also, with two methods (because of multiple install-uninstall cycles.) One was to use Package Manager, mark it for removal and get rid of it.

The other was to brute force it in Termina via
sudo pacman -Rddn virtualbox-ext-oracle
With the 2nd method, Package Manager also showed the package going from installed (green tickbox) to uninstalled (white tickbox).

Both times, VirtualBox was not running, and was launched thereafter to check and ensure that the Extension Pack was removed from Preferences. However, the official file refuses to install and quits with the previously mentioned error.

Very strange.

Edit: to elaborate, I went to the extent of sudo pacman -Rddn-ing VirtualBox and all associated packages installed from the repo/AUR, before doing an install of only VirtualBox (5.2.20), virtualbox-host-module (4.14) and Extension Pack (5.2.20) from the repo/AUR, just in case any remaining files after uninstalling might be causing some issue. This is why the Guest Editions CD was downloaded by VirtualBox itself during Win7 setup, and that solved the mouse & screen scaling issues that were being faced then.

Altogether, I've installed & uninstalled VirtualBox 5 times, and Win7 4 times. Right now, Extension Pack is not installed, awaiting further troubleshooting.

Install the Extension pack as Bogdan stated above, i.e. download the pack from their website and install it within VBox.

1 Like

Same error message thrown, whether installed from within VirtualBox or the file is double-clicked.

This is the additional text from the error message I forgot to include earlier:

Failed to install the Extension Pack /home/$USER/Oracle_VM_VirtualBox_Extension_Pack-5.2.20.vbox-extpack.

The installer failed with exit code 1: .

Result Code: NS_ERROR_FAILURE (0x80004005)
Component: ExtPackManagerWrap
Interface: IExtPackManager {edba9d10-45d8-b440-1712-46ac0c9bc4c5}

Thank you both for your continued assistance.

Edit: i did remember to reboot after VirtualBox installation and before Extension Pack installation.

Update: managed to get the Extension Pack installed from the command line using:
sudo VBoxManage extpack install --replace Oracle_VM_VirtualBox_Extension_Pack-5.2.20.vbox-extpack

However, USB devices still cannot be seen by VirtualBox.

So I did:
sudo VBoxManage extpack uninstall 'Oracle VM VirtualBox Extension Pack'
which got the extension pack uninstalled (verified within VirtualBox) and
sudo VBoxManage extpack cleanup
before re-doing
sudo VBoxManage extpack install --replace Oracle_VM_VirtualBox_Extension_Pack-5.2.20.vbox-extpack
Extension Pack installed properly, no error messages. Still can't see any USB devices either from within VirtualBox itself or from the Win7 machine.

Good that you sorted the install ... but ^this i don't get. If you go to the USB icon, it will say "No USB devices attached" but if you right click on it, then you can select the check box of each individual device.
image

1 Like

Screenshots for verification. Gotta do this one post at a time, since as a newbie, i can't do more than one image at a time in a post.

Extension Pack downloaded from the website and installed.
01

This is the filter I created to try and get my phone to show up, because.....
02

...clicking the button denoted by the red arrow brings up a box with "no devices available" and....
03

...right-clicking the USB icon shown by the red arrow brings up a drop-down box with "USB Settings..." and "No USB devices connected"
04
This is the same situation for USB 1.1, 2.0 and 3.0. My phone is plugged into a USB 3.0 port, and just now I tried with the USB2.0 port. Same results.

Don't know what I'm doing wrong. It should have worked by now...

Put USB2.0 where you enable USB controller.
Don't add devices (yet) to that list, and just enable one by one from the bottom icon when the VBox install is booted up.

1 Like

Something happened and the Win7 VM had become corrupt, couldn't boot. So, deleted it and reinstalled Win7 from scratch. Did as you instructed and set up the new VM with USB2.0 support and without any filters:14-01
Install went well, including Guest Additions.

Started off the Win7 VM with a webcam connected to the computer's USB2.0 port:
14-02
The Blue Yeti microphone is also connected to a USB2.0 port and never gets unplugged.

Clicked on the USB icon at the bottom right of the Win7 VM:
14-03
"No USB devices connected." Not even the Blue Yeti was being picked up.

Connected my phone to the computer's USB3.0 port:
14-04
"No USB devices connected."

Thinking that perhaps I should try another method, Kernel 4.17.19 was installed. Looked into Package Manager, and was pleasantly surprised to find that linux417-virtualbox-host-modules 5.2.20 had automatically been installed.

Rebooted into Kernel 4.17.19 without any unnecessary USB devices connected:
17-02
Blue Yeti microphone is still there because it is permanently connected to the rear USB2.0 port of the computer. Also, 2 other devices were connected to USB2.0 ports on the computer.

Fired up the Win7 VM. Clicked the USB icon at the bottom right. "No USB devices connected."

With Win7 VM still running, connected the webcam to USB2.0 port on the computer:
17-03
Result - "No USB devices connected."

Connected my phone to USB3.0 port on the computer:
17-04
Result - "No USB devices connected."

So, the issue isn't kernel-number related. Happens across different kernels.

Back on 4.14.78 now and thinking maybe I'm not destined to back-up my phone. :sweat:

This has been a very frustrating experience on my side, but it is so wonderful how much help is being rendered in this thread. Thank you @bogdancovaciu and @anon23612428

:pray::heart:

1 Like

Let's try to find the issue :slight_smile: and FIX IT :smiley:
Please check from terminal the:
groups
and see if you are in the vboxusers

if not, run this still from terminal:
sudo adduser $xfceman vboxusers
or maybe better
sudo gpasswd -a $xfceman vboxusers
considering that xfceman is your user in that machine too.
Reboot and let's see what is going on.

That sounds like a brilliant idea! :+1::grin:

Output from groups:
network scanner power vboxusers usbmux autologin video storage optical lp disk audio wheel xfceman
I'm already there.

But just in case, I did:

and rebooted the computer. Launched Win7 VM and still same result as before.

Where to next?

ls -la /dev | grep vboxusb
you should have something like this:

if is not so, then edit the /etc/udev/rules.d/60-vboxdrv.rules
and change to this:

SUBSYSTEM=="usb_device", ACTION=="add", RUN+="/usr/share/virtualbox/VBoxCreateUSBNode.sh $major $minor vboxusers"
SUBSYSTEM=="usb", ACTION=="add", ENV{DEVTYPE}=="usb_device", RUN+="/usr/share/virtualbox/VBoxCreateUSBNode.sh $major $minor vboxusers"

reboot and let's see ...

6 Likes
2 Likes

Forum kindly sponsored by