[SOLVED] Weird DPMS problem

Hey guys!

Ive been an Arch user for a long time, but I decided to give Manjaro a go on my new build, and so far I really like it. I've managed to get my setup exactly as I want it, with one niggling problem.

I'm running xfce with a dual monitor setup. I've disabled lighDM so I can boot to command line, and I've installed xfce4-screensaver so I can lock my screen. I've set the screen saver to activate after 55 mins, and (in the power manager) DPMS sleep to occur after 60 mins. The screen saver activates as expected, but it's 50/50 as to whether it then sets the monitors to standby 5 mins later.

If I force standby with the command

xset dpms force standby

I see the same issue! sometimes it goes into standby, sometimes it goes into the screen saver.

This is weird......any ideas!

here are my display options:

Keyboard Control:
  auto repeat:  on    key click percent:  0    LED mask:  00000000
  XKB indicators:
    00: Caps Lock:   off    01: Num Lock:    off    02: Scroll Lock: off
    03: Compose:     off    04: Kana:        off    05: Sleep:       off
    06: Suspend:     off    07: Mute:        off    08: Misc:        off
    09: Mail:        off    10: Charging:    off    11: Shift Lock:  off
    12: Group 2:     off    13: Mouse Keys:  off
  auto repeat delay:  500    repeat rate:  20
  auto repeating keys:  00ffffffdffffbbf
                        fadfffefffedffff
                        9fffffffffffffff
                        fff7ffffffffffff
  bell percent:  50    bell pitch:  400    bell duration:  100
Pointer Control:
  acceleration:  2/1    threshold:  4
Screen Saver:
  prefer blanking:  no    allow exposures:  no
  timeout:  3300    cycle:  3300
Colors:
  default colormap:  0x20    BlackPixel:  0x0    WhitePixel:  0xffffff
Font Path:
  /usr/share/fonts/misc,/usr/share/fonts/TTF,built-ins
DPMS (Energy Star):
  Standby: 3600    Suspend: 0    Off: 0
  DPMS is Enabled
  Monitor is On

edit:
browsing the forums, I've just seen this Steam screws up suspend

possibly related....manually suspend does seem to be working now I've shutdown the steam client

1 Like

Hey, thanks for linking to my post. This seems to be the exact same issue I am having.

Honestly, XFCE has had many power management problems since 4.14, so I've switched to Cinnamon. But if this is a Manjaro-specific problem, this should really be looked at.

1 Like

After a bit of messing about checking stuff, I think it was definitely Steam causing my issues. This issue is resolved for me.

Thanks for your help CheeseEBoi!

1 Like

No problem, but this is likely an issue with how XFCE deals with power management... I might report this but I don't really have much knowledge on the subject.

Forum kindly sponsored by