[SOLVED] Wifi Issue after suspend mode and more

Hello everyone,

I'm beginner to linux (I use it for programming) and I have some issues with my wifi when my laptop go to suspend mode (or long afk period) : My wifi stop working and I need to restart my laptop...

After some research I found answers to people who had the same problem but each solutions failed for me (and the topics are old... 2016)

I also notice that there is duplicate Wifi SSID on my network Manager (here is a screenshot)


Restarting network manager doesn't work

sudo systemctl stop NetworkManager ; sleep 5 ; sudo systemctl start NetworkManager  

Using this command (to set power saving off) doesn't work too

sudo iwconfig wlp3s0 power off

power on or off don't change anything

iwconfig output :

br-5b6fba2c8b53  no wireless extensions.

wlp3s0    IEEE 802.11  ESSID:"freebox_XXXXXX"  
          Mode:Managed  Frequency:2.462 GHz  Access Point: 5A:6C:16:F8:80:58   
          Bit Rate=115.6 Mb/s   Tx-Power=22 dBm   
          Retry short limit:7   RTS thr:off   Fragment thr:off
          Power Management:on
          Link Quality=44/70  Signal level=-66 dBm  
          Rx invalid nwid:0  Rx invalid crypt:0  Rx invalid frag:0
          Tx excessive retries:0  Invalid misc:22   Missed beacon:0

enp2s0f1  no wireless extensions.

docker0   no wireless extensions.

lo        no wireless extensions.

I use an Acer A515-51G with this configuration :

KDE 5.52.0 / Plasma 5.14.4
Manjaro 18.0.1 Illyria
NVIDIA GeForce 940MX

N.B. Sorry for my english, I'm not a native speaker

Best regards

Check again these topics. I think you will find them interesting ..

As @AgentS has already mentioned writing a service file usually solves this problem. However in your case I think there may be another issue going on as well.

Dual entries for your wifi in network manager tends to make me think you have installed the wrong driver for your adapter. We will need far more information to figure out what is going on here.

Please post the output of the following commands:

hwinfo --netcard --wlan --bluetooth | grep -Ei "model\:|driver\:|status\:|cmd\:|file\:|detected\:" | grep -v "Config Status" 
pacman -Qsq linux | grep linux | grep -v -E '(arch|util|sys|api|firmware)' | grep -v nvidia
grep -r "blacklist\|install\|options"  /etc/modprobe.d/
inxi -Fxxxz

Please post the input/outputs of all requested commands via the terminal as text, (not as pics).

Information on how to properly post hardware specs and logs:

Please format any terminal output with three backticks before and after, as shown in this picture:

1 Like

Hello, thank you for your answers, I already tried the scripts and I thought it doesn't work because the first time it doesn't do anything, so I removed the script.

But after a retry, the script work 80% of the time, sometimes it doesn't work, but I find a tips : I force my laptop to re-enter into suspend mode, and then my wifi work again

sudo systemctl suspend

But there is always duplicates Wifi SSID under Available Connections section of my Network Manager (5x for Freebox_XXXX, 2x for FreeWifi...)

Here is the output of the commands :

$ hwinfo --netcard --wlan --bluetooth | grep -Ei "model:|driver:|status:|cmd:|file:|detected:" | grep -v "Config Status"

  Driver: "iwlwifi"
  Device File: wlp3s0
  Link detected: yes
    Driver Status: iwlwifi is active
    Driver Activation Cmd: "modprobe iwlwifi"
  Model: "Realtek RTL8111/8168/8411 PCI Express Gigabit Ethernet Controller"
    Driver Status: r8169 is not active
    Driver Activation Cmd: "modprobe r8169"
    Driver Status: r8168 is not active
    Driver Activation Cmd: "modprobe r8168"
  Model: "Intel Bluetooth Device"
  Driver: "btusb"
    Driver Status: btusb is active
    Driver Activation Cmd: "modprobe btusb"

$ pacman -Qsq linux | grep linux | grep -v -E '(arch|util|sys|api|firmware)' | grep -v nvidia


$ grep -r "blacklist|install|options" /etc/modprobe.d/

/etc/modprobe.d/mhwd-bbswitch.conf:options bbswitch load_state=0 unload_state=0
/etc/modprobe.d/mhwd-nvidia.conf:blacklist nouveau
/etc/modprobe.d/mhwd-nvidia.conf:blacklist nvidia
/etc/modprobe.d/mhwd-nvidia.conf:blacklist nvidia-modeset
/etc/modprobe.d/mhwd-nvidia.conf:blacklist nvidia-uvm
/etc/modprobe.d/mhwd-nvidia.conf:blacklist ttm
/etc/modprobe.d/mhwd-nvidia.conf:blacklist drm_kms_helper
/etc/modprobe.d/mhwd-nvidia.conf:blacklist drm
/etc/modprobe.d/r8169_blacklist.conf:blacklist r8169

$ inxi -Fxxxz

System:    Host: Flo-PC Kernel: 4.19.13-1-MANJARO x86_64 bits: 64 compiler: gcc v: 8.2.1 
           Desktop: KDE Plasma 5.14.4 tk: Qt 5.12.0 wm: kwin_x11 dm: SDDM Distro: Manjaro Linux 
Machine:   Type: Laptop System: Acer product: Aspire A515-51G v: V1.06 serial: <filter> 
           Mobo: SKL model: Charmander_KL v: V1.06 serial: <filter> UEFI: Insyde v: 1.06 date: 06/01/2017 
Battery:   ID-1: BAT1 charge: 37.0 Wh condition: 45.3/48.9 Wh (93%) volts: 15.9/15.2 
           model: COMPAL PABAS0241231 type: Li-ion serial: <filter> status: Discharging 
CPU:       Topology: Dual Core model: Intel Core i3-6006U bits: 64 type: MT MCP arch: Skylake rev: 3 
           L2 cache: 3072 KiB 
           flags: lm nx pae sse sse2 sse3 sse4_1 sse4_2 ssse3 vmx bogomips: 15940 
           Speed: 1850 MHz min/max: 400/2000 MHz Core speeds (MHz): 1: 1887 2: 1900 3: 1891 4: 1899 
Graphics:  Device-1: Intel Skylake GT2 [HD Graphics 520] vendor: Acer Incorporated ALI driver: i915 
           v: kernel bus ID: 00:02.0 chip ID: 8086:1916 
           Device-2: NVIDIA GM108M [GeForce 940MX] driver: N/A bus ID: 01:00.0 chip ID: 10de:134d 
           Display: x11 server: X.Org 1.20.3 driver: intel compositor: kwin_x11 
           resolution: 1920x1080~60Hz 
           OpenGL: renderer: Mesa DRI Intel HD Graphics 520 (Skylake GT2) v: 4.5 Mesa 18.3.1 
           compat-v: 3.0 direct render: Yes 
Audio:     Device-1: Intel Sunrise Point-LP HD Audio vendor: Acer Incorporated ALI driver: snd_hda_intel 
           v: kernel bus ID: 00:1f.3 chip ID: 8086:9d70 
           Sound Server: ALSA v: k4.19.13-1-MANJARO 
Network:   Device-1: Realtek RTL8111/8168/8411 PCI Express Gigabit Ethernet vendor: Acer Incorporated ALI 
           driver: N/A port: 3000 bus ID: 02:00.1 chip ID: 10ec:8168 
           Device-2: Intel Wireless 7265 driver: iwlwifi v: kernel port: 3000 bus ID: 03:00.0 
           chip ID: 8086:095a 
           IF: wlp3s0 state: up mac: <filter> 
           IF-ID-1: br-5b6fba2c8b53 state: down mac: <filter> 
           IF-ID-2: docker0 state: down mac: <filter> 
Drives:    Local Storage: total: 1.14 TiB used: 93.79 GiB (8.1%) 
           ID-1: /dev/sda vendor: Western Digital model: WD10SPZX-21Z10T0 size: 931.51 GiB 
           speed: 6.0 Gb/s rotation: 5400 rpm serial: <filter> rev: 1A02 scheme: GPT 
           ID-2: /dev/sdb vendor: Samsung model: SSD 860 EVO M.2 250GB size: 232.89 GiB speed: 6.0 Gb/s 
           serial: <filter> rev: 1B6Q scheme: GPT 
Partition: ID-1: / size: 205.46 GiB used: 32.00 GiB (15.6%) fs: ext4 dev: /dev/sda6 
Sensors:   System Temperatures: cpu: 32.0 C mobo: 29.8 C 
           Fan Speeds (RPM): N/A 
Info:      Processes: 219 Uptime: 1d 2h 19m Memory: 7.67 GiB used: 2.98 GiB (38.9%) Init: systemd v: 239 
           Compilers: gcc: 8.2.1 Shell: bash v: 4.4.23 running in: konsole inxi: 3.0.28 ```

I would also suggest installing and testing both older and newer kernels as this is quite often kernel related. Try at least these three different kernels 4.14, 4.18, and 4.20. Install kernels through Manjaro Settings Manager, and always have at least two kernels installed at all times for safety.

1 Like

I switched kernell and it doesn't change anything, but I found a way to fix the problem :

sudo su
rm /etc/NetworkManager/system-connections/freebox*
rm /etc/NetworkManager/system-connections/FreeWifi*

I don't know why, but there was duplicate config of freebox_XXXXX and FreeWifi in the directory, and no one of my neighbors has the same SSID :thinking:

1 Like

Forum kindly sponsored by