[SOLVED] Wifi not working after reinstall

I was having trouble updating a laptop I hadn't used in a while. Someone suggested that I do a fresh install I did however now my WiFi is not working. The WiFi worked on the liveUSB.

For some reason, my screen stays blank between the manufacturer's splash screen and the login screen, so I can't access Grub after installing a new kernel. According to the rkill command (I think), the WiFi is hard blocked. I have pressed the wifi button on the computer several times but it didn't turn on.

Start by providing:
inxi -Fxzc0

Host: john-pc Kernel: 4.19.0-3-MANJARO x86_64 bits: 64 compiler: gcc
v: 8.2.1 Desktop: Xfce 4.13.2git-UNKNOWN Distro: Manjaro Linux
Type: Laptop System: Hewlett-Packard
product: HP Compaq nx6325 (RM158UT#ABA) v: F.06 serial:
Mobo: Hewlett-Packard model: 30B0 v: KBC Version 40.15 serial:
BIOS: Hewlett-Packard v: 68TT2 Ver. F.06 date: 12/21/2006
Device-1: C1C5 model: Hewlett-Packard Primary charge: 0% status: N/A
Topology: Single Core model: Mobile AMD Sempron 3400+ bits: 64 type: UP
arch: K8 rev.F+ rev: 2 L2 cache: 256 KiB
flags: lm nx pae sse sse2 sse3 bogomips: 1596
Speed: 800 MHz min/max: 800/1800 MHz Core speed (MHz): 1: 1600
Device-1: AMD RS482M [Mobility Radeon Xpress 200] vendor: Hewlett-Packard
driver: radeon v: kernel bus ID: 01:05.0
Display: x11 server: X.Org 1.20.3 driver: ati,radeon unloaded: modesetting
resolution: 1024x768~60Hz
OpenGL: renderer: ATI RS480 v: 2.1 Mesa 18.2.5 direct render: Yes
Device-1: AMD IXP SB4x0 High Definition Audio driver: snd_hda_intel
v: kernel bus ID: 00:14.2
Sound Server: ALSA v: k4.19.0-3-MANJARO
Device-1: Broadcom Limited NetXtreme BCM5788 Gigabit Ethernet
vendor: Hewlett-Packard driver: tg3 v: 3.137 port: 6000 bus ID: 02:01.0
IF: enp2s1 state: up speed: 100 Mbps duplex: full mac:
Device-2: Broadcom Limited BCM4311 802.11b/g WLAN vendor: Hewlett-Packard
driver: b43-pci-bridge v: N/A port: 6000 bus ID: 30:00.0
Local Storage: total: 74.53 GiB used: 6.47 GiB (8.7%)
ID-1: /dev/sda vendor: Hitachi model: HTS721080G9SA00 size: 74.53 GiB
ID-1: / size: 66.78 GiB used: 6.47 GiB (9.7%) fs: ext4 dev: /dev/sda1
ID-2: swap-1 size: 6.18 GiB used: 268 KiB (0.0%) fs: swap dev: /dev/sda2
System Temperatures: cpu: 45.0 C mobo: N/A
Fan Speeds (RPM): N/A
Processes: 138 Uptime: 5h 22m Memory: 2.81 GiB used: 987.9 MiB (34.4%)
Init: systemd Compilers: gcc: 8.2.1 Shell: bash v: 4.4.23 inxi: 3.0.27


If the broadcom-wl-dkms driver is not working under kernel 4.19 try different kernels. Install kernel 4.14 through Manjaro settings manager and test it for wifi operation. If it's still not working, then uninstall all versions of the wl driver and reboot. Perhaps the kernel module may work for you if the wl driver is not.

1 Like

For some reason, the Grub menu doesn't pop up when I boot up. So, I won't be able to select a different kernel.

That is a new "feature". Try the shift key at boot, there are other keys as well. I can't remember exactly, as I don't use that feature.


I switched to the 4.4 kernel and uninstalled those drivers. My WiFi is back. :grin: Thanks.

Now the problem is that the laptop is running slower than when 16.10 was installed. ( Yes, I know I'm running a single core, but it ran decently. Now I have to wait for windows to switch when I alt + tab or open the menu.) I think I'll try openbox.

Openbox is snappier but Xfce should be good enough.
Better check for any errors in journal and .Xsessionerrors

1 Like

Did you mean kernel 4.14?

Glad you got your wifi working.

No, I mean 4.4. Does work on 4.14.

Thanks for confirming that. Much appreciated. Glad you got it working. I guess you can mark this solved. :+1:

I remember now that I had a lot of problems with system slow downs with some of the 4.10+ kernels. Must be a problem with support for my AMD CPU.

Where can I find an isolated for 16.10 xfce? I want to install it on this laptop and see if that clears up the responsiveness issue.

I just popped in another old drive with Manjaro JWM 15.12 with the 4.1 kernel and the cpu is holding steady around 10%. It was running much higher on the 4.10+ kernels.

Well there's nothing wrong with using an older kernel as long as it's still supported. The older LTS kernels still have support for a while yet.

I reinstalled 18.0 XFCE, removed the wl driver and rebooted. Wifi worked and the system ran decently. I guess my originally install of 18.0 was corrupted somehow.

1 Like

This topic was automatically closed 90 days after the last reply. New replies are no longer allowed.

Forum kindly sponsored by