[SOLVED] Wifi not Working after updating Some package [Broadcom BCM43142 802.11b/g/n]

I Have installed Manjaro kde plasma 20.0.3 last night.Then I connected the laptop to my wifi.After connecting to wifi system got some package update.After update i restarted my laptop & then no wifi showing in the Network.

Using inxi -Fxz,
  Host: Manjaro-hp Kernel: 5.6.15-1-MANJARO x86_64 bits: 64 compiler: gcc 
  v: 10.1.0 Desktop: KDE Plasma 5.18.5 Distro: Manjaro Linux 
  Type: Laptop System: Hewlett-Packard product: HP Notebook 
  v: Type1ProductConfigId serial: <filter> 
  Mobo: Hewlett-Packard model: 80C3 v: 96.51 serial: <filter> 
  UEFI: Insyde v: F.27 date: 07/05/2018 
  ID-1: BAT1 charge: 9.3 Wh condition: 24.3/41.4 Wh (59%) 
  model: COMPAL PABAS0241231 status: Discharging 
  Topology: Dual Core model: Intel Core i3-4005U bits: 64 type: MT MCP 
  arch: Haswell rev: 1 L2 cache: 3072 KiB 
  flags: avx avx2 lm nx pae sse sse2 sse3 sse4_1 sse4_2 ssse3 
  bogomips: 13574 
  Speed: 798 MHz min/max: 800/1600 MHz Core speeds (MHz): 1: 798 2: 798 
  3: 799 4: 798 
  Device-1: Intel Haswell-ULT Integrated Graphics vendor: Hewlett-Packard 
  driver: i915 v: kernel bus ID: 00:02.0 
  Display: x11 server: X.Org 1.20.8 driver: intel unloaded: modesetting 
  resolution: 1366x768~60Hz 
  OpenGL: renderer: Mesa DRI Intel HD Graphics 4400 (HSW GT2) 
  v: 4.5 Mesa 20.0.7 direct render: Yes 
  Device-1: Intel Haswell-ULT HD Audio vendor: Hewlett-Packard 
  driver: snd_hda_intel v: kernel bus ID: 00:03.0 
  Device-2: Intel 8 Series HD Audio vendor: Hewlett-Packard 
  driver: snd_hda_intel v: kernel bus ID: 00:1b.0 
  Sound Server: ALSA v: k5.6.15-1-MANJARO 
  Device-1: Realtek RTL810xE PCI Express Fast Ethernet 
  vendor: Hewlett-Packard driver: r8169 v: kernel port: 4000 
  bus ID: 07:00.0 
  IF: enp7s0 state: down mac: <filter> 
  Device-2: Broadcom and subsidiaries BCM43142 802.11b/g/n 
  vendor: Hewlett-Packard driver: wl v: kernel port: 4000 bus ID: 0d:00.0 
  IF: wlp13s0 state: up mac: <filter> 
  Local Storage: total: 931.51 GiB used: 7.09 GiB (0.8%) 
  ID-1: /dev/sda vendor: HGST (Hitachi) model: HTS541010A9E680 
  size: 931.51 GiB 
  ID-1: / size: 57.42 GiB used: 6.94 GiB (12.1%) fs: ext4 dev: /dev/sda2 
  ID-2: /home size: 248.92 GiB used: 155.8 MiB (0.1%) fs: ext4 
  dev: /dev/sda3 
  ID-3: swap-1 size: 7.81 GiB used: 0 KiB (0.0%) fs: swap dev: /dev/sda4 
  System Temperatures: cpu: 40.5 C mobo: N/A 
  Fan Speeds (RPM): N/A 
  Processes: 177 Uptime: 18m Memory: 3.77 GiB used: 1.60 GiB (42.4%) 
  Init: systemd Compilers: gcc: 10.1.0 Shell: bash v: 5.0.17 inxi: 3.0.37**

If i upgrade to a latest kernel(5.7.0-3) & uninstall the previous "linux56-broadcom-wl (" Will it work for me?

Manjaro supports installing many different kernels at once. You can do so through Manjaro Settings Manager or the terminal.

If you don't have a working Ethernet connection you can use USB Android phone tethering for a temporary internet connection to install kernels or packages.

Here is a link you may want to follow if changing kernels brings no success:

Thanks man i didnt installed the latest kernel but tried your guide[Linux kernel headers+broadcom-wl-dkms driver+reboot].Now its working.

I Have 3 question

1.If i install a new kernel i have to configureLinux kernel headers+broadcom-wl-dkms
manually again?or just install a new kernel & then it will configure by itself?

2.How to check my display/graphics driver is installed correctly or not?

3.how to fix
KDE Daemon keeps asking for wi-fi password randomly every time when i connect to a wifi.

Glad that fixed thing up for you.

  1. DKMS will automatically install new kernel headers and rebuild the driver once you have installed a new kernel.

  2. I don't give video driver advice as I don't consider myself expert enough to do so.

  3. KDE has been plagued by that recurring bug for years.

You could try this:

Manually delete your network connection in Network Manager.

After the connection is deleted, then recreate your wifi connection in network manager.

Right click over the wifi icon in your system tray.

Scroll down to configure network connections.

Delete any connections under wifi in the left pane.

Then click on the "+" button to add a connection.

Choose wifi from the list.

When the new window appears click on ssid and enter the name of the connection for the wifi you want to connect to.

Click the tab for your wifi security, choose the one that corresponds to the wifi security you are using.

Enter the password for your wifi then click on save.


Select your wifi connection in Network Manager and apply these settings:

“All users may connect to this network”

“Automatically connect to this network when it is available”

“Store password for all users (not encrypted)”

Then, reboot.


Storing your password unencrypted is a slight security risk if others have physical access to your computer.

There is a possibility others who use your computer may be able to find your WiFi login credentials if it is not encrypted.

This topic was automatically closed 90 days after the last reply. New replies are no longer allowed.

Forum kindly sponsored by