[SOLVED] WiFi speed from 50Mbps to 8Mbps after connecting Bluetooth speaker

Hello,

I recently bought an UE Wonderboom bluetooth speaker and tried connecting to my linux machine - and it worked!
The issue occurred when I tried browsing the internet and all the websites started loading really really slow.
Did a speedtest.net test without the speaker connected and I've got a 50Mbps download speed and another one with the speaker connected resulting in a download speed of maximum 8Mbps!

I also have a bluetooth mouse connected to my laptop and I have no issues with it, so I'd say it's not related to the bluetooth application/driver...

I tried deactivating bluetooth coexistance (as described on arch wiki) with not positive result.
I'm also using tlp for power management so I tried using the bluetooth speaker while plugged-in and noticed no improvement.

Found a similar topic here and someone asked for the output of this command hwinfo --bluetooth --network --wlan. Maybe the output is useful, so here it is:

16: PCI 200.0: 0282 WLAN controller                             
  [Created at pci.378]
  Unique ID: qru8.Dn18G6rxXaB
  Parent ID: 0Rrv.8YtZet0R7aF
  SysFS ID: /devices/pci0000:00/0000:00:1c.7/0000:02:00.0
  SysFS BusID: 0000:02:00.0
  Hardware Class: network
  Model: "Intel Wireless 8265 / 8275"
  Vendor: pci 0x8086 "Intel Corporation"
  Device: pci 0x24fd "Wireless 8265 / 8275"
  SubVendor: pci 0x8086 "Intel Corporation"
  SubDevice: pci 0x9010 
  Revision: 0x78
  Driver: "iwlwifi"
  Driver Modules: "iwlwifi"
  Device File: wlp2s0
  Features: WLAN
  Memory Range: 0xb4100000-0xb4101fff (rw,non-prefetchable)
  IRQ: 137 (no events)
  HW Address: f4:96:34:90:bc:08
  Permanent HW Address: f4:96:34:90:bc:08
  Link detected: yes
  WLAN channels: 1 2 3 4 5 6 7 8 9 10 11 12 13 36 40 44 48 52 56 60 64 100 104 108 112 116 120 124 128 132 136 140
  WLAN frequencies: 2.412 2.417 2.422 2.427 2.432 2.437 2.442 2.447 2.452 2.457 2.462 2.467 2.472 5.18 5.2 5.22 5.24 5.26 5.28 5.3 5.32 5.5 5.52 5.54 5.56 5.58 5.6 5.62 5.64 5.66 5.68 5.7
  WLAN encryption modes: WEP40 WEP104 TKIP CCMP
  WLAN authentication modes: open sharedkey wpa-psk wpa-eap
  Module Alias: "pci:v00008086d000024FDsv00008086sd00009010bc02sc80i00"
  Driver Info #0:
    Driver Status: iwlwifi is active
    Driver Activation Cmd: "modprobe iwlwifi"
  Config Status: cfg=new, avail=yes, need=no, active=unknown
  Attached to: #17 (PCI bridge)

21: USB 00.1: 11500 Bluetooth Device
  [Created at usb.122]
  Unique ID: NwzV.GS0ueMFUyi1
  Parent ID: k4bc.2DFUsyrieMD
  SysFS ID: /devices/pci0000:00/0000:00:14.0/usb1/1-5/1-5:1.1
  SysFS BusID: 1-5:1.1
  Hardware Class: bluetooth
  Model: "Intel Bluetooth Device"
  Hotplug: USB
  Vendor: usb 0x8087 "Intel Corp."
  Device: usb 0x0a2b 
  Revision: "0.10"
  Driver: "btusb"
  Driver Modules: "btusb"
  Speed: 12 Mbps
  Module Alias: "usb:v8087p0A2Bd0010dcE0dsc01dp01icE0isc01ip01in01"
  Driver Info #0:
    Driver Status: btusb is active
    Driver Activation Cmd: "modprobe btusb"
  Config Status: cfg=new, avail=yes, need=no, active=unknown
  Attached to: #23 (Hub)

29: None 00.0: 10701 Ethernet
  [Created at net.126]
  Unique ID: VV91.ndpeucax6V1
  Parent ID: qru8.Dn18G6rxXaB
  SysFS ID: /class/net/wlp2s0
  SysFS Device Link: /devices/pci0000:00/0000:00:1c.7/0000:02:00.0
  Hardware Class: network interface
  Model: "Ethernet network interface"
  Driver: "iwlwifi"
  Driver Modules: "iwlwifi"
  Device File: wlp2s0
  HW Address: f4:96:34:90:bc:08
  Permanent HW Address: f4:96:34:90:bc:08
  Link detected: yes
  Config Status: cfg=new, avail=yes, need=no, active=unknown
  Attached to: #16 (WLAN controller)

30: None 00.0: 10700 Loopback
  [Created at net.126]
  Unique ID: ZsBS.GQNx7L4uPNA
  SysFS ID: /class/net/lo
  Hardware Class: network interface
  Model: "Loopback network interface"
  Device File: lo
  Link detected: yes
  Config Status: cfg=new, avail=yes, need=no, active=unknown

Software versions:
Latest LTS kernel (4.14.34-1)
Latest Gnome (3.28)

Laptop: Xiaomi Mi Notebook Pro

Thanks in advance!!
Tanase B.

Welcome to the wonderful world of radio interference.

You could try switching your wifi to a different channel to see if it helps. Otherwise, you're pretty much stuck.

2 Likes

@jonathon you are right!

I have connected to my mobile hotspot network, connected the bluetooth speaker and the speed tests were almost the same (+/- 1Mbps).

Tried different channels and settings, but nothing worked with my wireless router network.
This is my current configuration, it is an Asus RT-N12D1 router (2.4Ghz).
image

I guess I should try all the channels or get another router..

Or another speaker... :wink:

1 Like

Do you have an Android phone? If so, install the app Wifi Analyzer from the playstore.
It will show you the channels which are busy, either by wifi signals from neighbors, or your bluetooth.
Set the router from selecting channels automatically to a free channel indicated by the app and also change the 20/40MHz to just 20MHz. It will narrow the bandwidth you are using. Try the speedtests again with these settings.

1 Like

Really nice tool, thank you!

It says that channel 14 is the best, but my router has max. 13 channels. The second best channel is 13, but still I have the same issue...

Tried also setting 20Mhz + best channel.

Can you see on which channel the bluetooth connection is working?
If so, choose a channel for wifi as far away from that one as possible.

When you switch of bluetooth things are back to normal?

I can't or at least I don't know how to get the channel my bluetooth speaker is using.

I don't have any network issuses while bluetooth is turned on. I'm successfully using a wireless mouse connected via bluetooth without having my network slowed down. The issue occurs only when I connect this specific bluetooth speaker.

I've found some interference issues between bluetooth and wireless on archwiki; also found similar topics which tells that the problem might be that the bluetooth and wireless uses the same antenna and the bug is only present on Linux (windows working). But still, if I use a wireless network via mobile hotspot, the issue is fixed...

Many says a solution is a wireless router with 5Ghz connection.

UPDATE: my laptop uses Intel® Dual Band Wireless-AC 8265 network controller and from intel's website, this indeed uses the same antenna for wireless and bluetooth.

1 Like

You can try toggling bt coex:
https://wiki.archlinux.org/index.php/Wireless#Bluetooth_coexistence

@cscs already tried that with no luck.
Tried with bt_coex_active=0 and bt_coex_active=N (this is for Intel from what I understood).

That it is. Get your wireless off of the 2.4GHz frequency band. Microwave ovens, wireless speakers, wireless cameras, baby monitors, and most consumer routers are still commonly configured in the 2.4 range. Once you go 5 GHz and you get a stable channel, you'll never go back.

1 Like

I can confirm that it works perfect with a 5GHz connection!

Thank you all for your time!

1 Like

This topic was automatically closed 90 days after the last reply. New replies are no longer allowed.

Forum kindly sponsored by