[SOLVED] Windows Boot Manager and Manjaro

Greetings! New to Manjaro and looking to get started.

However, I am having issues with my original boot manager as well as Manjaro. When I installed Manjaro to my local machine, to an unallocated section of disk (after shrinking my active partition in Windows Disk Manager), I could not boot. Looking around, I found the following article: https://itsfoss.com/no-grub-windows-linux/
I ran the command: bcdedit /set {bootmgr} path \EFI\ubuntu\grubx64.efi
As you might imagine, as we are not in Ubuntu-land, this didn't take on reboot. I am now unable to boot into regular Windows partition, as my system does not seem to detect it. I do, however, have a recovery USB for both Windows and Manjaro. None of my files seem affected.
Am I able to run a command in either Manjaro or Windows recovery systems such that I can reset my EFI settings (since those seem to be what I messed up?)

Any assistance you can provide is greatly appreciated, as I am positive I can undo it, but am not quite sure how. I deleted Manjaro off my SSD and reformated and merged its space back into my SSD volume using a combination of gPart from the Manjaro USB and DiskPart from my Windows USB. If there are any questions you would like me to answer, I would be more than happy to.

inxi -Fxzresults:

  Host: manjaro Kernel: 4.14.39-1-MANJARO x86_64 bits: 64 compiler: gcc 
  v: 7.3.1 Desktop: N/A Distro: Manjaro Linux 17.1.10 Hakoila 
  Type: Desktop Mobo: ASUSTeK model: ROG STRIX Z370-I GAMING v: Rev X.0x 
  serial: N/A UEFI [Legacy]: American Megatrends v: 0430 date: 11/01/2017 
  Topology: 6-Core model: Intel Core i5-8600K bits: 64 type: MCP 
  arch: Skylake rev: 10 L2 cache: 9216 KiB 
  flags: lm nx pae sse sse2 sse3 sse4_1 sse4_2 ssse3 vmx bogomips: 43212 
  Speed: 800 MHz min/max: 800/4300 MHz Core speeds (MHz): 1: 800 2: 800 
  3: 800 4: 800 5: 800 6: 800 
  Card-1: NVIDIA GP106 [GeForce GTX 1060 6GB] driver: nvidia v: 396.24 
  bus ID: 01:00.0 
  Display: x11 server: N/A driver: nvidia resolution: <xdpyinfo missing> 
  OpenGL: renderer: GeForce GTX 1060 6GB/PCIe/SSE2 v: 4.6.0 NVIDIA 396.24 
  direct render: Yes 
  Card-1: Intel 200 Series PCH HD Audio driver: snd_hda_intel v: kernel 
  bus ID: 00:1f.3 
  Card-2: NVIDIA GP106 High Definition Audio driver: snd_hda_intel v: kernel 
  bus ID: 01:00.1 
  Sound Server: ALSA v: k4.14.39-1-MANJARO 
  Card-1: Intel Ethernet Connection I219-V driver: e1000e v: 3.2.6-k 
  port: N/A bus ID: 00:1f.6 
  IF: enp0s31f6 state: down mac: <filter> 
  Card-2: Realtek RTL8822BE 802.11a/b/g/n/ac WiFi adapter driver: r8822be 
  v: kernel port: d000 bus ID: 03:00.0 
  IF: wlp3s0 state: up mac: <filter> 
  HDD Total Size: 2.85 TiB used: 38.93 GiB (1.3%) 
  ID-1: /dev/sda model: Samsung_SSD_840 size: 111.79 GiB 
  ID-2: /dev/sdb model: ST3000DM008-2DM1 size: 2.73 TiB 
  ID-3: /dev/sdc type: USB model: silicon-power size: 7.21 GiB 
  ID-1: / size: 11.70 GiB used: 346.3 MiB (2.9%) fs: overlay dev: ERR-102 
  System Temperatures: cpu: 29.8 C mobo: 27.8 C gpu: nvidia temp: 34 C 
  Fan Speeds (RPM): cpu: 0 gpu: nvidia fan: 0% 
  Processes: 197 Uptime: 19m Memory: 15.61 GiB used: 1.64 GiB (10.5%) 
  Init: systemd Compilers: gcc: 7.3.1 Shell: bash v: 4.4.19 inxi: 3.0.07 

Try this. But over here we do not use bcd. We use grub.

bcdedit /set {bootmgr} path \EFI\Manjaro\grubx64.efi

Boot from your Manjaro Stick and have it detect bootable systems. Boot into Windows and do the bcdedit with your Manjaro grubx64.efi. Or change it back to Windows

$ bcdedit /set '{bootmgr}' path \EFI\Microsoft\Boot\bootmgfw.efi

No recovery needed.

Have it detect bootable operating systems? Can you be a bit more specific on that? The Manjaro stick says that there is an operating system, but it just boots me through my BIOS boot order (Windows Boot Manager, SSD, Network, USB) and back into Manjaro.

Yeah, that command is what I should have ran in the first place, but I wonder if it would have made it so I could only get into Manjaro and still lost access to Windows?? From what gohlip is saying, we don't use BCD anymore as of 17.0.1?

Thanks for the information, saw your replies on several different forum questions. :slight_smile: Just found out I can recover a second SSD to use for my machine, so I might end up using one for Manjaro and one for Windows, provided I can get Windows back up and running. As I have an Asus model mobo, I think setting up a custom boot entry may be my best bet for getting Windows back on track, does that sound likely to you?

It says in the Boot-Stick Menu

Detect Efi Bootloaders

After starting it select from the list the entry with


This will start your Windows. And this is exactly the entry you should restore with bcdedit.

Note not all Asus models have the "difficult UEFI setup" and may just work straight 'off the playbook', meaning without any special adjustments in the bios settings. You may want to try 'straight off the playbook' and see if that works for you. Anyway, the 'difficult' Asus settings, if required, is not because of any 'tie-in' with Microsoft. Makes it more 'palatable' and acceptable.

But to be clear, the Asus link for the settings is here.. The term described is " Add New Boot Option", not "custom boot entry".

Good luck. We're here if you need us. Cheers.

Very good information, thank you! Thank you for the link, it certainly looks beneficial for me in the future.

1 Like

For some reason, it was not showing Detect EFI Bootloaders, though it had before. I went into my UEFI settings and switched around some stuff to detect OtherOS versus UEFI Windows.
I ran bcdedit.exe to restore the Windows boot manager. Lets see if this persists across reboot...
EDIT: It does!! Thank you, gohlip, calvous, and razvanstr! You've sold me on Manjaro, I'll be back! :smiley:

1 Like

Glad it worked out this way. I've setup my system exactly the same way you tried to (w/o making the mistake setting the wrong boot path with bcdedit). My Manjaro is running on a Surface Pro, Microsofts very own hardware. Any efibootmgr settings fail on this system and will be resetted once I boot into Win10 again. If you have the same issues set your boot path to Manjaro as you intendet to in the first place. Give it a Label so you not get confused:

$ bcdedit /set '{bootmgr}' description "Manjaro"
1 Like

This topic was automatically closed 30 days after the last reply. New replies are no longer allowed.

Forum kindly sponsored by