[SOLVED] Windows lagging behind when moving - xfce, manjaro 18.0.4 stable vs 18.1pre2 testing


I recently noticed that windows are lagging behind on my system (testing branch, xfce, intel uhd 620). Not sure with which update it came in though.

When running 18.0.4 stable live ISO, there is no such issue.
Just to make sure it's not because of me messing up config setting, I also tried the latest dev iso 18.1.0pre2. Same issue there as well.

Here two short videos that should explain the problem

18.0.4 stable ISO, no prob. Window follows cursor almost instantly:

18.1.0pre2, there is quite some delay before the window follows the cursor:

Graphics:  Device-1: Intel UHD Graphics 620 driver: i915 v: kernel 
           Display: x11 server: X.Org 1.20.5 driver: intel unloaded: modesetting resolution: 3440x1440~60Hz 
           OpenGL: renderer: Mesa DRI Intel UHD Graphics 620 (Kabylake GT2) v: 4.5 Mesa 19.0.5 

What I tried so far is:

  • using 4.19 kernel instead of 5.1
  • modesetting instead of the intel driver
  • different themes

Doesn't change things though. I assume it has something to do with the compositor. When compositing is switched off, it is not lagging.

Has anyone experienced the same?

Just tried 18.1.0pre1 no issue there.


Ok, found it: https://git.xfce.org/xfce/xfwm4/commit/?id=e07574d6e7a2dbaa08c3ba4765c6306073d9493e

Setting vblank_mode to xpresent is fixing it (but may introduce other issues, see https://bugzilla.xfce.org/show_bug.cgi?id=15325)
Also note that CPU consumption seems to be higher while dragging windows around.

xfconf-query -c xfwm4 -p /general/vblank_mode -s xpresent

Videos tell nothing. have you tried turning the compositor of, Also compton really sorts XFCE out their must be 500 threads on this problem in xfce, just save yourself time use the search facility on this forum not google.

Why not? You can see pretty clearly what the issue is from those videos. I'd say it makes it much clearer than trying to explain things with text.

Yes, I did. The point is that even when compositing is enabled, previously things were fine and they are not anymore. I don't want to disable compositing ->

I am not using compton. xfwm4 is the default compositor and is was working fine before so why bother switching to compton.

btw. In the meanwhile I could find out what has changed and how to "fix" it. Hopefully that might help some of the folks here.

So let get this clear something with XFCE is running on on a broomstick.
That is what a video says
You can't be bothered to give proper system specs, something like inxi -F
you refuse to try the advice given about trying compton the known cure for 99% of problem with xfce installed on a broomstick as per your video


Well, not anymore as I mentioned.

Don't know, maybe you don't see it. The intention was to show that when a window is moved, it lags behind the cursor position quite a bit.

I did post inxi -G and explained what I tried so far.

Because at that point the problem was already solved. Also I prefer trying to fix things and find out the root cause instead of just installing different software. If everybody would just switch to different applications instead of having issues solved in the ones they are using, where would we be now?

Again, xfwm is the default compositor of the main xfce edition of manjaro. I have a problem, so I try to find a solution for it (preferably together with the community in case they have noticed a similar problem / behavior, hence this post)

I don't get why you bashing around here.

That is the problem do a forum search its the worst compositor for xfce even Xcomp gives better results, So its not about installing software its about installing better software fit for the job.

I get your point. Could be that compton is much better doing the job. But again, I tried to find a solution for xfwm.

It always worked fine until a certain point, I wanted to figure out why.

Of course I could just switch to compton instead... Again, I try to solve issues in the current release of manjaro and it's software. If manjaro decides to go compton. Ok fine. But until then it should be the focus to get things running good with the current standard installation setup. So most of them are using xfwm.

@moson I respect what you are trying to say but you can't make a silk purse out of a pigs ear unfortunately.

1 Like

:slight_smile: I'd still go for pig leather instead of silk. :wink:
Maybe we can turn it into calf leather some time...

btw. Maybe there should be a discussion on whether manjaro should be delivering xfwm or compton as their default compositor.

Nevertheless you've got me to try out compton. I'm curious now :wink:

This topic was automatically closed 90 days after the last reply. New replies are no longer allowed.

Forum kindly sponsored by