[SOLVED] Won't start after deleting Fat16 partition

Any way to restore it?

Only if you had a clone of your harddrive before making the change.

Then no

Hold on.
From anywhere (livecd-usb, most likely), print out

sudo parted -l
sudo blkid
efibootmgr -v
and contents of /etc/fstab at the installed manjaro installed partition (use file manager)

All disks do not omit and explain partitions.

And are you positive both windows and Manjaro are uefi ?
If not sure, it's okay, just say so and what you know..windows for example.

1 Like

Currently I only have tails on a spare USB and I can't access /etc/fstab from it at the moment, it doesn't recognize it. Here are the previous commands

amnesia@amnesia:~$ sudo parted -l

We trust you have received the usual lecture from the local System
Administrator. It usually boils down to these three things:

    #1) Respect the privacy of others.
    #2) Think before you type.
    #3) With great power comes great responsibility.

[sudo] password for amnesia: 
Model: Sony Storage Media (scsi)
Disk /dev/sda: 15.8GB
Sector size (logical/physical): 512B/512B
Partition Table: gpt
Disk Flags: 

Number  Start   End     Size    File system  Name   Flags
 1      1049kB  8591MB  8590MB  fat32        Tails  boot, hidden, legacy_boot, esp

Model: ATA TOSHIBA MQ04ABF1 (scsi)
Disk /dev/sdb: 1000GB
Sector size (logical/physical): 512B/4096B
Partition Table: gpt
Disk Flags: 

Number  Start   End    Size   File system  Name                  Flags
 1      32.8kB  892GB  892GB  ntfs         Basic data partition  msftdata
 2      892GB   892GB  538MB  fat32                              msftdata

Model: ATA ADATA SU800NS38 (scsi)
Disk /dev/sdc: 128GB
Sector size (logical/physical): 512B/512B
Partition Table: gpt
Disk Flags: 

Number  Start   End     Size    File system  Name                          Flags
 1      1049kB  17.8MB  16.8MB               Microsoft reserved partition  msftres
 2      17.8MB  128GB   127GB   ntfs         Basic data partition          msftdata
 3      128GB   128GB   517MB   ntfs                                       hidden, diag

amnesia@amnesia:~$ sudo blkid
[sudo] password for amnesia: 
/dev/sda1: LABEL="TAILS" UUID="4619-5EE0" TYPE="vfat" PARTLABEL="Tails" PARTUUID="b66b03e4-f225-4062-bf7a-bf89909fb2fe"
/dev/sdb1: LABEL="General" UUID="0206436706435B35" TYPE="ntfs" PARTLABEL="Basic data partition" PARTUUID="cb150de2-3032-46a7-8b0c-dd5824ab42c8"
/dev/sdb2: UUID="A088-7C2F" TYPE="vfat" PARTUUID="1f3818d9-2d64-4252-ab68-20b620678875"
/dev/sdc1: PARTLABEL="Microsoft reserved partition" PARTUUID="9aab70ef-5663-4c41-b109-a7d043ad434c"
/dev/sdc2: UUID="64108DC9108DA322" TYPE="ntfs" PARTLABEL="Basic data partition" PARTUUID="3bb63727-ffe3-4f7d-b730-8a2ae3b366a1"
/dev/sdc3: UUID="C2C8FBFCC8FBEC93" TYPE="ntfs" PARTUUID="c1d34300-2e7b-4f86-bb38-3ebb5aea8f90"
/dev/loop0: TYPE="squashfs"
amnesia@amnesia:~$ efibootmgr -v
BootCurrent: 0000
Timeout: 0 seconds
BootOrder: 2001,2002,2003
Boot0000* USB HDD: Sony    Storage Media	PciRoot(0x0)/Pci(0x14,0x0)/USB(12,0)/HD(1,GPT,b66b03e4-f225-4062-bf7a-bf89909fb2fe,0x800,0x1000000)RC
Boot2001* EFI USB Device	RC
Boot2003* EFI Network	RC

And both of them are UEFI

Okay, but ("and I can't access /etc/fstab") fstab is important.

Here's what I suggest, trusting that your manjaro fstab has a 'valid' /boot/efi entry at fstab.
[It may not be 'valid' if your /boot/efi partition is no longer there. Most likely and hopefully sdb2]
If you can check that it is there in fstab, that would be better.

Now use use this first post to try to boot manjaro. Oh, you can use Tails grub and its grub prompt to do that.

Note do the 2 extra UEFI commands there. Important.
Also important, if any of the disk is removable, do not unplug any disk until we resolve this.
And tell us which disk is removable. Manjaro?

Oh sorry late here, I may log off and you may hear from me much later.
But @AgentS can intercede if he's awake.

How do I open the grub prompt from tails?

At grub menu, press 'c' (if your tails have grub).
If none, use manjaro livecd. Follow the post in the link.
Doesn;t mattter how we boot into manjro, as long as we boot into it.
Oh... start in uefi. Always. if installed manjaro is uefi.

And when/if we boot into it, we can check its fstab, Do that.
Verify with 'findmnt /boot/efi'

Is it possible to also restore my Windows from this? Because I need it more urgently than my Manjaro. If it's not possible it would be better to just start reinstalling both right away

If we can restore manjaro grub and if windows is uefi, and if its boot file (efi) is still there somewhere (not the deleted partition, I hope) then yes, we can get windows.

And we can check if windows boot file is there at any (uefi) grub prompt with
grub> search.file /EFI/Microsoft/Boot/bootmgfw.efi

It has 2 hidden partitions on my SSD, so I don't know. I'm currently redownloading Manjaro so I'll give it a try from the grub menu if it manages to get to it.

Ubuntu install cd will also work as will debian and some more.
But they have to be started in uefi mode.

Before I sign off, if windows is more important (to you) and you you know how to restore windows, suggest you restore windows first and then we can work on getting back your manjaro later. We've no problem with that.

Good night.

1 Like

It returns with no such device for both search.file /etc/manjaro-release root and search.file /EFI/Microsoft/Boot/bootmgfw.efi

Command to search is not
search.file /etc/manjaro-release root
search.file /etc/manjaro-release
(no 'root')

Then to set 'grub to root' the next command follows. (if there is an output)
search.file /etc/manjaro-release root

But not having windows file doesn't look good either (for windows).

Perhaps the other posters here are right. Maybe you will need to reinstall.
But we tried.

search.file /etc/manjaro-release still returns no such device


Still.... why /etc/manjaro-release is not there?
Unless you also bungled Manjaro root partition?
Shoiuld be there and bootable, regardless if $esp is destroyed.

Surely that's not possible. That FAT16 partition has been there long before I installed Manjaro. It was in the beginning of the drive, after it was a huge NTFS partition and my Manjaro partitions (including its boot/efi) started only after the NTFS partition.

Ok then, one last question - do I need to live boot into Manjaro as UEFI in order to install it as UEFI?

Right now, your fat12 partition does not mean anything.
As long as you have a undestroyed manjaro root partition (and boot kerneles in it), we can boot it.
Even if mbr is destroed (in the case of bios-legacy, which I originally thought that is the case), it will boot.

In othere words, we don't need mbr or $esp to boot as long as root partition is okay and kernels are there.

1 Like

Forum kindly sponsored by