[SOLVED] XFCE Live 18.0.4 Desktop Environment unresponsive on HP latptop with AMD Radeon

Hi all,

I am trying to use the XFCE 18.0.4 64bit live media to eventually install Manjaro on a new HP laptop which came with Windows 10 pre-installed. I am succesfully booting from a USB drive - which by the way I successfully used to boot and install a few weeks ago on a different machine.

I have installed XFCE on a bunch of laptops already and this is the first time I encounter such a blocking issue. What I usually do is boot into the live media, do some quick testing of e.g. wifi (connecting, going on the internet, checking if main 'hardware buttons' work. Then upon success (up to now always), start the install with the installer.

I would be grateful on further ideas and tests on how to debug this, given that while the final aim is to install Manjaro and replace the pre-installed Windows I would really like to do the 'live test' also because this machine is for my mother and therefore ideally once set-up relatively low maintenance :slight_smile:

So thanks in advance to anyone patient enough to read on :slight_smile:

Main Machine specs:

  • CPU: AMD 8032 (2 processors) "Radeon" (actually probably a E 9000e)
  • RAM: 4 GB
  • 240 GB SSD drive
  • Graphics card: Radeon Series (couldn't detect the exact model)

What works:

  • Booting from USB
  • Boot-up: it is quite smooth given this is a live edition and not the highest end machine
  • Once booted (see also below) going to a console with CTRL+ALT+F1 etc. works and the console seems 'normal' (i.e. responsive)
  • Probably not so relevant: but boot into the pre-installed Windows 10 (albeit with usual 'windows-slugginesh... :stuck_out_tongue_winking_eye:)

Main issue
After usual live bootup the Desktop environment loads with the usual Manjaro 'welcome' screen visible but then freezes for a long time.
The XFCE panel is displayed but (for instance) the notification area (where usually you have bluetooth, network manager etc.) seems mangled with weird squares.
The mouse pointer is responsive to movement, but when clicking (both left and tight) all elements (including trying to e.g. close the welcome window), is unresponsive, in some cases seemingly taking seconds to react or just nothing happening.
Same goes with known keyboard shortcuts such as ALT+F2 or CTRL+ALT+T for opening a terminal.

Things I have tried with no success

  • The BIOS offers booting the USB both as 'UEFI' and not. Tried both
  • Swapping USB ports
  • Booting with both the 'free' and 'non-free' drivers (at the grub menu)
  • Opening a textual concolse (CTRL+ALT+F2) and doing a free which shows ca. 500 Mb of RAM used on a total of 4GB available
  • Still in the textual console doing a top and from there it doesn't look there are any crazy processes or CPU consumption

The only real difference I see here compared to previous successful installations is the AMD CPU and graphics. Could this be a problem even when selecting the 'free' driver? Also: this is not the fastest machine but my general experience with live XFCE (not only on Manjaro) is that it usually worked well even on much lower-specs.

Essentially my concern is not so much about the live (I think I could try installing without), but if and how this will work out once installed.

This seems like a kernel issue with amdgpu drivers.
Can you try the most recent 18.1 RC? I believe that is running 5.1 or 5.2.

I can confirm that with the latest RC4 the live media worked correctly, including the DE with the 'free' driver. Indeed I just finished installing the system successfully.

In case it might be useful the CPU and graphics card information follows:

-Processors-
Package Information	
AMD E2-9000e RADEON R2, 4 COMPUTE CORES 2C+2G	0	0:0	1500.00 MHz	
AMD E2-9000e RADEON R2, 4 COMPUTE CORES 2C+2G	1	0:1	1500.00 MHz	

-GPUs-
drm-card0		: Advanced Micro Devices, Inc. [AMD/ATI] Stoney [Radeon R2/R3/R4/R5 Graphics]

This topic was automatically closed 90 days after the last reply. New replies are no longer allowed.

Forum kindly sponsored by