[SOLVED] XMonad + Xfce : Could not get owner of name 'org.xfce.SessionManager'

Has anyone working with XMonad and Xfce dealt with the error "How to provide good information in your posts" when trying to quit XMonad? I've tried searching this wiki and google, but could not find anything relevant or quite understandable. I've also tried what was suggested at the Haskell wiki but could not find a fix.

Here's some info about my current setup (Sorry if irrelevant info is in! Trying to think of what's relevant and go by the guidelines in the post-placeholder text). Included is .xsessionrc, .xinitrc, xmonad.hs and output from inxi -Fxz.

Any input would be greatly appreciated!



# Load resources

xrdb -merge .Xresources

# Set up an icon tray
stalonetray &

# Set up battery icon
xfce4-power-manager &

# Fire up apps

xscreensaver -no-splash &

if [ -x /usr/bin/nm-applet ] ; then
   nm-applet --sm-disable &

exec xmonad


# .xinitrc

xrandr -s 0

[[ -f $HOME/.Xresources ]] && xrdb -merge $HOME/.Xresources
xsetroot -cursor_name left_ptr
xsetroot -solid '#80a0af'

# if we have private ssh key(s), start ssh-agent and add the key(s)
if [ -x /usr/bin/ssh-agent ] && [ -f $id1 -o -f $id2 -o -f $id3 ];
	eval `ssh-agent -s`
	ssh-add < /dev/null

xset fp+ /usr/local/lib/X11/fonts/terminus
xset fp+ /usr/local/lib/X11/fonts/ghostscript
xset fp+ /usr/X11R6/lib/X11/fonts/TTF/

# xset fp rehash
xset b 100 0 0
xset r rate 140 200

xmodmap -e "keycode 233 = Page_Down"
xmodmap -e "keycode 234 = Page_Up"
xmodmap -e "remove Lock = Caps_Lock"
xmodmap -e "keysym Caps_Lock = Control_L"
xmodmap -e "add Control = Control_L"


# launch the external 60 second clock, and launch the workspace status bar
xmonad-clock | dzen2 -e '' -x 400 -w 1200 -ta r -fg $FG -bg $BG &

xmonad &

# wait for xmonad
wait $!
pkill -HUP dzen2
pkill -HUP -f xmonad-clock


import XMonad
import XMonad.Config.Xfce
import XMonad.Hooks.DynamicLog
import XMonad.Hooks.ManageDocks
import XMonad.Util.Run(spawnPipe)
import XMonad.Util.EZConfig(additionalKeys)
import System.IO

main = do
    xmproc <- spawnPipe "xmobar"

    xmonad $ xfceConfig
        { terminal = "xfce4-terminal"
	, manageHook = manageDocks <+> manageHook defaultConfig
        , layoutHook = avoidStruts  $  layoutHook defaultConfig
        , logHook = dynamicLogWithPP xmobarPP
                        { ppOutput = hPutStrLn xmproc
                        , ppTitle = xmobarColor "green" "" . shorten 50
        , modMask = mod4Mask     -- Rebind Mod to the Windows key
        } `additionalKeys`
        [ ((mod4Mask .|. shiftMask, xK_z), spawn "xscreensaver-command -lock; xset dpms force off")
        , ((controlMask, xK_Print), spawn "sleep 0.2; scrot -s")
        , ((0, xK_Print), spawn "scrot")

From inxi -Fxz

System:    Host: QueenTeenPrinceX Kernel: 4.14.60-1-MANJARO x86_64 bits: 64 compiler: gcc v: 8.1.1 Desktop: N/A 
           Distro: Manjaro Linux 
Machine:   Type: Laptop System: Apple product: MacBookPro5,3 v: 1.0 serial: <filter> 
           Mobo: Apple model: Mac-F22587C8 serial: <filter> UEFI: Apple v: MBP53.88Z.00AC.B03.0906151647 
           date: 06/15/09 
Battery:   ID-1: BAT0 charge: 72.6 Wh condition: 76.5/77.8 Wh (98%) model: Newer Tech A1321 status: Charging 
CPU:       Topology: Dual Core model: Intel Core2 Duo P8800 bits: 64 type: MCP arch: Penryn rev: A 
           L2 cache: 3072 KiB 
           flags: lm nx pae sse sse2 sse3 sse4_1 ssse3 vmx bogomips: 10617 
           Speed: 1592 MHz min/max: 1596/2660 MHz Core speeds (MHz): 1: 1592 2: 1592 
Graphics:  Card-1: NVIDIA G96M [GeForce 9600M GT] driver: nouveau v: kernel bus ID: 02:00.0 
           Card-2: NVIDIA C79 [GeForce 9400M] driver: nouveau v: kernel bus ID: 03:00.0 
           Display: x11 server: N/A driver: nouveau unloaded: modesetting resolution: <xdpyinfo missing> 
           OpenGL: renderer: NVAC v: 3.3 Mesa 18.1.5 direct render: Yes 
Audio:     Card-1: NVIDIA MCP79 High Definition Audio driver: snd_hda_intel v: kernel bus ID: 00:08.0 
           Sound Server: ALSA v: k4.14.60-1-MANJARO 
Network:   Card-1: NVIDIA MCP79 Ethernet driver: forcedeth v: kernel port: 31e0 bus ID: 00:0a 
           IF: enp0s10 state: up speed: 1000 Mbps duplex: full mac: <filter> 
           Card-2: Broadcom Limited BCM4322 802.11a/b/g/n Wireless LAN driver: wl v: kernel bus ID: 04:00 
           IF: wlp4s0 state: up mac: <filter> 
Drives:    Local Storage: total: 312.35 GiB used: 7.83 GiB (2.5%) 
           ID-1: /dev/sda vendor: Toshiba model: MK3255GSXF size: 298.09 GiB 
           ID-2: /dev/sdb type: USB model: UFD 3.0 Silicon-Power16G size: 14.26 GiB 
Partition: ID-1: / size: 283.46 GiB used: 7.83 GiB (2.8%) fs: ext4 dev: /dev/sda2 
           ID-2: swap-1 size: 8.80 GiB used: 0 KiB (0.0%) fs: swap dev: /dev/sda3 
Sensors:   System Temperatures: cpu: 69.0 C mobo: N/A 
           Fan Speeds (RPM): N/A 
           GPU: device: nouveau temp: 71 C device: nouveau temp: 72 C 
Info:      Processes: 117 Uptime: 19m Memory: 7.54 GiB used: 870.3 MiB (11.3%) Init: systemd Compilers: 
           gcc: 8.1.1 Shell: bash v: 4.4.23 inxi: 3.0.18 

In case anyone else is running into this issue this link was particularly helpful.

It came down the following (assumes xmonad & ghc are already installed and xmonad --recompile was run):

  1. Backup .config dir (just to be safe)
  2. Open Sessions and Startup in Xfce Settings Manager
  3. Enable session chooser and automatic saving of sessions
  4. Log out
  5. Log in again and choose "create a new session"
  6. Open Xfce Settings Manager and make the following changes:
  • Desktop -> Icons = None
  • Keyboard = may be helpful to undo the Super L/R shortcuts
  • Preferred Applications = set Terminal to whatever
  1. In Xfce Settings Manager -> Session and Startup -> Application Autostart add an entry for xmonad with the following in command: xmonad --replace and make sure it's checked!
  2. Run xmonad --replace and you should be set!

This topic was automatically closed 30 days after the last reply. New replies are no longer allowed.

Forum kindly sponsored by