Solving the Slow and laggy Firefox problem

try refreshing firefox profile OR create new profile to validate if this is just profile specific or generic issue

Do this
firefox --no-remote --ProfileManager %u

then create new profile.

[OT]
The Annie Lennox YT video, https://www.youtube.com/watch?v=HG7I4oniOyA&index=2&list=PL8LTysrNMvaGEUMl0LlSLoz2C1-4Mej0J, plays fine for me. I did the 04-02 update last night.
BUT I'm using Mozilla's Firefox.
$> mozilla-firefox --version Mozilla Firefox 52.0.2
Which Firefox do you use? I will assume from the KDE Plasma in your info that you use the "enhanced" version, firefox-kde. Perhaps try the other, firefox, but, NB, it will replace the 'enhanced' firefox-kde version.
You could also try the binary beta
yaourt firefox-beta-bin
which will install alongside of the firefox ...not sure if it will for the firefox-kde as I stopped using firefox-kde a long time ago(did not work good for me).

HTH...
[/OT]


Thanks but this has been going on for years ...in windoz too tho' not as dramatic. I'm 90% certain it is cache related. After a while, sometimes, for some websites, the Back|Forward will work as it should(well almost: only a second delay).

c-ya

My set up is updated to 2017-04-02 with firefox kde. But video playback issue is happening for chromium also.

On 1st April i tried playing videos from April Fool's day prank thread started by philm and it did not work. I thought that's how it is supposed to be. youtube videos or i must say html5 playback is not happening on my KDE plasma setup.

I shall start a new thread for this issue else current thread wud go off-topic.

1 Like

Fixed this problem by following steps
In konsole type
kdesu dbus-launch konsole

In new Root konsole window execute below commands in exact order
pacman -Rndd ffmpeg
pacman -S ffmpeg
pacman -S --asdeps ladspa

I know i am technically necrobumping, but otoh this Tutorial is still being actively referenced in the forum, eg:

Therefore, i thought i might inspect some of the OP recommendations in my FF-Nightly Version 76.0a1 (2020-03-22) (64-bit). This is not exhaustive; i just tried a few, but a high proportion of those i tried, do not have a matching pre-existing flag already in my FF-N's about:config, eg:
browser.cache.use_new_backend
network.http.pipelining
So maybe these ones simply need manual creation [though it was not mentioned for them, unlike an earlier one] & thence would still work... or maybe they're now superseded in contemporary FF? :woman_shrugging:

Wrt Graphics, mine simply says
Compositing WebRender
...so maybe the OP advice is now superseded [not saying it is, i dunno]? :woman_shrugging:

IMO Tutorials are wonderful when fresh out of the oven, but become a double-edged sword breadknife with the passage of time.

2 Likes

Three years ago was pre-Firefox Quantum wasn't it? So yes, some options will have changed or been removed. Good warning for folks tempted to go hunting.

2 Likes

Would it be appropriate to tag this thread as outdated?

2 Likes

It would be more appropriate to bring it to @BS86 attention and let them decide to either update it or self-flag.

That said, it is a Wiki post so anyone can edit it.

3 Likes

Afaik iirc tla, when it was written FF was still with the [IMO ghastly] Australis paradigm [ugh, hated that]. Again afaik but happy to be corrected, the change to Quantum also changed various flags [hate myself for using the chromium terminology here, but it's quick & dirty] which furthermore, as Quantum itself has matured has further changed many flags.

Somehow IMO tutes like this need some kind of sunset-clause [or maybe a validity-canary, teehee]...?


Just checked some old bookmarks. Q arived with FF 57, which was 2017, maybe June'ish? Hmmm, more like November apoparently...


2 Likes

I added a note.

3 Likes

Not sure if the topic should be kept for some historic purposes or if someone wants to check if the commands still help. I edited the starting post to at least tell the facts at the beginning but I would have no problem with setting it private only / hiding it from the public / deleting it.

Personally, I reverted all the manual changes not long after the Quantum update and don't have any motiviation on trying them again as Firefox is definitely not slow or laggy at all since Quantum arrived.

2 Likes

I think the amended 1st post's banner

This tutorial was created pre-Quantum (FF57). Some commands might still help, but most won't. Consider this tutorial outdated and obsolete!

is lucid & explanatory, ie, excellent.

From my perspective, re my heinous necrobump, i was simply anxious to help illuminate that whilst once accurate, anyone post-Australis trying to blindly apply some of those settings now might end up "disappointed" or worse. Also, the banner might now stop other Manjaroos cross-referencing this thread to noobs.

1 Like

It is really quite simple to fix such issues with FF or any modern browser:

Well prune the excess number of Add-ons and Extensions.
Especially those that are buggy or utterly useless.

Don't install excessive numbers of those things in the First Place!!!

Forum kindly sponsored by