Some keyboard Keys not working

Hey everyone

My laptop worked just fine just last week. Booted it up today to write up something and noticed that the, spacebar, 4, 6 and a shift keys no longer worked. I checked the keyboard layout in settings and it was on generic 86-key, so I switched it to generic 101-key and rebooted. Issue remains. I'm typing this via a spare keyboard i plugged in. I am still lovin' Manjaro and any input would be appreciated,
Thanks

20200731_225154

System:    Host: er-pc Kernel: 4.19.133-1-MANJARO x86_64 bits: 64 compiler: gcc v: 10.1.0 Desktop: KDE Plasma 5.19.3 
           Distro: Manjaro Linux 
Machine:   Type: Laptop System: TOSHIBA product: Satellite P875 v: PSPLAU-006006 serial: <root required> 
           Mobo: TOSHIBA model: Portable PC v: MP serial: <root required> UEFI [Legacy]: Insyde v: 6.30 date: 01/17/2013 
Battery:   ID-1: BAT0 charge: 67.7 Wh condition: 71.3/47.5 Wh (150%) model: PA5024U-1BRS status: Discharging 
CPU:       Topology: Dual Core model: Intel Core i5-3210M bits: 64 type: MT MCP arch: Ivy Bridge rev: 9 
           L2 cache: 3072 KiB 
           flags: avx lm nx pae sse sse2 sse3 sse4_1 sse4_2 ssse3 vmx bogomips: 19954 
           Speed: 1197 MHz min/max: 1200/3100 MHz Core speeds (MHz): 1: 1197 2: 1197 3: 1197 4: 1197 
Graphics:  Device-1: Intel 3rd Gen Core processor Graphics vendor: Toshiba driver: i915 v: kernel bus ID: 00:02.0 
           Display: x11 server: X.Org 1.20.8 driver: intel unloaded: modesetting resolution: 1600x900~60Hz 
           OpenGL: renderer: Mesa DRI Intel HD Graphics 4000 (IVB GT2) v: 4.2 Mesa 20.1.3 direct render: Yes 
Audio:     Device-1: Intel 7 Series/C216 Family High Definition Audio vendor: Toshiba driver: snd_hda_intel v: kernel 
           bus ID: 00:1b.0 
           Sound Server: ALSA v: k4.19.133-1-MANJARO 
Network:   Device-1: Qualcomm Atheros AR8162 Fast Ethernet vendor: Toshiba driver: alx v: kernel port: 2000 
           bus ID: 01:00.0 
           IF: enp1s0 state: down mac: 00:26:6c:19:77:4d 
           Device-2: Intel Centrino Wireless-N 2200 driver: iwlwifi v: kernel port: 2000 bus ID: 02:00.0 
           IF: wlp2s0 state: up mac: 9c:4e:36:1c:4e:30 
Drives:    Local Storage: total: 111.79 GiB used: 12.03 GiB (10.8%) 
           ID-1: /dev/sda vendor: PNY model: CS900 120GB SSD size: 111.79 GiB 
Partition: ID-1: / size: 109.53 GiB used: 12.03 GiB (11.0%) fs: ext4 dev: /dev/sda1 
Sensors:   System Temperatures: cpu: 60.0 C mobo: N/A 
           Fan Speeds (RPM): N/A 
Info:      Processes: 167 Uptime: 30m Memory: 5.71 GiB used: 1.26 GiB (22.0%) Init: systemd Compilers: gcc: 10.1.0 
           Shell: bash v: 5.0.18 inxi: 3.0.3

This topic was automatically closed 90 days after the last reply. New replies are no longer allowed.

Forum kindly sponsored by