Some wireless networks not visible

Hello! I'm having trouble with connecting to my wifi. I am able to connect to the internet using cable or my phone's hotspot. So it seems like the card and firmware is working and the problem lies in my router. The router supports only 802.11b/g/n, not 802.11ac.
Using lspci -k command I get

Network controller: Qualcomm Atheros QCA9377 802.11ac Wireless Network Adapter (rev 31)
        Subsystem: Lite-On Communications Inc Qualcomm Atheros QCA9377 802.11ac Wireless Network Adapter
        Kernel driver in use: ath10k_pci
        Kernel modules: ath10k_pci

According to this log the adapter is for ac standard which obviously won't work for me.
Where do I get the right driver and change it?

You are using the correct driver. Your output shows just a human readable name, but the 802.11ac in the name doesn't mean the chip/driver just supports this standard or this is the only standard that can be used.

So since you are using the correct driver, even for 802.11b/g/n, which is the concrete problem you are facing.

So the solution would be to buy a modern router?

No, the driver and your laptop hardware support all protocols up to ac, so it should also work with a b/g/n access point.

There must be something else amiss.

The wifi works and is visible on Windows 10, but not on arch nor Ubuntu on this specific machine. Must be a problem with the card because the wifi can be used on a different machine with Ubuntu. I factory reset the router without any success either.

Alright, fixed it! :smiley:
I followed this https://wiki.archlinux.org/index.php/Network_configuration/Wireless#Respecting_the_regulatory_domain
I set my device to "world regulatory domain", iw reg set 00 and queried with iw list | grep -A 15 Frequencies: resulting:

Frequencies:
                        * 2412 MHz [1] (20.0 dBm)
                        * 2417 MHz [2] (20.0 dBm)
                        * 2422 MHz [3] (20.0 dBm)
                        * 2427 MHz [4] (20.0 dBm)
                        * 2432 MHz [5] (20.0 dBm)
                        * 2437 MHz [6] (20.0 dBm)
                        * 2442 MHz [7] (20.0 dBm)
                        * 2447 MHz [8] (20.0 dBm)
                        * 2452 MHz [9] (20.0 dBm)
                        * 2457 MHz [10] (20.0 dBm)
                        * 2462 MHz [11] (20.0 dBm)
                        * 2467 MHz [12] (disabled)
                        * 2472 MHz [13] (disabled)
                        * 2484 MHz [14] (disabled)
        Band 2:
--
                Frequencies:
                        * 5180 MHz [36] (30.0 dBm) (no IR)
                        * 5200 MHz [40] (30.0 dBm) (no IR)
                        * 5220 MHz [44] (30.0 dBm)
                        * 5240 MHz [48] (30.0 dBm) (no IR)
                        * 5260 MHz [52] (30.0 dBm) (no IR, radar detection)
                        * 5280 MHz [56] (30.0 dBm) (no IR, radar detection)
                        * 5300 MHz [60] (30.0 dBm) (no IR, radar detection)
                        * 5320 MHz [64] (30.0 dBm) (no IR, radar detection)
                        * 5500 MHz [100] (30.0 dBm) (no IR, radar detection)
                        * 5520 MHz [104] (30.0 dBm) (no IR, radar detection)
                        * 5540 MHz [108] (30.0 dBm) (no IR, radar detection)
                        * 5560 MHz [112] (30.0 dBm) (no IR, radar detection)
                        * 5580 MHz [116] (30.0 dBm) (no IR, radar detection)
                        * 5600 MHz [120] (30.0 dBm) (no IR, radar detection)
                        * 5620 MHz [124] (30.0 dBm) (no IR, radar detection)

As the router is using 2.4GHz I noticed that 12-14 channels are disabled and went to the router settings just to find that it was using channel 13 :slight_smile:

Changing to channel 10 (least noice) on router settings made wifi appear on the Network Manager list. Arch wiki is pretty amazing.

This topic was automatically closed 30 days after the last reply. New replies are no longer allowed.

Forum kindly sponsored by