Sometimes the WiFi fails to start with message: "iwlwifi: probe failed with error -110"

Hi everyone. It seems that i have similar problem to this one. But it is not constant: sometimes at the startup my wifi driver not starts and sometimes it starts well. I just reboot the pc most of the time since i have not much time to debug this. I also had this problem on Pop! Os 20. And it seems that now i use the same kernel (LTS) as Pop.

My specs:

System:
  Host: denis-mj Kernel: 5.4.44-1-MANJARO x86_64 bits: 64 compiler: gcc 
  v: 10.1.0 Desktop: Cinnamon 4.6.3 dm: LightDM 1.30.0 Distro: Manjaro Linux 
Machine:
  Type: Laptop System: Micro-Star product: GL63 8RD v: REV:1.0 
  serial: <filter> Chassis: type: 10 serial: <filter> 
  Mobo: Micro-Star model: MS-16P6 v: REV:1.0 serial: <filter> 
  UEFI: American Megatrends v: E16P6IMS.107 date: 09/05/2018 
Battery:
  ID-1: BAT1 charge: 39.7 Wh condition: 40.6/42.4 Wh (96%) volts: 12.2/10.8 
  model: MSI Corp. MS-16P6 type: Li-ion serial: N/A status: Unknown 
CPU:
  Topology: Quad Core model: Intel Core i5-8300H bits: 64 type: MT MCP 
  arch: Kaby Lake rev: A L2 cache: 8192 KiB 
  flags: avx avx2 lm nx pae sse sse2 sse3 sse4_1 sse4_2 ssse3 vmx 
  bogomips: 36812 
  Speed: 900 MHz min/max: 800/4000 MHz Core speeds (MHz): 1: 900 2: 900 
  3: 900 4: 900 5: 900 6: 900 7: 900 8: 900 
Graphics:
  Device-1: Intel UHD Graphics 630 vendor: Micro-Star MSI driver: i915 
  v: kernel bus ID: 00:02.0 chip ID: 8086:3e9b 
  Device-2: NVIDIA GP107M [GeForce GTX 1050 Ti Mobile] driver: N/A 
  bus ID: 01:00.0 chip ID: 10de:1c8c 
  Display: x11 server: X.Org 1.20.8 driver: intel tty: N/A 
  OpenGL: renderer: Mesa Intel UHD Graphics 630 (CFL GT2) v: 4.6 Mesa 20.0.7 
  direct render: Yes 
Audio:
  Device-1: Intel Cannon Lake PCH cAVS vendor: Micro-Star MSI 
  driver: snd_hda_intel v: kernel bus ID: 00:1f.3 chip ID: 8086:a348 
  Sound Server: ALSA v: k5.4.44-1-MANJARO 
Network:
  Device-1: Intel Wireless-AC 9560 [Jefferson Peak] driver: N/A port: 5000 
  bus ID: 00:14.3 chip ID: 8086:a370 
  Device-2: Qualcomm Atheros QCA8171 Gigabit Ethernet vendor: Micro-Star MSI 
  driver: alx v: kernel port: 3000 bus ID: 02:00.0 chip ID: 1969:10a1 
  IF: enp2s0 state: down mac: <filter> 
  IF-ID-1: enp0s20f0u2 state: unknown speed: N/A duplex: N/A mac: <filter> 
Drives:
  Local Storage: total: 931.51 GiB used: 15.61 GiB (1.7%) 
  ID-1: /dev/sda vendor: Western Digital model: WD10SPZX-17Z10T1 
  size: 931.51 GiB speed: 6.0 Gb/s rotation: 5400 rpm serial: <filter> 
  rev: 1A04 scheme: GPT 
Partition:
  ID-1: / size: 109.74 GiB used: 15.58 GiB (14.2%) fs: ext4 dev: /dev/sda5 
  ID-2: swap-1 size: 8.00 GiB used: 0 KiB (0.0%) fs: swap dev: /dev/sda6 
Sensors:
  System Temperatures: cpu: 53.0 C mobo: N/A 
  Fan Speeds (RPM): N/A 
Info:
  Processes: 250 Uptime: 21m Memory: 15.49 GiB used: 2.13 GiB (13.7%) 
  Init: systemd v: 245 Compilers: gcc: N/A Shell: bash v: 5.0.17 
  running in: gnome-terminal inxi: 3.0.37 

Firmware: linux-firmware 20200519.8ba6fa6-1

I tried to restart iwliwifi (modprobe -r iwlwifi; modprobe iwlwifi) twice so in logs there are three errors.

dmesg:

[   11.154218] Intel(R) Wireless WiFi driver for Linux
[   11.154219] Copyright(c) 2003- 2015 Intel Corporation
[   11.154266] iwlwifi 0000:00:14.3: enabling device (0000 -> 0002)
[   11.162911] alx 0000:02:00.0 eth0: Qualcomm Atheros AR816x/AR817x Ethernet [00:d8:61:04:dd:3d]
[   11.261934] iwlwifi: probe of 0000:00:14.3 failed with error -110

[  231.657585] cfg80211: Loading compiled-in X.509 certificates for regulatory database
[  231.657774] cfg80211: Loaded X.509 cert 'sforshee: 00b28ddf47aef9cea7'
[  231.674388] Intel(R) Wireless WiFi driver for Linux
[  231.674389] Copyright(c) 2003- 2015 Intel Corporation
[  231.861571] iwlwifi: probe of 0000:00:14.3 failed with error -110


[  259.499370] cfg80211: Loading compiled-in X.509 certificates for regulatory database
[  259.499502] cfg80211: Loaded X.509 cert 'sforshee: 00b28ddf47aef9cea7'
[  259.515863] Intel(R) Wireless WiFi driver for Linux
[  259.515864] Copyright(c) 2003- 2015 Intel Corporation
[  259.701553] iwlwifi: probe of 0000:00:14.3 failed with error -110

I also tried to update iwlwifi firmware but it seems that i have the last version (it was 34 on the website):

iwlwifi-9000-pu-b0-jf-b0-33.ucode
iwlwifi-9000-pu-b0-jf-b0-34.ucode
iwlwifi-9000-pu-b0-jf-b0-38.ucode
iwlwifi-9000-pu-b0-jf-b0-41.ucode
iwlwifi-9000-pu-b0-jf-b0-43.ucode


Is your bios up to date? If not then it would be a good idea to update it.



Are you dual booting with Windows?



Have you tried kernels 5.6 and 5.7. I would also suggest testing one of the real time kernels as well as several older kernels such as 4.19 and 4.14. Manjaro is capable of having more than one kernel installed at the same time. It is best to always have at least 2 kernels installed (at least one should be an LTS).



Have you tested alternate iwlwifi driver options for improvement? You can test them on the fly to see if different options may help.


Test different iwlwifi driver options:

You can temporarily test different iwlwifi driver options to see if your connectivity improves.

You can change the Intel iwlwifi drivers on the fly via rmmoding and modprobing.

Test one choice of options at a time by entering the following commands in the terminal individually.

Start at the top and work your way down the list, testing your connection for improvement after each change.

sudo lsmod | grep -o -e ^iwlmvm -e ^iwldvm -e ^iwlwifi | xargs sudo rmmod && sleep 3 && sudo modprobe iwlwifi swcrypto=1
sudo lsmod | grep -o -e ^iwlmvm -e ^iwldvm -e ^iwlwifi | xargs sudo rmmod && sleep 3 && sudo modprobe iwlwifi 11n_disable=8
sudo lsmod | grep -o -e ^iwlmvm -e ^iwldvm -e ^iwlwifi | xargs sudo rmmod && sleep 3 && sudo modprobe iwlwifi 11n_disable=1
sudo lsmod | grep -o -e ^iwlmvm -e ^iwldvm -e ^iwlwifi | xargs sudo rmmod && sleep 3 && sudo modprobe iwlwifi swcrypto=1 11n_disable=8
sudo lsmod | grep -o -e ^iwlmvm -e ^iwldvm -e ^iwlwifi | xargs sudo rmmod && sleep 3 && sudo modprobe iwlwifi swcrypto=1 11n_disable=1
sudo lsmod | grep -o -e ^iwlmvm -e ^iwldvm -e ^iwlwifi | xargs sudo rmmod && sleep 3 && sudo modprobe iwlwifi swcrypto=1 11n_disable=1 bt_coex_active=0
sudo lsmod | grep -o -e ^iwlmvm -e ^iwldvm -e ^iwlwifi | xargs sudo rmmod && sleep 3 && sudo modprobe iwlwifi swcrypto=1 11n_disable=8 bt_coex_active=0
sudo lsmod | grep -o -e ^iwlmvm -e ^iwldvm -e ^iwlwifi | xargs sudo rmmod && sleep 3 && sudo modprobe iwlwifi swcrypto=1 11n_disable=1 bt_coex_active=0 power_save=0
sudo lsmod | grep -o -e ^iwlmvm -e ^iwldvm -e ^iwlwifi | xargs sudo rmmod && sleep 3 && sudo modprobe iwlwifi swcrypto=1 11n_disable=8 bt_coex_active=0 power_save=0
sudo lsmod | grep -o -e ^iwlmvm -e ^iwldvm -e ^iwlwifi | xargs sudo rmmod && sleep 3 && sudo modprobe iwlwifi bt_coex_active=0 power_save=0 
sudo lsmod | grep -o -e ^iwlmvm -e ^iwldvm -e ^iwlwifi | xargs sudo rmmod && sleep 3 && sudo modprobe iwlwifi swcrypto=1 11n_disable=8 bt_coex_active=0 power_save=0 
sudo lsmod | grep -o -e ^iwlmvm -e ^iwldvm -e ^iwlwifi | xargs sudo rmmod && sleep 3 && sudo modprobe iwlwifi bt_coex_active=0 power_save=0 d0i3_disable=0 uapsd_disable=0 

Those are some of the most commonly used options to improve connectivity with the iwlwifi driver. There are other options as well, but those are are the options that are commonly the most effective. Those options when executed from the terminal are not permanent. The modified driver option only persists until you reboot. The options can be made permanent by creating a configuration file in /etc/modprobe.d.

To permanently change the driver options, create the file:

/etc/modprobe.d/iwlwifi.conf

You can add any of the following lines to the iwlwifi configuration file to make the option(s) persistent::

options iwlwifi bt_coex_active=0
options iwlwifi bt_coex_active=1
options iwlwifi 11n_disable=1
options iwlwifi 11n_disable=8 
options iwlwifi swcrypto=1
options iwlwifi power_save=0
options iwlmvm power_scheme=1 
options iwlwifi d0i3_disable=1 
options iwlwifi uapsd_disable=1 

1st option: disables Bluetooth compatibility
2nd option: enables Bluetooth compatibility
3rd option: disables wireless N band
4th option enables antenna aggregation
5th option - adds software encryption
6th option - disables adapters power saving
7th option: another way to disable power saving (if also using the iwlmvm module)
8th option: disables the power save mode
9th option: disables the power save mode

Adding a comment ( "# " pound sign) in front of any option disables it. Try any, or all options in different combinations. Simply comment out, or delete any option that doesn’t improve performance. You can also delete the /etc/modprobe.d/iwlwifi.conf file completely if you find it is of no benefit.

Reboot after making any permanent driver option change in /etc/modprobe.d /iwlwifi.conf for the option to take effect.

Hopefully testing some of the available iwlwifi driver options might help improve your connectivity.


If you recieved an error message when running the above commands then you may need to try several different methods to change your options successfully.

If you received the following error:

rmmod: ERROR: missing module name.

Then run the following command:

sudo modprobe iwlwifi

Then execute the list of commands above sequentially to see if modifying your iwlwifi driver options can help improve your WiFi performance.


Revised Commands For Alternate Shells

If you are using a shell other than bash you may have to use a different version of the above commands so they will run successfully.

If you Recieved a list of errors similar to this:

grep: Documents: Is a directory
grep: Downloads: Is a directory
grep: Games: Is a directory

Then you will need to use the modified commands below.

Work your way down the list, running each command individually. Test your connection for improvement after running each command.

sudo -u $USER /bin/sh -lc 'lsmod | grep -o -e ^iwlmvm -e ^iwldvm -e ^iwlwifi | xargs sudo rmmod && sleep 3 && sudo modprobe iwlwifi swcrypto=1' 
sudo -u $USER /bin/sh -lc 'lsmod | grep -o -e ^iwlmvm -e ^iwldvm -e ^iwlwifi | xargs sudo rmmod && sleep 3 && sudo modprobe iwlwifi 11n_disable=8' 
sudo -u $USER /bin/sh -lc 'lsmod | grep -o -e ^iwlmvm -e ^iwldvm -e ^iwlwifi | xargs sudo rmmod && sleep 3 && sudo modprobe iwlwifi 11n_disable=1' 
sudo -u $USER /bin/sh -lc 'lsmod | grep -o -e ^iwlmvm -e ^iwldvm -e ^iwlwifi | xargs sudo rmmod && sleep 3 && sudo modprobe iwlwifi swcrypto=1 11n_disable=8' 
sudo -u $USER /bin/sh -lc 'lsmod | grep -o -e ^iwlmvm -e ^iwldvm -e ^iwlwifi | xargs sudo rmmod && sleep 3 && sudo modprobe iwlwifi swcrypto=1 11n_disable=1' 
sudo -u $USER /bin/sh -lc 'lsmod | grep -o -e ^iwlmvm -e ^iwldvm -e ^iwlwifi | xargs sudo rmmod && sleep 3 && sudo modprobe iwlwifi swcrypto=1 11n_disable=1 bt_coex_active=0' 
sudo -u $USER /bin/sh -lc 'lsmod | grep -o -e ^iwlmvm -e ^iwldvm -e ^iwlwifi | xargs sudo rmmod && sleep 3 && sudo modprobe iwlwifi swcrypto=1 11n_disable=8 bt_coex_active=0' 
sudo -u $USER /bin/sh -lc 'lsmod | grep -o -e ^iwlmvm -e ^iwldvm -e ^iwlwifi | xargs sudo rmmod && sleep 3 && sudo modprobe iwlwifi swcrypto=1 11n_disable=1 bt_coex_active=0 power_save=0' 
sudo -u $USER /bin/sh -lc 'lsmod | grep -o -e ^iwlmvm -e ^iwldvm -e ^iwlwifi | xargs sudo rmmod && sleep 3 && sudo modprobe iwlwifi swcrypto=1 11n_disable=8 bt_coex_active=0 power_save=0' 


Perhaps these kernel boot parameters may help:

ipv6.disable=1 intel_iommu=off

The following command will automatically add the above kernel boot parameter(s) to /etc/default/grub:

sudo cp /etc/default/grub /etc/default/grub.bak && sudo sed '/^GRUB_CMDLINE_LINUX_DEFAULT=/s/"$/ ipv6.disable=1 intel_iommu=off"/g' -i /etc/default/grub

After adding the kernel boot parameter to grub, run:

sudo update-grub 

Then, reboot and test for improvement.


To reverse the grub changes run:

sudo cp /etc/default/grub.bak /etc/default/grub

Then issue sudo update-grub again.



Have you tried other Manjaro DE's from a live boot disk to see if the problem is present on other desktops as well.



On a boot attempt where your wifi is not operational please post:

rfkill list

Also please post the output from a boot where wifi is working as well.

If there is a soft or hard block returned on any of the rfkill commands be sure to post:

lsmod | sort


Consider disabling MAC address randomization in Network Manager with the following command:

echo -e "[device]\nwifi.scan-rand-mac-address=no" | sudo tee /etc/NetworkManager/conf.d/disable-random-mac.conf

Reboot (or restart NM) after creating, modifying, or removing any Network Manager configuration file.

Definitely perform this step if you are dual booting Windows.


If you wish to re-enable MAC randomization you can delete /etc/NetworkManager/conf.d/disable-random-mac.conf (or remove or comment out the conf files contents).



Blacklist Bluetooth (temporarily):

I have left this step until last as many people rely on Bluetooth. Sometimes the Bluetooth module can conflict with WiFi. As a troubleshooting step we will disable the Bluetooth driver module. This step can easily be reversed so please perform this step even if you rely on BT. If you use a Bluetooth keyboard/mouse it would be best to replace them temporarily with USB models.

The following command will automatically generate the conf file required to blacklist bluetooth:

echo "​blacklist btusb" | sudo tee /​etc/modprobe.d/blacklist_btusb.conf.

The blacklist can be reversed by deleting the file /etc/modprobe.d/blacklist_btusb.conf. Alternately place a pound sign if front of "​blacklist btusb" (or delete the contents of the file).



I would not recommend undoing my recommended fixes until you have tested them all. Leave the fixes in place until you have completed testing all my suggestions. Sometimes it takes severeral (or more) of the fixes in combination to effect a cure. Once you have worked through the list if nothing has improved you can consider which changes you want to roll back.

Hopefully some of those suggestions will improve your issue.



1 Like

I have the same problem as well, not just with Manjaro (KDE), but this happens with OpenSuse Tumbleweed(KDE) as well. Checked with the latest versions of both.

I am able to replicate in Dual Boot conditions.

  1. Initiate power down(power switch in SMPS at back or power plug),
  2. Boot to Manjaro, Wifi Works.
  3. Do a reboot(restart from OS without PowerDown) and boot up windows, Wifi works
  4. Now Restart from Windows and Boot to Manjaro : Wifi Disappears in KDE Network Applet.
  5. Shutdown from OS. Then Switch off the SMPS Switch or remove power plug.
  6. Wait for a few seconds to discharge any capacitor charge in SMPS.
  7. Boot to Manjaro : Wifi Works again.

This has something to do with what Windows is doing with the iwlwifi adapter. Seems it may be sending some sleep command that persists across normal reboots(without Power cycle).

In OpenSuse, sometimes when the Wifi Disappears, Wicked is able to get the Wifi Running again, even when the KDE network applet does not show the Wifi option.

rfkill does not show the adapter. And modprobe remove and insert again, generates the error - iwlwifi: probe of xxxxxxxxxxxx(some numbers) failed with error -110

lspci does show the adapter as a recognized hardware.

I am assuming, it could be some power saving flags that windows writes to EEPROM of the network card or somewhere else, that it fails to initialize properly. Elsewhere I have read, the reverse happens, unless people boot to windows, it does not work. In my case, when boot to windows it fails.

If anyone wants my help in debugging this, I am willing to give it a shot. Have windows, Manjaro and Tumbleweed on 3 separate SSDs, so can run tests on both.

Just in case if it helps - My HW has : Ryzen 3700X, Asrock X570 Taichi, GiBy RTX 2060 Super. 32GB RAM

I pretty much wrote out most of the entire troubleshooting book for iwlwifi based adapters on this thread for the OP. In over three weeks time the OP couldn't even be bothered to respond to my post after all the effort I went through. That doesn't exactly make me feel inclined want to help further with this issue.

I would suggest testing my prior suggestions I already documented earlier on this thread.

Good luck resolving your issue.

1 Like

@tbg Your efforts are definitely appreciated by many. This is one of the first search results for the error message and other people like me find it very insightful.

Thank you for taking the time to write up detailed troubleshooting steps.

I can confirm I have the same problem as described by @anandp on similar hardware but different distributions.

This is right after a major Windows update and bios firmware upgrade.

I'll try to see if there's any upstream discussion happening.

Forum kindly sponsored by