Sound only works after installing PulseAudio

I recently installed Manjaro OpenRC edition, but had no sound. (I'm using on-board Intel audio, which I've had working with other linux distros). I checked the modules were installed, used alsamixer (which detected the sound cards perfectly and allowed adjustment of the audio levels - I checked to see if there were any channels muted too :stuck_out_tongue: ), and also selected all of the XFCE volume control outputs in case it was using the wrong one.

I used my google-fu and tried many of the solutions others have tried, and in my desperation I installed the mess known as PulseAudio and PAVUControl and voila! It worked.

(I'm quite used to tracking down issues with Linux installs by the way, though I'm new to Manjaro.)

Has anyone had similar issues? I really really don't want to use PA.

it has been a long time trying to alsa-fu, but here are the problems i faced back then. Not being able to play from multiple apps. If one app didn't exit properly, no sound till reboot. Stuff like that.

Unless you are some music producer, i don't see why you should get rid of pulse.

I do do some music (I use Renoise) but this soundcard just isn't good enough, so I'll stick to using PA then.

Thanks for the reply.

I'm not an expert on alsa btw, just voicing an opinion :slight_smile:
If you wish to alsa-fu for the sake of learning, stick around.

1 Like

Don't let go just yet! You can still make it with alsa (maybe).You can try the instructions from the following link: http://www.troubleshooters.com/linux/void/voidtips.htm
Section: Enable video, sound, Youtube
You should read the next section if you have issues with card monopolization. (There is a typo though ... I think. In the modified ~/.soundrc in line three (3) I think that it should be "dmix" instead of "dmixer". At least that's how it worked for me).
Hope it helps.

PS: If you want to try that route you should remove pulse first.

1 Like

What I've noticed, over and over as applied to Xfce, is a case of the audio simply being muted.

Regards

I thought that might be the case, so I checked it with Alsamixer too. I only get sound when I run pulseaudio (which wasn't installed by default and isn't started by openrc) and pavucontrol.

Im just very disspaointed with the sound quality in Pulseaudio, dont like at all, its flat and not equalized.

Then try jackaudio. How to replace Pulseaudio with Jack, Jack and PulseAudio Together as Friend
:slight_smile:

1 Like

show your /etc/pulse/daemon.conf and which application are you using for playback ?
Also lemme know how much your sound card can handle for bit-depth and bit-rate.

ok here it is:
Configuration file for the PulseAudio daemon. See pulse-daemon.conf(5) for
more information. Default values are commented out. Use either ; or for
commenting.
; daemonize = no
; fail = yes
; allow-module-loading = yes
; allow-exit = yes
; use-pid-file = yes
; system-instance = no
; local-server-type = user
; enable-shm = yes
; shm-size-bytes = 0 # setting this 0 will use the system-default, usually 64 MiB
; lock-memory = no
; cpu-limit = no

; high-priority = yes
; nice-level = -11

; realtime-scheduling = yes
; realtime-priority = 5

exit-idle-time=0
; exit-idle-time = 20
; scache-idle-time = 20

; dl-search-path = (depends on architecture)

; load-default-script-file = yes
; default-script-file = /etc/pulse/default.pa

; log-target = auto
; log-level = notice
; log-meta = no
; log-time = no
; log-backtrace = 0

; resample-method = speex-float-1
; enable-remixing = yes
; enable-lfe-remixing = yes
; lfe-crossover-freq = 120

flat-volumes = no
; flat-volumes = yes

; rlimit-fsize = -1
; rlimit-data = -1
; rlimit-stack = -1
; rlimit-core = -1
; rlimit-as = -1
; rlimit-rss = -1
; rlimit-nproc = -1
; rlimit-nofile = 256
; rlimit-memlock = -1
; rlimit-locks = -1
; rlimit-sigpending = -1
; rlimit-msgqueue = -1
; rlimit-nice = 31
; rlimit-rtprio = 9
; rlimit-rttime = 200000

; default-sample-format = s16le
; default-sample-rate = 44100
; alternate-sample-rate = 48000
; default-sample-channels = 6
; default-channel-map = front-left,front-right

; default-fragments = 4
; default-fragment-size-msec = 25

; enable-deferred-volume = yes
; deferred-volume-safety-margin-usec = 8000
; deferred-volume-extra-delay-usec = 0

the sound card its an HDA ATI SB Realtek alc892

all is running via Pulseaudio as comes in manjaro.

try mine.

resample-method = speex-float-10

flat-volumes = no

default-sample-format = s32ne
default-sample-rate = 48000

This topic was automatically closed 30 days after the last reply. New replies are no longer allowed.

Forum kindly sponsored by