SSD heating

Thanks. I partly did, before writing the post.

This being said, the first link does not say much about 'SSD' or 'Hard Drive' (besides for dual or triple boots, which is not my case) and the second link does not seem extremely relevant (beside it being slightly outdated, it seems to say nothing of heating SSDs).

If the SSD is warm then it is active.

There are various reasons why this might be happening.

For example:

  1. Numerous filesystems defer initialisation operations until a later time. This speeds up the initial "format" and lets the user get on with using the disk.

  2. An file indexer may be running, e.g. tracker or updatedb which is scanning the disk and its content.

You can check what is using your disk with iotop.

However, given you have experienced this already with a different distro it's most likely option 1.

Thread title edited to remove "with Manjaro" as this isn't a Manjaro-specific issue

Thanks for your answer.

Indeed, most processes displayed by 'iotop' show marginal reading, writing or IO ('0%' or '0 B/s' everywhere) -- this was for the second point I guess.

I am not sure how I should understand your understand your first point. What can be done about it?

If it's the filesystem then you simply have to wait.

There's nothing "to be done".

Maybe it is a kernel issue then. Have you tried older kernels?

1 Like

Lack of cooling you should not use a laptop restricting the air flow. also the fan may by full of dust.

I will try other kernel, and post updates.

I tried manjaro with different Kernels: 4.19.69, 4.14.141, 4.9.190, 4.4.190. It seemed to heat, whenever the WiFi was working -- whenever the broadcom 4360 driver was installed.

I reinstalled completely Manjaro, and noted that, when the install was fresh, no updates done and no wifi working, the ssd temperature was good (between 40 and 60 with normal load) -- now I remember that the issues started when I updated the fresh install and installed broadcom-wl (following advices found there: BCM4360 - No wifi in Manjaro Illyria)

Does it sound possible?

The wl drivers have been working better on the newer kernels. I would test out kernels 5.2 and 5.3.

Wifi drivers have been known to create many strange side effects. Broadcom drivers have many strange quirks.

Did you test the brcmfmac kernel driver?


It would be best if you could post your system specs:

inxi -Fxxxz

So it's not the SSD which is heating up, it's the wifi being active which is creating heat.

A number of wifi chipsets are known to create heat so this sounds plausible.

1 Like


  Host: touki-pc Kernel: 4.19.28-1-MANJARO x86_64 bits: 64 compiler: gcc 
  v: 8.2.1 Desktop: Xfce 4.13.2git-UNKNOWN tk: Gtk 3.24.3 info: xfce4-panel 
  wm: xfwm4 dm: LightDM 1.28.0 Distro: Manjaro Linux 
  Type: Laptop System: Apple product: MacBookAir6,2 v: 1.0 serial: <filter> 
  Chassis: type: 10 v: Mac-7DF21CB3ED6977E5 serial: <filter> 
  Mobo: Apple model: Mac-7DF21CB3ED6977E5 v: MacBookAir6,2 serial: <filter> 
  UEFI: Apple v: MBA61.88Z.0099.B20.1509081314 date: 09/08/2015 
  ID-1: BAT0 charge: 33.8 Wh condition: 33.1/54.3 Wh (61%) volts: 8.3/7.6 
  model: SMP bq20z451 type: Li-ion serial: N/A status: Charging cycles: 1212 
  Topology: Dual Core model: Intel Core i5-4250U bits: 64 type: MT MCP 
  arch: Haswell rev: 1 L2 cache: 3072 KiB 
  flags: lm nx pae sse sse2 sse3 sse4_1 sse4_2 ssse3 vmx bogomips: 15204 
  Speed: 800 MHz min/max: 800/2600 MHz Core speeds (MHz): 1: 800 2: 800 
  3: 800 4: 800 
  Device-1: Intel Haswell-ULT Integrated Graphics vendor: Apple driver: i915 
  v: kernel bus ID: 00:02.0 chip ID: 8086:0a26 
  Display: x11 server: X.Org 1.20.4 driver: intel unloaded: modesetting 
  alternate: fbdev,vesa tty: N/A 
  OpenGL: renderer: Mesa DRI Intel Haswell Mobile v: 4.5 Mesa 18.3.4 
  compat-v: 3.0 direct render: Yes 
  Device-1: Intel Haswell-ULT HD Audio vendor: Apple driver: snd_hda_intel 
  v: kernel bus ID: 00:03.0 chip ID: 8086:0a0c 
  Device-2: Intel 8 Series HD Audio driver: snd_hda_intel v: kernel 
  bus ID: 00:1b.0 chip ID: 8086:9c20 
  Device-3: Broadcom and subsidiaries 720p FaceTime HD Camera 
  driver: bdc-pci bus ID: 02:00.0 chip ID: 14e4:1570 
  Sound Server: ALSA v: k4.19.28-1-MANJARO 
  Device-1: Broadcom and subsidiaries BCM4360 802.11ac Wireless Network 
  vendor: Apple driver: bcma-pci-bridge v: N/A port: efa0 bus ID: 03:00.0 
  chip ID: 14e4:43a0 
  IF-ID-1: bnep0 state: unknown speed: N/A duplex: N/A mac: <filter> 
  Local Storage: total: 113.00 GiB used: 47.71 GiB (42.2%) 
  ID-1: /dev/sda vendor: Apple model: SSD SD0128F size: 113.00 GiB 
  speed: 6.0 Gb/s serial: <filter> rev: 821 scheme: GPT 
  ID-1: / size: 110.43 GiB used: 47.71 GiB (43.2%) fs: ext4 dev: /dev/sda2 
  System Temperatures: cpu: 60.0 C mobo: N/A 
  Fan Speeds (RPM): N/A 
  Processes: 186 Uptime: 20h 29m Memory: 3.79 GiB used: 1.76 GiB (46.4%) 
  Init: systemd v: 241 Compilers: gcc: 8.2.1 Shell: bash v: 5.0.0 
  running in: xfce4-terminal inxi: 3.0.32

I am not sure the "brcmfmac" supports the "bcm-4360". I can indeed try more recent kernel.

At the very least you should update your system. It may even be fixed in a newer version of the same kernel series.

I already did -- and it didn't not do anything, rather it was correlated with heating.

This were the specs of a fresh install that is not heating.

1 Like

I don't think that updating is related to enabling your wifi - you said you updated and installed a wifi driver.

Have you looked through the other threads about this wifi chip:


I did. I followed the procedure in one of the post.

Initially : 1) I installed Manjaro, 2) I updated, 3) I installed the WiFi, 4) it started heating, 5) I installed other kernels (previous and next) and it seemed keeping heating whenever the broadcom WiFi kept working (without needing reinstallation, after having switch to another kernel).

I guess will now update Illyrio and see what happens, then I will tinker with broadcom drivers ans see what happens.

It's also worth disabling the wifi connection to narrow that down as the cause.

1 Like

Is it possible you disabled wifi power saving from a recommendation in a help thread. Disabling wifi power saving helps with connectivity problems, but could possibly contribute to an overtemp condition.


The problem is not related to the broadcom driver.

  1. I installed Manjaro Illyrio: no heating,
  2. I update Manjaro (with 'sudo pacman-mirrors -f5 && sudo pacman -Syyu'): ssd heating (sensors show 'TH0A' heating up to 67° with 'iotop' showing almost no activity).

The broadcom driver has not even been installed.

And the wifi state before and after?

This topic was automatically closed 90 days after the last reply. New replies are no longer allowed.

Forum kindly sponsored by