SSDs are suddenly showing as "removable media" in KDE after BIOS update

So I've decided to update my BIOS to fix that RDRand issue related to 3rd gen Ryzen systems because it was getting annoying. Lo' and behold Grub breaks after updating the BIOS and couldn't boot into my installation. Anyways I managed to get into my desktop afterwards and do a sudo update-grub.
However, the issue is that all my SSDs are showing as "removable" after the BIOS update:

[andrew@andrew-pc ~]$ for file in /sys/class/block/*/removable ; do echo $file :$(cat $file); done 
/sys/class/block/loop0/removable :0
/sys/class/block/loop1/removable :0
/sys/class/block/loop2/removable :0
/sys/class/block/loop3/removable :0
/sys/class/block/loop4/removable :0
/sys/class/block/loop5/removable :0
/sys/class/block/loop6/removable :0
/sys/class/block/loop7/removable :0
/sys/class/block/sda/removable :1
/sys/class/block/sdb/removable :1
/sys/class/block/sdc/removable :1

Here's more info about my system:

andrew@andrew-pc ~> inxi -Fxxxz
System:    Host: andrew-pc Kernel: 5.5.11-1-MANJARO x86_64 bits: 64 compiler: gcc v: 9.3.0 
           Desktop: KDE Plasma 5.18.3 tk: Qt 5.14.1 wm: kwin_x11 dm: SDDM Distro: Manjaro Linux 
Machine:   Type: Desktop Mobo: Gigabyte model: X570 GAMING X v: x.x serial: <filter> 
           UEFI: American Megatrends v: F12e date: 03/06/2020 
CPU:       Topology: 8-Core model: AMD Ryzen 7 3700X bits: 64 type: MT MCP arch: Zen L2 cache: 4096 KiB 
           flags: avx avx2 lm nx pae sse sse2 sse3 sse4_1 sse4_2 sse4a ssse3 svm bogomips: 115027 
           Speed: 3586 MHz min/max: 2200/3600 MHz boost: enabled Core speeds (MHz): 1: 3591 2: 2053 3: 2132 
           4: 2132 5: 2060 6: 1870 7: 2754 8: 2058 9: 2053 10: 2049 11: 1862 12: 1861 13: 2486 14: 2013 
           15: 3340 16: 2116 
Graphics:  Device-1: NVIDIA TU106 [GeForce RTX 2060 SUPER] vendor: Gigabyte driver: nvidia v: 430.64 
           bus ID: 07:00.0 chip ID: 10de:1f06 
           Display: x11 server: X.Org 1.20.7 driver: nvidia compositor: kwin_x11 resolution: 1920x1080~60Hz 
           OpenGL: renderer: GeForce RTX 2060 SUPER/PCIe/SSE2 v: 4.6.0 NVIDIA 430.64 direct render: Yes 
Audio:     Device-1: NVIDIA TU106 High Definition Audio vendor: Gigabyte driver: snd_hda_intel v: kernel 
           bus ID: 07:00.1 chip ID: 10de:10f9 
           Device-2: Advanced Micro Devices [AMD] Starship/Matisse HD Audio vendor: Gigabyte 
           driver: snd_hda_intel v: kernel bus ID: 09:00.4 chip ID: 1022:1487 
           Sound Server: ALSA v: k5.5.11-1-MANJARO 
Network:   Device-1: Realtek RTL8111/8168/8411 PCI Express Gigabit Ethernet vendor: Gigabyte driver: r8169 
           v: kernel port: f000 bus ID: 03:00.0 chip ID: 10ec:8168 
           IF: enp3s0 state: up speed: 1000 Mbps duplex: full mac: <filter> 
Drives:    Local Storage: total: 447.15 GiB used: 35.03 GiB (7.8%) 
           ID-1: /dev/sda vendor: Kingston model: SV300S37A120G size: 111.79 GiB speed: 6.0 Gb/s 
           serial: <filter> rev: BBF0 scheme: MBR 
           ID-2: /dev/sdb vendor: Patriot model: Blast size: 111.79 GiB speed: 6.0 Gb/s serial: <filter> 
           rev: 12.2 scheme: MBR 
           ID-3: /dev/sdc vendor: Kingston model: SA400S37240G size: 223.57 GiB speed: 6.0 Gb/s 
           serial: <filter> rev: 5A scheme: MBR 
Partition: ID-1: / size: 51.27 GiB used: 35.03 GiB (68.3%) fs: ext4 dev: /dev/sdb3 
Sensors:   System Temperatures: cpu: 43.5 C mobo: N/A gpu: nvidia temp: 45 C 
           Fan Speeds (RPM): N/A gpu: nvidia fan: 0% 
Info:      Processes: 349 Uptime: 46m Memory: 15.65 GiB used: 3.86 GiB (24.7%) Init: systemd v: 245 
           Compilers: gcc: 9.3.0 alt: 8 clang: 9.0.1 Shell: fish v: 3.1.0 running in: fish inxi: 3.0.37 

Here's an image of how it looks on desktop:image
So how do I gracefully fix this? (how do I make them non-removable again?)

Did you enable hotplugging in the BIOS?

This might actually be feature, not a bug.

2 Likes

Huh apparently that was it. I found the "SATA port hot plug" setting to be enabled for some reason. Maybe it was because the BIOS decided to reset after failing to boot into manjaro and it changed to default settings. The question I have in mind is why was this by default enabled? Anyways, thanks!

This topic was automatically closed 90 days after the last reply. New replies are no longer allowed.

Forum kindly sponsored by