[stable release KDE] 5.2.4-1-MANJARO kernel seems to chokes or has some issues with memory usage

I have just 20 pages opened in 3-4 browsers windows (chrome and firefox) and Videolan running some audio streams or video and system is really choking, lots of scatterings, jams. I'll try the 5.3RC2 kernel and revert back to 5.1 kernel if this newest won't solve the issue, but there's definitelly some issue, even I tried to build some package from AUR which in past went more quickly and with less resources usage now it seems to lasts forever so I need to hard reset the laptop (8 thread intel i5-8250U, 8GB RAM)


Without more information, it's hard to know where to start with help. Please provide more information.


Emphasis with bold is mine...

Are you at all surprised that the system chokes on that? Your system is constantly swapping, and the I/O to and from your swap partition is blocking everything else.

If you want to keep doing that kind of stuff, then you should upgrade your RAM to at least 16 GiB or perhaps even 32 GiB.

5.1 is EOL. It is no longer in the repository.

1 Like

The observations are valid if this happens only with kernel 5.2. If the symptoms don't persist with 5.1 or 5.3rc then it's something in kernel 5.2 (to which the solution may well be "use a different kernel").

@jonathon, I have 8 GiB of RAM too ─ and 6 actual cores ─ and if I have 3 to 4 browser windows open with 20 tabs, then my system will be swapping too, regardless of what kernel I'm using.

As the matter of fact, even with vm.swappiness=0, I've got 1.3 MiB worth of swap in use right now, with only Google Chromium, KMail, Claws Mail (for Usenet) and one Konsole window open. And I have on average 6 to 10 tabs open in that single Chromium window. Not 4 separate browser windows, not 20 tabs and no VideoLan streams.

And when I was compiling the appmenu-enabled version of Firefox from the AUR, my system was locked up solid for 5 hours straight, with all cores maxed out, all of my 8 GiB of RAM in use, and about 8 GiB worth of swap.

There's only so much the machine can take, you know.

1 Like

Can we see the output of these commands:

inxi -Fxxxza
swapon -s

Which package were you trying to build?

1 Like
inxi -Fxxxza
System:    Host: pawel Kernel: 5.2.4-1-MANJARO x86_64 bits: 64 compiler: gcc v: 9.1.0 
           parameters: BOOT_IMAGE=/boot/vmlinuz-5.2-x86_64 root=UUID=5b48e9a4-6204-4334-b415-8c60098ba4c0 rw quiet 
           Desktop: KDE Plasma 5.16.3 tk: Qt 5.13.0 info: latte-dock wm: kwin_x11 dm: SDDM Distro: Manjaro Linux 
Machine:   Type: Laptop System: Acer product: Aspire A517-51G v: V2.02 serial: <filter> 
           Mobo: KBL model: Dragonite_KL v: V2.02 serial: <filter> UEFI: Insyde v: 2.02 date: 01/03/2019 
Battery:   ID-1: BAT1 charge: 47.3 Wh condition: 47.3/48.9 Wh (97%) volts: 16.7/15.2 model: LG 004B384234314341 type: Li-ion 
           serial: <filter> status: Full 
CPU:       Topology: Quad Core model: Intel Core i5-8250U bits: 64 type: MT MCP arch: Kaby Lake family: 6 model-id: 8E (142) 
           stepping: A (10) microcode: B4 L2 cache: 6144 KiB 
           flags: avx avx2 lm nx pae sse sse2 sse3 sse4_1 sse4_2 ssse3 vmx bogomips: 28808 
           Speed: 656 MHz min/max: 400/3400 MHz Core speeds (MHz): 1: 600 2: 600 3: 612 4: 600 5: 600 6: 602 7: 601 8: 600 
           Vulnerabilities: Type: l1tf mitigation: PTE Inversion; VMX: conditional cache flushes, SMT vulnerable 
           Type: mds mitigation: Clear CPU buffers; SMT vulnerable 
           Type: meltdown mitigation: PTI 
           Type: spec_store_bypass mitigation: Speculative Store Bypass disabled via prctl and seccomp 
           Type: spectre_v1 mitigation: __user pointer sanitization 
           Type: spectre_v2 mitigation: Full generic retpoline, IBPB: conditional, IBRS_FW, STIBP: conditional, RSB filling 
Graphics:  Device-1: Intel UHD Graphics 620 vendor: Acer Incorporated ALI driver: i915 v: kernel bus ID: 00:02.0 
           chip ID: 8086:5917 
           Device-2: NVIDIA GP108M [GeForce MX150] driver: N/A bus ID: 01:00.0 chip ID: 10de:1d10 
           Display: x11 server: X.Org 1.20.5 driver: intel compositor: kwin_x11 resolution: 1920x1080~60Hz, 1920x1200~60Hz 
           OpenGL: renderer: Mesa DRI Intel UHD Graphics 620 (Kabylake GT2) v: 4.5 Mesa 19.1.3 compat-v: 3.0 
           direct render: Yes 
Audio:     Device-1: Intel Sunrise Point-LP HD Audio vendor: Acer Incorporated ALI driver: snd_hda_intel v: kernel 
           bus ID: 00:1f.3 chip ID: 8086:9d71 
           Sound Server: ALSA v: k5.2.4-1-MANJARO 
Network:   Device-1: Realtek RTL8111/8168/8411 PCI Express Gigabit Ethernet vendor: Acer Incorporated ALI driver: r8168 
           v: 8.047.02-NAPI port: 3000 bus ID: 02:00.1 chip ID: 10ec:8168 
           IF: enp2s0f1 state: down mac: <filter> 
           Device-2: Qualcomm Atheros QCA9377 802.11ac Wireless Network Adapter vendor: Lite-On driver: ath10k_pci v: kernel 
           port: 3000 bus ID: 03:00.0 chip ID: 168c:0042 
           IF: wlp3s0 state: up mac: <filter> 
Drives:    Local Storage: total: 931.51 GiB used: 76.47 GiB (8.2%) 
           ID-1: /dev/sda vendor: Toshiba model: MQ04ABF100 size: 931.51 GiB block size: physical: 4096 B logical: 512 B 
           speed: 6.0 Gb/s rotation: 5400 rpm serial: <filter> rev: 1J scheme: GPT 
Partition: ID-1: / raw size: 102.05 GiB size: 99.95 GiB (97.94%) used: 76.40 GiB (76.4%) fs: ext4 dev: /dev/sda6 
           ID-2: swap-1 size: 4.65 GiB used: 0 KiB (0.0%) fs: swap swappiness: 10 (default 60) cache pressure: 100 (default) 
           dev: /dev/sda7 
Sensors:   System Temperatures: cpu: 42.0 C mobo: N/A 
           Fan Speeds (RPM): N/A 
Info:      Processes: 254 Uptime: 16m Memory: 7.67 GiB used: 2.63 GiB (34.3%) Init: systemd v: 242 Compilers: gcc: 9.1.0 
           alt: 4.8 clang: 8.0.1 Shell: zsh v: 5.7.1 running in: konsole inxi: 3.0.35
swapon -s
Name                                       Type              Size used          Priority
/dev/sda7                               partition       4879356 0       -2

the package to built is mongodb-compass-beta 1.19.0beta.2-1 or other mongodb it was and I then found already compiled mongodb-bin package from AUR and I probably switched to that instead of waiting to compilation being finished...anyway a painfull process, more than 2 hours and still no finish...

I've tried experimental 5.3 kernel but was already some choking ongoing from the start when the system was loaded and even I couldn't connect to my wifi after typing password (I was redirected to endlessly type the password without the connection being established) so I reverted back to 5.2 kernel and have installed but inactive 5.1 version just in case.

I have no any programs opened and with 5.2 kernel some weird things happens and this choking effect occurs from time to time and it was never like that even with lots of web pages opened or multiple browser windows. I could have chrome, firefox, krita/gimp/inkscape, vlc and some other lite apps opened at the same time with no any issues with efficiency. But now it seems weird vulnerable to use more than a few things or any.

There's no point in spending any more time describing the issue you're having with 5.2.4.

If you're not going to try other kernels (or even update to 5.2.6 via the testing branch) to try and narrow down the issue then any more discussion is pointless.

1 Like

In addition to trying kernel 4.19 as @jonathon suggests, check to make sure baloo isn't compounding your issues with balooctl monitor If baloo is reindexing, that will slow everything down. With your spinning disk and heavy workload, that could put you over the edge.


I was fine without any issue with Kernel 5.x, just recent changes in kernel brought the possible issue as I didn't change anything in system

Just because the kernel changed doesn't mean nothing else changed. Sometimes baloo will start re-indexing after a reboot.

That being said, it is easy enough to test. Make sure your system is up-to-date and switch to kernel 4.19.


5.0? 5.1? 5.2? They are very different kernels, and each series has numerous sub-releases.

1 Like

This topic was automatically closed after 180 days. New replies are no longer allowed.

Forum kindly sponsored by